Machine Virtuelle (VPS) - qemu-guest-agent.service est-il indispensable ?

Demande d'aide : c'est ici.
Répondre
Avatar de l’utilisateur
dezix
Modérateur
Modérateur
Messages : 2057
Inscription : 04 juin 2016, 14:50
Status : Hors-ligne

Bonjour, :006:

Sur un VPS j'ai :

Code : Tout sélectionner

# systemctl status qemu-guest-agent.service
● qemu-guest-agent.service - QEMU Guest Agent
     Loaded: loaded (/lib/systemd/system/qemu-guest-agent.service; static)
     Active: active (running) since Mon 2022-04-04 11:39:38 UTC; 2 weeks 0 days ago
   Main PID: 429 (qemu-ga)
      Tasks: 2 (limit: 2279)
     Memory: 1.9M
        CPU: 3ms
     CGroup: /system.slice/qemu-guest-agent.service
             └─429 /usr/sbin/qemu-ga

Apr 04 11:39:38 vps-1234 systemd[1]: Started QEMU Guest Agent.

Ce service est fourni par le paquet : qemu-guest-agent

Vu la description :
- querying and setting guest system time
- performing guest filesystem sync operation
- initiating guest shutdown or suspend to ram
- accessing guest files
- freezing/thawing guest filesystem operations
- others.

j'ai une forte envie de désactiver le service et supprimer le paquet,

mais j'ai tout de même un doute sur son indispensabilité.

Note : Je suis conscient de l’intérêt que peut avoir ce service pour l'administrateur des VMs sur l'hôte, mais ce n'est pas mon cas.


Avez-vous des infos sur ce sujet ?

Merci.
Debian stable - XFCE
Avatar de l’utilisateur
dezix
Modérateur
Modérateur
Messages : 2057
Inscription : 04 juin 2016, 14:50
Status : Hors-ligne

J'ai oublié de préciser que je n'utilise pas le service "snapshot" proposé par l'hébergeur (OVH)
car dans ce cas, je suppose que le service qemu-guest-agent est nécessaire.
Debian stable - XFCE
Avatar de l’utilisateur
dezix
Modérateur
Modérateur
Messages : 2057
Inscription : 04 juin 2016, 14:50
Status : Hors-ligne

J'ai fait quelques tests pratiques :
  • Arrêt du service
  • Désactivation du service
  • Désinstallation du paquet
  • Réinstallation et réactivation.
Le tout ponctué de redémarrages,
soit directement avec reboot
soit via l'interface web du fournisseur en mode Rescue et Normal

En détails :

Code : Tout sélectionner

# systemctl stop qemu-guest-agent.service


#systemctl status qemu-guest-agent.service
● qemu-guest-agent.service - QEMU Guest Agent
	 Loaded: loaded (/lib/systemd/system/qemu-guest-agent.service; static)
	 Active: inactive (dead) since Thu 2022-04-21 17:55:19 CEST; 1min 11s ago
   Main PID: 419 (code=exited, status=0/SUCCESS)
		CPU: 55ms

Apr 21 17:55:19 vps782741 systemd[1]: Stopping QEMU Guest Agent...
Apr 21 17:55:19 vps782741 systemd[1]: qemu-guest-agent.service: Succeeded.
Apr 21 17:55:19 vps782741 systemd[1]: Stopped QEMU Guest Agent.
Warning: journal has been rotated since unit was started, output may be incomplete.



# systemctl disable qemu-guest-agent.service
Synchronizing state of qemu-guest-agent.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install disable qemu-guest-agent
Après un # reboot

le service était à nouveau actif,
j'ai donc procédé à la suppression du paquet :

Code : Tout sélectionner

# systemctl stop qemu-guest-agent.service
# systemctl disable qemu-guest-agent.service
Synchronizing state of qemu-guest-agent.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install disable qemu-guest-agent
J'ai d'abord supprimé avec :

Code : Tout sélectionner

# apt remove qemu-guest-agent
j'ai fait quelques tests de redémarrage du VPS avec # reboot
et
aussi depuis le tableau de bord sur le site du fournisseur,
qui ont fonctionné avec quelques "bégaiements" => nécessité de passer 2x la demande de redémarrage.

Vu les résultats passables, j'ai purgé le paquet qemu-guest-agent


Les couacs sont devenus plus persistants (nécessité de plusieurs répétitions pour redémarrer)
soit pas pris en compte,
soit SeaBIOS pédale dans la semoule et gel du boot (vu dans la console KVM quand elle parvient à se connecter).


Pour essayer de voir si cela vient d'un problème passager de la plateforme du fournisseur ou des conséquences de mes actions,
j'ai réinstallé et relancé le service,
mais pas d'amélioration notable.

Cela ne me permet pas de conclusions,
car il est possible que l'image d'installation fournisse une configuration "maison"
différente de celle fournie par le paquet debian.

Pour en être certain il faudrait que je réinstalle cette image
pour voir si les choses rentrent dans l'ordre,
et mieux,
faire des comparaisons de fichiers entre versions d'origine et celles réinstallées depuis debian (ça risque d'être assez laborieux).


Voilà,
je vais continuer à creuser un peu le sujet,
mais mis à part ces difficultés erratiques pour redémarrer depuis le tableau de bord OVH,
le système semble tourner rond.

Des suggestions pour vérifier cette dernière supposition "ça tourne rond" ?

@+ pour la suite ...
Debian stable - XFCE
Avatar de l’utilisateur
piratebab
Site Admin
Site Admin
Messages : 3929
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Tente une montée en charge, ou un burn test (mémoire et CPU). C'est normalement fait pour tester le matériel, mais ça permet aussi de voir comment se comporte le systeme avec un CPU ou une mémoire fortement sollicitée
Répondre