libreoffice fait des siennes Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3397
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

22 juil. 2020, 23:58

Hello,
depuis quelque temps libreoffice refuse de démarrer de temps en temps. Je commence à voir le logo, puis plus rien.
Si je le lance en CLI, il ne se lance pas, mais je n'ai rien pas un message.
dmesg: rien sur soffice.
Une idée ou chercher la cause du problème.
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 997
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

23 juil. 2020, 09:35

Salut,

J'utilise peu, mais j'ai souvenir du même genre d'histoire dans le passé....

Regarde du côté de Profil utilisateur LibreOffice — The Document Foundation Wiki

qui débute par :
Résoudre la corruption du profil

Beaucoup de problèmes de LibreOffice peuvent être causés par la corruption du profil utilisateur. Lorsque vous vous rendez compte d'un comportement étrange de LibreOffice, la première chose à faire est de réinitialiser votre profil utilisateur. Pour ce faire, suivez les étapes suivantes.....


Je n'ai pas mieux à t'offrir.

Bonne journée

:006:
Debian testing/stable - XFCE
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3397
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

23 juil. 2020, 11:33

C'est une piste à suivre, je tente ça ce soir.
Qu'est ce que tu utilses pour la bureautique ?
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3397
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

23 juil. 2020, 11:59

J'ai commencé à lire le lien.
Ca commence mal:
LibreOffice 5.3 et versions plus récentes

Lancez LibreOffice et sélectionnez Aide
Pour résoudre un probleme de libreoffice qui ne se lance pas, c'est mal barré!

Je vais tenté en cli
lancez-le via la ligne de commande libreoffice --safe-mode
Tenté en ssh depuis une machine distante, je vois un process libreoffice via htop, c'est encouragent, hier en local je n'avais pas de process libreoffice qui se lançait (sans l'option safe-mode).
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 997
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

23 juil. 2020, 15:37

piratebab a écrit :
23 juil. 2020, 11:33
C'est une piste à suivre, je tente ça ce soir.
Qu'est ce que tu utilses pour la bureautique ?

À dire vrai, je "bureautise" assez peu ... le moins possible ;-)
... avec LibreOffice :

Writer et Calc pour ce qui leur revient quand c'est incontournable.

Sinon, j'utilise principalement Zim, Leafpad et Geany pour tout ce qui est texte.

j'ai eu tenté Abiword et Gnumeric ; le 1er n'a jamais bien fonctionné et le 2d ne m'aura pas convaincu.
C'est pourquoi je conserve LibreOffice.


Question PDF,
j'utilise le plus printer-driver-cups-pdf (p.ex: Zim > Firefox > Print to PDF)
et je passe par Writer si je veux plus de formatage.

Draw me sert très rarement pour retoucher du PDF.

PDFmod pour du montage/découpage ; mupdf ou qpdfview comme visionneuse.

Des présentations,
ça fait longtemps que je n'en ai pas eu à faire => LibreOffice

Voilà ma pauvre expérience, ça ne va pas trop t'inspirer :blush:
Debian testing/stable - XFCE
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3397
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

23 juil. 2020, 19:18

C'était bien ça, j'ai démarrer en mode sans échec, demandé à utiliser la dernière configuration connue, , sauver les modifications et redémarrer.
Merci Dezix

Nota: lorsque j'ai démarré en CLI sans échec, j'avais cette erreur
XSetErrorHandler() called with a GDK error trap pushed. Don't do that
Répondre