Versions de Certbot "incohérentes"

Demande d'aide : c'est ici.
Répondre
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3031
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

16 janv. 2020, 13:17

Salut,

J'ai reçu un mail ce matin de Lets Encrypt me mettant en garde sur la nécessité de mettre à jour mon client;
According to our records, the software client you're using to get Let's
Encrypt TLS/SSL certificates issued or renewed at least one HTTPS certificate
in the past two weeks using the ACMEv1 protocol. Your client's IP address was:
etc.
La machine en question est sous Stretch (oldstable).
Ni une ni deux, J'ai mis à jour Certbot vers Buster:

Code : Tout sélectionner

# apt install certbot -t stable
Je suis donc maintenant avec la version Certbot 0.31 de apt, et le binaire de certbot est d'accord avec ça...

Code : Tout sélectionner

# apt-cache policy certbot | grep -i Installé
  Installé : 0.31.0-1
# certbot --version
certbot 0.31.0
Par curiosité je suis allé voir une autre machine (elle aussi sous Stretch), et là... petite surprise...

Code : Tout sélectionner

# apt-cache policy certbot | grep -i Installé
  Installé : 0.28.0-1~deb9u2
# certbot --version
certbot 1.1.0
:017:

Auriez-vous une idée du pourquoi ?
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Répondre