[TESTING] Virtualbox - Connexion PC hôte → VM Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Avatar du membre
dezix
Membre
Membre
Messages : 465
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

03 déc. 2019, 22:03

Bonjour,

Lorsque je tente d'accéder du PC aux VMs (locales) par ssh
ou http (via un navigateur pour afficher les sites hébergés sur VM)
10.0.0.2 (adresse de l'interface virtuelle vboxnet0 ) est redirigé sur le localhost du PC

Avant, cela fonctionnait parfaitement,
enfin je crois (je ne suis plus sûr de rien :(( )


J'ai pensé que c'était suite au passage de testing au noyau 5.3

je suis donc revenu à 5.2 via le menu de GRUB ; j'ai du réinstaller virtualbox-dkms
mais cela n'a rien arrangé.

Voilà, je ne comprends pas pourquoi cette "redirection".

Autre fait qui me laisse dubitatif :

Après : $ sudo ifconfig vboxnet0 down

$ lynx 10.0.0.2
continue à afficher index.html du serveur local du PC


ÉDITÉ : Un exposé clair de "Comment créer un Réseau local virtuel" est placé en 2ème postage




Pour documenter la situation :


Côté PC (Hôte)

Code : Tout sélectionner

$ uname -r
5.3.0-2-amd64

Code : Tout sélectionner

$ dpkg-query -l | grep virtualbox
ii  virtualbox                           6.0.14-dfsg-3                   amd64        x86 virtualization solution - base binaries
ii  virtualbox-dkms                      6.0.14-dfsg-3                   all          x86 virtualization solution - kernel module sources for dkms
ii  virtualbox-ext-pack                  6.0.14-1                        all          extra capabilities for VirtualBox, downloader.
ii  virtualbox-guest-additions-iso       6.0.10-1                        all          guest additions iso image for VirtualBox
ii  virtualbox-guest-dkms                6.0.14-dfsg-3                   all          x86 virtualization solution - guest addition module source for dkms
ii  virtualbox-guest-utils               6.0.14-dfsg-3                   amd64        x86 virtualization solution - non-X11 guest utilities
ii  virtualbox-guest-x11                 6.0.14-dfsg-3                   amd64        x86 virtualization solution - X11 guest utilities
ii  virtualbox-qt                        6.0.14-dfsg-3                   amd64        x86 virtualization solution - Qt based user interface

Code : Tout sélectionner

$ cat /etc/hosts
127.0.0.1	localhost
127.0.1.1	nuc6
127.0.1.1	fluxbb.local

# VM de VirtualBox
#  Utiliser 10.0.0.2 pour tous les domaines sur debwebserv1
 10.0.0.2	debwebserv1.virt	debwebserv1
#10.0.0.2	forum1.virt
#  Utiliser 10.0.0.3 pour tous les domaines sur debwebserv2
#10.0.0.3	debwebserv2.virt	debwebserv2

192.168.1.1	livebox.dezorg	livebox

192.168.1.10	nuc6.dezorg	nuc6
192.168.1.11	dc7800.dezorg	dc7800
192.168.1.12	one-dezix.dezorg	one-dezix

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Au démarrage du PC (Virtualbox n'est pas lancé)

Code : Tout sélectionner

$ sudo ifconfig
enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.10  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 2a01:cb00:8a54:8c00:25c0:c827:fb5f:f5e7  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::96c6:91ff:fea9:d1c6  prefixlen 64  scopeid 0x20<link>
        inet6 2a01:cb00:8a54:8c00:96c6:91ff:fea9:d1c6  prefixlen 64  scopeid 0x0<global>
        ether 94:c6:91:a9:d1:c6  txqueuelen 1000  (Ethernet)
        RX packets 331  bytes 123036 (120.1 KiB)
        RX errors 0  dropped 20  overruns 0  frame 0
        TX packets 408  bytes 185438 (181.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 4  bytes 156 (156.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 156 (156.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
et

$ sudo ifconfig -a

affiche en plus l'interface sans fil (inutilisée) : wlp2s0

À ce stade (virtualbox non-démarré),

$ lynx 10.0.0.2
et
$ ssh 10.0.0.2

ne parviennent pas à se connecter (c'est normal)



Après avoir lancé VirtualBox (GUI)

Code : Tout sélectionner


$ sudo ifconfig
enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.10  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 2a01:cb00:8a54:8c00:25c0:c827:fb5f:f5e7  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::96c6:91ff:fea9:d1c6  prefixlen 64  scopeid 0x20<link>
        inet6 2a01:cb00:8a54:8c00:96c6:91ff:fea9:d1c6  prefixlen 64  scopeid 0x0<global>
        ether 94:c6:91:a9:d1:c6  txqueuelen 1000  (Ethernet)
        RX packets 647  bytes 164864 (161.0 KiB)
        RX errors 0  dropped 76  overruns 0  frame 0
        TX packets 755  bytes 262917 (256.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 4  bytes 156 (156.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 156 (156.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Code : Tout sélectionner

$ sudo ifconfig -a
enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.10  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 2a01:cb00:8a54:8c00:25c0:c827:fb5f:f5e7  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::96c6:91ff:fea9:d1c6  prefixlen 64  scopeid 0x20<link>
        inet6 2a01:cb00:8a54:8c00:96c6:91ff:fea9:d1c6  prefixlen 64  scopeid 0x0<global>
        ether 94:c6:91:a9:d1:c6  txqueuelen 1000  (Ethernet)
        RX packets 661  bytes 166272 (162.3 KiB)
        RX errors 0  dropped 78  overruns 0  frame 0
        TX packets 771  bytes 267540 (261.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 4  bytes 156 (156.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 156 (156.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vboxnet0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 0a:00:27:00:00:00  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 96:ea:e6:23:3c:a2  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

$ lynx 10.0.0.2
et
$ ssh 10.0.0.2

ne parviennent toujours pas à se connecter.


VM = DebWebServ1
Debian stable

Code : Tout sélectionner

toto@debwebserv1:~$ uname -r
4.19.0-6-amd64
pasted_image.png
Si j'ai bien compris :
* interface1 => Extérieur (Internet)
* interface2 => Réseau virtuel VMs & PC hôte


Après démarrage de la VM : DebWebServ1

Le PC redirige 10.0.0.2 sur son localhost

HTTP

$ lynx 10.0.0.2

affiche : index.html
du serveur local du PC

et

SSH

Code : Tout sélectionner

$ ssh 10.0.0.2
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
SHA256:omTC/ltQ+LlOG7NwB5UundpzMOY4e/C8PQwW5NC3dUk.
Please contact your system administrator.
Add correct host key in /home/dezix/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /home/dezix/.ssh/known_hosts:6
  remove with:
  ssh-keygen -f "/home/dezix/.ssh/known_hosts" -R "10.0.0.2"
ECDSA host key for 10.0.0.2 has changed and you have requested strict checking.
Host key verification failed.
Si on poursuit avec :
ssh-keygen -f "/home/dezix/.ssh/known_hosts" -R "10.0.0.2"

on parvient même à se connecter (en boucle) sur le compte utilisateur du PC avec : ssh dezix@10.0.0.2

On a à présent :

Code : Tout sélectionner

$ sudo ifconfig
enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.10  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::96c6:91ff:fea9:d1c6  prefixlen 64  scopeid 0x20<link>
        inet6 2a01:cb00:8a54:8c00:96c6:91ff:fea9:d1c6  prefixlen 64  scopeid 0x0<global>
        inet6 2a01:cb00:8a54:8c00:71d6:d15e:8d7e:2062  prefixlen 64  scopeid 0x0<global>
        ether 94:c6:91:a9:d1:c6  txqueuelen 1000  (Ethernet)
        RX packets 408  bytes 131990 (128.8 KiB)
        RX errors 0  dropped 38  overruns 0  frame 0
        TX packets 512  bytes 215772 (210.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 44  bytes 12971 (12.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 44  bytes 12971 (12.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vboxnet0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.2  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 fe80::800:27ff:fe00:0  prefixlen 64  scopeid 0x20<link>
        ether 0a:00:27:00:00:00  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 92  bytes 11763 (11.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Avec :
vboxnet0: inet 10.0.0.2

qui reste identique après arrêt de la VM et [Ctrl+Q] sur la GUI de VBox


Côté VM

Code : Tout sélectionner

toto@debwebserv1:~$ cat /etc/hosts
127.0.0.1	localhost
127.0.1.1	debwebserv1.virt	debwebserv1

# Others VM vbox
10.0.2.4	deb9lxde.virt	deb9lxde

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Code : Tout sélectionner

toto@debwebserv1:~$ sudo ifconfig
[sudo] Mot de passe de toto : 
enp0s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.2.6  netmask 255.255.255.0  broadcast 10.0.2.255
        inet6 fe80::a00:27ff:fefa:7813  prefixlen 64  scopeid 0x20<link>
        ether 08:00:27:fa:78:13  txqueuelen 1000  (Ethernet)
        RX packets 27  bytes 7882 (7.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 60  bytes 7762 (7.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp0s8: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.2  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 fe80::a00:27ff:fe39:e259  prefixlen 64  scopeid 0x20<link>
        ether 08:00:27:39:e2:59  txqueuelen 1000  (Ethernet)
        RX packets 72  bytes 13104 (12.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 38  bytes 4722 (4.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  base 0xd240  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 40  bytes 13526 (13.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 40  bytes 13526 (13.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Pour info :

toto@debwebserv1:~$ sudo ifconfig -a

renvoie la même chose.



Les commandes suivantes :

toto@debwebserv1:~$ lynx 10.0.0.2
toto@debwebserv1:~$ lynx localhost
toto@debwebserv1:~$ lynx http://debwebserv1.virt

fonctionnent parfaitement en affichant : index.html du serveur local de la VM.

et

toto@debwebserv1:~$ lynx 192.168.1.10

Affiche : index.html
du serveur local du PC.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Merci d'avance pour vos avis.
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Debian testing/stable - XFCE
Avatar du membre
dezix
Membre
Membre
Messages : 465
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

10 déc. 2019, 00:44

EURÊKA !

Une fois de plus je me suis bien compliqué l'existence,
car j'étais passé à côté de l'essentiel :diablo:

Alors pour ceux qui auront la bonne idée de passer par ici,
je "résume" l'histoire en donnant la solution sous forme de tuto. :yahoo:

D'abord le but recherché

Créer un réseau local virtuel entre l'Hôte (notre PC qui fait tourner Virtualbox)
et les VM (machines virtuelles)

Cela (dans mon cas) pour utiliser des VM "serveur"
afin de simuler un hébergement distant
pour développer des sites web dans des conditions assez similaires à la réalité
sur un vrai serveur (distant) connecté à Internet.

Principe mise en place du réseau
Ce que j'ai eu du mal à comprendre

Virtualbox (plateforme de virtualisation)
permet de créer sur le PC (hôte) physique des cartes réseau virtuelles.

C'est à dire que l'on rajoute une interface réseau (virtuelle) à notre PC,
qui va être utilisée par l'utilisateur du PC (moi)
pour se connecter aux machines virtuelles
qui auront été configurées pour ce réseau local virtuel.

Le réseau virtuel est donc composé du PC et d'au moins une VM

Voilà pour le principe de base.
À ce stade, je ne me suis pas penché sur la possibilité (ou non) de créer plusieurs réseaux virtuels distincts.


Passons maintenant à la pratique
comme je ne suis pas rompu à l'utilisation de vbox en ligne de commande,
tout ce qui suit, est réalisé dans l'interface graphique de Virtualbox (gui vbox).


Voici le réseau que je vais mettre en place

Image

Création de l'interface virtuelle sur le PC (hôte)

Dans gui vbox,
[Ctrl+H] ouvre le gestionnaire de réseau hôte

Créer
Si c'est la 1ère interface créée elle est nommée : vboxnet0
Cocher Configurer manuellement
et configurer comme suit :

Interface
  • IPv4 : 10.0.0.1
  • Masque IPv4 : 255.255.255.0
  • IPv6 : laisser la valeur pré-assignée
  • longueur préfixe : 64
Server DHCP
  • Cocher Activer
  • Adresse serveur : 10.0.0.100
  • Masque serveur : 255.255.255.0
  • Limite inférieure : 10.0.0.101
  • Limite supérieure : 10.0.0.254
puis Appliquer

ce qui donne les captures suivantes :

Image

Image



à ce stade l'interface est créée,

les commandes :

$ sudo ifconfig -a
et
ls /proc/net/dev_snmp6/

montre bien : vboxnet0



Il faut maintenant ajouter les VM au réseau.

J'ai donc déjà créé mes 2 serveurs virtuels (debian)
  • debwebserv1
  • debwebserv2
VM arrêtée

La configuration se fait par l'interface de configuration de la VM sélectionnée dans la liste :

Configuration ( ou [Ctrl+S] ) > Réseau

Par défaut Interface 1 est déjà configurée en Réseau NAT ; elle permet l'accès à Internet

Image

Normalement cela fonctionne dès la création de la VM,
donc on n'y touche pas.

On va activer l'Interface 2 pour donner accès au réseau virtuel basé sur vboxnet0
pour cela :
  • Cocher Activer
  • Sélectionner le mode : Réseau privé hôte
  • dans ce mode on choisit (Nom) : vboxnet0
  • Le type d'interface PCnet-FAST III est recommandée pour Linux mais les autres types doivent aussi fonctionner
  • Promiscuité : indifférente (à vérifier)
  • MAC par défaut ou nouvelle aléatoire si nécessaire
  • Câble branché (coché)
ça donne :

Image

les 2 VM sont configurées à l'identique avec des MAC différentes

Il faut ensuite Lancer les VM et configurer leurs interfaces avec p.ex :

$ sudo nano /etc/network/interfaces

pour obtenir quelque-chose dans ce genre :

Code : Tout sélectionner

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug enp0s3
iface enp0s3 inet dhcp


# Carte réseau N°2 activée par toto
auto enp0s8
iface enp0s8 inet static
        address 10.0.0.2
        netmask 255.255.255.0

la commande :

ls /proc/net/dev_snmp6/

permet de vérifier le nom des interfaces existantes.

Dans le schéma du réseau joint au début de cet exemple les IP du réseau sont :
  • 10.0.0.1 pour le PC → vboxnet0
  • 10.0.0.2 pour la VM 1 → debwebserv1
  • 10.0.0.3 pour la VM 2 → debwebserv2
Ici j'ai opté pour des IP static car c'est ce que je sais faire
et qui me semble le plus simple d'utilisation.

Une fois le fichier /etc/network/interfaces enregistré,

il faudra redémarrer le service réseau pour que la config soit prise en compte,
avec :

$ sudo systemctl restart networking.service


On refait la même opération sur la VM 2 en lui assignant : 10.0.0.3

Maintenant, si tout s'est bien passé,
les VM devraient être accessibles depuis le PC avec respectivement :
  • 10.0.0.2 pour la VM 1 → debwebserv1
  • 10.0.0.3 pour la VM 2 → debwebserv2
p.ex : $ ssh toto@10.0.0.2
ou
avec : $ lynx 10.0.0.3

à condition que le serveur SSH soit fonctionnel sur VM 1
et qu'un serveur HTTP soit opérationnel sur VM 2



Pour finir et si on veut pouvoir accéder aux sites web servis par les VM
depuis un navigateur tournant sur le PC,

alors sur le PC on pourra éditer : /etc/hosts

en ajoutant des lignes correspondant aux domaines des sites p.ex :

Code : Tout sélectionner

# VM de VirtualBox
#  Utiliser 10.0.0.2 pour tous les domaines sur debwebserv1
10.0.0.2	debwebserv1.virt	debwebserv1
10.0.0.2	forum1.virt	forum1
10.0.0.2	forum2.virt	forum2

#  Utiliser 10.0.0.3 pour tous les domaines sur debwebserv2
10.0.0.3	debwebserv2.virt	debwebserv2
10.0.0.3	site-perso.virt	site-perso

Ce qui permet de passer ces adresses directement dans le navigateur p.ex:

$ lynx http://site-perso.virt

pour avoir un aperçu du résultat.





:006:
Debian testing/stable - XFCE
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2941
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

10 déc. 2019, 07:59

J'ai bien lu "tuto" ? :)
C'est un candidat pour le wiki ça ..
Merci pour ce retour
Avatar du membre
dezix
Membre
Membre
Messages : 465
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

10 déc. 2019, 09:27

Salut, Pirate !

Oui, j'y pense ... au wiki
j'ai déjà une petite file d'attente pour lui :wacko:

Sinon, rapport au forum,
c'est normal d'être limité à 3 pièces jointes / affichées ?

Je mettrai bien ces images sur Framapic mais dans 1 an elles seront perdues :((

Pour ce cas particulier, je vais les mettre sur le wiki ; on doit pouvoir mettre un lien ici.

Mais dans le cas général, que faire ?
Debian testing/stable - XFCE
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2941
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

10 déc. 2019, 09:56

Nous sommes gracieusement hébergé par tuxfamily, mais l'espace de stockage est limité. Il faut privilégier le stockage externe pour les images à durée de vie limitées, et limiter l'hébergement en interne sur les images destinées à rester plus logtemps (tuto, wiki).
Un hébergeur externe peux effectivement disparaitre du jour au lendemain, et l'accés aux images hébergées est perdu (voir la disparition récente et subite de tinypics).
Avatar du membre
dezix
Membre
Membre
Messages : 465
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

10 déc. 2019, 10:22

Message reçu !

Merci
Debian testing/stable - XFCE
Avatar du membre
dezix
Membre
Membre
Messages : 465
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

10 déc. 2019, 18:29

Pour les 2 dernières images j'ai utilisé : http://pix.toile-libre.org
en espérant que cela soit un bon choix.
Debian testing/stable - XFCE
Répondre