[Testing] Qutebrowser : Dictionnaire de vérification orthographique Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Avatar du membre
dezix
Membre
Membre
Messages : 371
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

10 oct. 2018, 15:36

Agil comme la méthode !

Comme quoi :

1. il ne faut pas baisser les bras
2. la coopération -> ça fonctionne :023:
Debian testing/stable - XFCE
--gilles--
Membre
Membre
Messages : 453
Enregistré le : 24 août 2016, 19:35
Status : Hors ligne

10 oct. 2018, 15:53

J'ai fait le :set spellcheck.languages, il m'a proposé : fr-FR, en-US, j'ai fait Entrée, mais je ne constate pas d'effet quand je tape en ligne avec qutebrowser.
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell
Avatar du membre
dezix
Membre
Membre
Messages : 371
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

11 oct. 2018, 09:26

Ayant des problèmes avec la VM,
j'ai fait le test sur mon installation fixe


Résultat et solution

Sur la page : https://github.com/qutebrowser/qutebrow ... dictcli.py

J'ai copié le contenu du fichier ( à cette date : les versions des branches master et 1.5.xx sont identiques )


j'ai collé ce contenu dans un nouveau fichier avec Geany,
j'ai vérifié qu'il était en UTF-8 et indiqué que c'était un script en python.

Puis je l'ai enregistré comme :

~/.local/share/qutebrowser/scripts/dictcli.py

Ensuite dans le terminal :


$ cd ~/.local/share/qutebrowser/scripts

Code : Tout sélectionner

	$ python3 dictcli.py
		usage: dictcli [-h] {list,update,remove-old,install} ...
		dictcli: error: the following arguments are required: cmd
=> Affiche le mode d'emploi


$ python3 dictcli.py list
=> Affiche la liste des dictionnaires disponibles (voir #20 de Gille)

Installation des dictionnaires :

Français

Code : Tout sélectionner

	
	$ python3 dictcli.py  install fr-FR
			Installing fr-FR: French (France)
		/home/lionux/.local/share/qutebrowser/qtwebengine_dictionaries does not exist, creating the directory
		Downloading https://chromium.googlesource.com/chromium/deps/hunspell_dictionaries.git/+/master/fr-FR-3-0.bdic?format=TEXT
		Done.
Anglais

Code : Tout sélectionner

	$ python3 dictcli.py  install en-EN
		invalid languages: en-EN
=> il faut choisir dans la liste ! ;-)

Code : Tout sélectionner

	$ python3 dictcli.py  install en-GB
		Installing en-GB: English (United Kingdom)
		Downloading https://chromium.googlesource.com/chromium/deps/hunspell_dictionaries.git/+/master/en-GB-8-0.bdic?format=TEXT
		Done.


	$ python3 dictcli.py  install en-US
		Installing en-US: English (United States)
		Downloading https://chromium.googlesource.com/chromium/deps/hunspell_dictionaries.git/+/master/en-US-8-0.bdic?format=TEXT
		Done.

Les dictionnaires sont dans :

~/.local/share/qutebrowser/qtwebengine_dictionaries


En redémarrant le navigateur, les messages (orange) indiquant l'absence des dictionnaires ont disparu

et la vérification FONCTIONNE !

=> On va pouvoir continuer à user le i et le Echap :icon_e_geek:
Debian testing/stable - XFCE
Avatar du membre
dezix
Membre
Membre
Messages : 371
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

11 oct. 2018, 12:15

J'ai reçu une réponse au mail envoyé à l'équipe qui maintient le paquet,
il s'agit d'un oubli.

Les scripts seront inclus dans le futur
et
il est proposé de faire ce qui est décrit plus haut
-> récupérer les scripts sur GitHub
en attendant la correction.
Debian testing/stable - XFCE
--gilles--
Membre
Membre
Messages : 453
Enregistré le : 24 août 2016, 19:35
Status : Hors ligne

11 oct. 2018, 19:41

1] À la ligne 23 du script dictcli.py tu as :
python -m scripts.dictcli [-h] {list,update,remove-old,inst}

Si tu te mets dans le répertoire de dictcli.py et et si tu tapes :python -m scripts.dictcli -h qu'est-ce tu obtiens ?


2]
Ma version de qutebrowser $ qutebrowser -V
qutebrowser v1.5.0
Git commit:
Backend: QtWebEngine (Chromium 65.0.3325.230)

CPython: 3.6.6
Qt: 5.11.1
PyQt: 5.11.2

sip: 4.19.13
colorama: 0.3.7
pypeg2: 2.15
jinja2: 2.10
pygments: 2.2.0
yaml: 3.12
cssutils: 1.0.2 $Id$
attr: 17.4.0
PyQt5.QtWebEngineWidgets: yes
PyQt5.QtWebKitWidgets: yes
pdf.js: no
sqlite: 3.25.2
QtNetwork SSL: OpenSSL 1.1.0h 27 Mar 2018

Style: QFusionStyle
Platform: Linux-4.18.0-1-amd64-x86_64-with-debian-buster-sid, 64bit
Linux distribution: Debian GNU/Linux buster/sid (debian)
Frozen: False
Imported from /usr/lib/python3/dist-packages/qutebrowser
Using Python from /usr/bin/python3
Qt library executable path: /usr/lib/x86_64-linux-gnu/qt5/libexec, data path: /usr/share/qt5

Paths:
cache: /home/utilisateur100/.cache/qutebrowser
config: /home/utilisateur100/.config/qutebrowser
data: /home/utilisateur100/.local/share/qutebrowser
runtime: /run/user/1000/qutebrowser
system data: /usr/share/qutebrowser

Uptime: 0:00:00
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell
Avatar du membre
dezix
Membre
Membre
Messages : 371
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

11 oct. 2018, 21:16

Code : Tout sélectionner

$ cd ~/.local/share/qutebrowser/scripts

$ python -m scripts.dictcli -h
/usr/bin/python: No module named scripts
mais je ne comprends pas pourquoi tu utilises scripts.dictcli :017:
Debian testing/stable - XFCE
Avatar du membre
dezix
Membre
Membre
Messages : 371
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

11 oct. 2018, 21:29

dans le navigateur, la commande c'est p.ex :

:set spellcheck.languages "['fr-FR', 'en-US']"

Il faut préciser la(es) langue(s) que tu veux activer .


et dans : ~/.local/share/qutebrowser/qtwebengine_dictionaries

tu as tes dicos ?
Debian testing/stable - XFCE
Avatar du membre
dezix
Membre
Membre
Messages : 371
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

11 oct. 2018, 21:34

le résultat de l'activation est dans : ~/.config/qutebrowser/autoconfig.yml

qui contient (dans mon cas)

Code : Tout sélectionner

# DO NOT edit this file by hand, qutebrowser will overwrite it.
# Instead, create a config.py - see :help for details.

config_version: 2
settings:
  aliases:
    global:
      q: quit
      w: session-save
      wq: quit --save
  scrolling.bar:
    global: true
  scrolling.smooth:
    global: true
  spellcheck.languages:
    global:
    - fr-FR
    - en-US

Debian testing/stable - XFCE
Avatar du membre
dezix
Membre
Membre
Messages : 371
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

11 oct. 2018, 21:54

une grauss fôte d'autograffe esce que çai sufisent ? :)))
j'ai fait de mon mieux pour te faire voir le résultat :003:
Image
Debian testing/stable - XFCE
Avatar du membre
dezix
Membre
Membre
Messages : 371
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

11 oct. 2018, 23:39

Gilles ça y est, je vois d'où vient ta confusion !

Effectivement dans le script à la ligne 23 on a :

Code : Tout sélectionner

"""A script installing Hunspell dictionaries.
Use: python -m scripts.dictcli [-h] {list,update,remove-old,install} ...
"""
C'est la chaîne "docstring" qui sert de documentation dans python,
et qui est produit ce genre de sortie :

Code : Tout sélectionner

$ python3 dictcli.py
		usage: dictcli [-h] {list,update,remove-old,install} ...
		dictcli: error: the following arguments are required: cmd

Celle de la ligne 23 date peut-être et n'aurait pas été mise à jour ???

Une chose est certaine => le script que nous avons placé se nomme dictcli.py
c'est donc ce nom qui doit être passé pour lancer le script....

Voilà je pense que l'explication est là,
tu auras fait des copier/coller
ou une fixette sur cette ligne 23 :biggrin:
Debian testing/stable - XFCE
--gilles--
Membre
Membre
Messages : 453
Enregistré le : 24 août 2016, 19:35
Status : Hors ligne

12 oct. 2018, 07:02

dezix a écrit :
11 oct. 2018, 21:16

Code : Tout sélectionner

$ cd ~/.local/share/qutebrowser/scripts

$ python -m scripts.dictcli -h
/usr/bin/python: No module named scripts
mais je ne comprends pas pourquoi tu utilises scripts.dictcli :017:
J'ai lu cette ligne de commande dans le script et je l'ai essayé et comme elle renvoie une erreur j'ai pensé que c'est la cause du non-fonctionnement, mais comme tu l'as aussi, ce n'est pas cela ! Bon, bien cela fonctionne aujourd'hui suite à une mise à jour ! :icon_e_biggrin:
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell
--gilles--
Membre
Membre
Messages : 453
Enregistré le : 24 août 2016, 19:35
Status : Hors ligne

12 oct. 2018, 07:09

dezix a écrit :
11 oct. 2018, 21:29
dans le navigateur, la commande c'est p.ex :

:set spellcheck.languages "['fr-FR', 'en-US']"

Il faut préciser la(es) langue(s) que tu veux activer .


et dans : ~/.local/share/qutebrowser/qtwebengine_dictionaries

tu as tes dicos ?
~/.local/share/qutebrowser/qtwebengine_dictionaries$ ls -ail

total 1500
4064937 drwxr-xr-x 2 utilisateur100 utilisateur100 4096 oct. 11 19:53 .
3804485 drwx------ 9 utilisateur100 utilisateur100 4096 oct. 12 06:55 ..
4064938 -rw-r--r-- 1 utilisateur100 utilisateur100 446642 oct. 11 19:53 en-US-8-0.bdic
4064939 -rw-r--r-- 1 utilisateur100 utilisateur100 1074744 oct. 11 19:53 fr-FR-3-0.bdic
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell
--gilles--
Membre
Membre
Messages : 453
Enregistré le : 24 août 2016, 19:35
Status : Hors ligne

12 oct. 2018, 07:21

elle renvoit des enzimes gloutoms dant la lecive


Image

Je devais avoir des paquets python pas à jour, c'est une hypothèse pour expliquer pourquoi cela ne fonctionnait pas hier et que cela fonctionne aujourd'hui.
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell
Avatar du membre
dezix
Membre
Membre
Messages : 371
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

12 oct. 2018, 09:50

À Gilles :icon_cool: Content que cela fonctionne aussi pour toi !

À présent que l'activation se fait :

Reste la question de la désactivation :icon_e_geek:

=> il suffit de repasser la commande :setspellcheck.languages "[<paramètres>]"

en indiquant soit la/les langues voulues, soit en laissant les crochets vides pour désactiver toutes les langues :biggrin:

Les modifications sont prises en compte immédiatement par le navigateur.

Cette commande modifie le fichier : ~/.config/qutebrowser/autoconfig.yml

Ce fichier Ne doit pas ÊTRE MODIFIÉ MANUELLEMENT
Debian testing/stable - XFCE
--gilles--
Membre
Membre
Messages : 453
Enregistré le : 24 août 2016, 19:35
Status : Hors ligne

12 oct. 2018, 12:57

Nous avons bien collaboré ! :icon_biggrin: :banana_jumprope:

J'espère que les utilisateurs de qutebrowser profiteront de ce tutoriel. Merci à toi.
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell
Avatar du membre
dezix
Membre
Membre
Messages : 371
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

12 oct. 2018, 13:09

--gilles-- a écrit :
12 oct. 2018, 12:57
J'espère que les utilisateurs de qutebrowser profiteront de ce tutoriel. Merci à toi.

C'est le juste retour à la communauté,
merci à VOUS !
Debian testing/stable - XFCE
Répondre