Problème de boot sur nouveaux noyaux

Demande d'aide : c'est ici.
Répondre
snouf
Membre
Membre
Messages : 10
Enregistré le : 17 juil. 2016, 14:27
Status : Hors ligne

17 juil. 2016, 14:55

Bonjour à tous

Je suis sur testing sur un pc portable relativement récent (zenbook 15'' d'asus)

Le noyau (4.5.0-1-amd64) installé en même temps que le reste du système fonctionne très bien (malgré quelque affichage d'erreur au boot) mais depuis l'installation il y a eu 2 mise à jours
1/ Une mineur 4.5.0-2-amd64
2/ Une majeur 4.6.0-1-amd64
Impossible de booter sur ces nouvelle versions, au milieu du boot le chargement se bloque et quelque instant après les ventilos tourne à fond, obligé de faire un "arrêt brutal" (pression longue sur power)

Je ne sais pas comment diagnostiquer le problème toute aide sera la bienvenue
marcastro
Membre actif
Membre actif
Messages : 674
Enregistré le : 22 avr. 2016, 12:05
Localisation : 83560 Saint Julien
Jappix : marcastro@xmpp.jp
Status : Hors ligne

17 juil. 2016, 15:23

le kernel 4.6.0-1-amd64 n'est pas proposé par apt-get ou aptitude lors de la mise à jour bien qu'il existe dans les dépôts testing,il est buggé pour le moment,je viens de l'installer manuellement et j'ai le même problème de blocage au boot. Il faut donc rester avec le noyau 4.5.0-2-amd64 en attendant des jours meilleurs.N'oublie pas d'installer le paquet apt-listbugs si tu tournes en testing ou sid.
sur le forum depuis 2007.
testing 4.19-amd64#1 sid 4.19-amd64 stretch4.19- bpo nvidia-driver marcastro@xmpp.jp et climatosceptique.
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3373
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

18 juil. 2016, 17:25

Salut,
Aucun problème chez moi:

Code : Tout sélectionner

$ uname -a
Linux tor 4.6.0-1-amd64 #1 SMP Debian 4.6.3-1 (2016-07-04) x86_64 GNU/Linux
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Avatar du membre
Junichirô
Membre actif
Membre actif
Messages : 868
Enregistré le : 26 avr. 2016, 01:10
Localisation : Baillif (Guadeloupe)
Contact :
Status : Hors ligne

18 juil. 2016, 17:40

snouf, fais un uname -a pour voir si tu as la même version que lol (Debian 4.6.3-1 (2016-07-04)).
“Lorsque vous avez éliminé l’impossible, ce qui reste, si improbable soit-il, est nécessairement la vérité.”
snouf
Membre
Membre
Messages : 10
Enregistré le : 17 juil. 2016, 14:27
Status : Hors ligne

19 juil. 2016, 21:31

Contrairement à marcastro 4.5.0-2 ne boot pas non plus, je pensais à un problème passager j'ai donc attendu une nouvelle version avant de me soucié du bug

L'ordi ne boot que sur 4.5.0-1 donc ce n'est pas ma même chose que lol ;)

Code : Tout sélectionner

uname -a
Linux ZenBook-Jonas 4.5.0-1-amd64 #1 SMP Debian 4.5.1-1 (2016-04-14) x86_64 GNU/Linux
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3373
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

19 juil. 2016, 21:38

Tu peux nous dire à quel moment le processus de démarrage s'arrête (Quelle ligne est affichée) ?
Tu n'a pas modifié les options de /etc/default/grub.cfg ?
C'est un EFI ou un BIOS normal ?
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
snouf
Membre
Membre
Messages : 10
Enregistré le : 17 juil. 2016, 14:27
Status : Hors ligne

19 juil. 2016, 22:16

BIOS EFI, aucun modification manuelle dans /etc/default/grub.cfg

Extrait du dmesg sur 4.5.0-1 (celui qui boot)

Code : Tout sélectionner

...
[    1.600012] asus_wmi: BIOS WMI version: 7.9
[    1.600051] asus_wmi: SFUN value: 0xa0065
[    1.601491] input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input8
[    1.603601] asus_wmi: Number of fans: 1
[    1.615122] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    1.615615] tsc: Refined TSC clocksource calibration: 2592.017 MHz
[    1.615618] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x255cc6d0f0f, max_idle_ns: 440795255895 ns
[    1.637337] fbcon: inteldrmfb (fb0) is primary device
[    1.641190] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
[    1.843236] random: nonblocking pool is initialized
[    1.848814] i2c_hid i2c-FTE1001:00: error in i2c_hid_init_report size:633 / ret_size:0
[    1.852224] i2c_hid i2c-FTE1001:00: error in i2c_hid_init_report size:131 / ret_size:0
[    1.852345] input: FTE1001:00 0B05:0101 as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-7/i2c-FTE1001:00/0018:0B05:0101.0001/input/input9
[    1.852715] hid-generic 0018:0B05:0101.0001: input,hidraw0: I2C HID v1.00 Mouse [FTE1001:00 0B05:0101] on i2c-FTE1001:00
[    2.615948] clocksource: Switched to clocksource tsc
[    2.675340] ------------[ cut here ]------------
[    2.675406] WARNING: CPU: 0 PID: 6 at /build/linux-HoPide/linux-4.5.1/drivers/gpu/drm/i915/intel_pm.c:3553 skl_update_other_pipe_wm+0x15d/0x170 [i915]()
[    2.675414] WARN_ON(!wm_changed)
[    2.675453] Modules linked in: hid_generic(E) arc4(E) i2c_designware_platform(E) i2c_designware_core(E) asus_nb_wmi(E) asus_wmi(E) sparse_keymap(E) mxm_wmi(E) intel_rapl(E) x86_pkg_temp_thermal(E) intel_powerclamp(E) coretemp(E) kvm_intel(E) kvm(E) irqbypass(E) crct10dif_pclmul(E) crc32_pclmul(E) ghash_clmulni_intel(E) iwlmvm(E) mac80211(E) iwlwifi(E) jitterentropy_rng(E) cfg80211(E) hmac(E) drbg(E) ansi_cprng(E) aesni_intel(E) aes_x86_64(E) lrw(E) gf128mul(E) glue_helper(E) ablk_helper(E) cryptd(E) snd_hda_intel(E) snd_hda_codec(E) efi_pstore(E) i915(E) evdev(E) snd_hda_core(E) snd_hwdep(E) serio_raw(E) snd_pcm(E) pcspkr(E) drm_kms_helper(E) efivars(E) snd_timer(E) snd(E) idma64(E) hci_uart(E) virt_dma(E) drm(E) mei_me(E) i2c_i801(E) soundcore(E) btbcm(E) shpchp(E) processor_thermal_device(E) mei(E)
[    2.675482]  i2c_algo_bit(E) btqca(E) intel_soc_dts_iosf(E) intel_lpss_pci(E) btintel(E) int3403_thermal(E) bluetooth(E) rfkill(E) tpm_crb(E) wmi(E) int3400_thermal(E) int3402_thermal(E) battery(E) acpi_thermal_rel(E) int340x_thermal_zone(E) intel_lpss_acpi(E) intel_lpss(E) video(E) asus_wireless(E) mfd_core(E) ac(E) tpm_tis(E) tpm(E) acpi_pad(E) button(E) processor(E) efivarfs(E) autofs4(E) ext4(E) crc16(E) mbcache(E) jbd2(E) crc32c_generic(E) crc32c_intel(E) ahci(E) libahci(E) xhci_pci(E) xhci_hcd(E) libata(E) nvme(E) usbcore(E) scsi_mod(E) usb_common(E) thermal(E) i2c_hid(E) hid(E) fjes(E)
...
Sur les autres noyaux les dernières ligne que j'aperçois sont

Code : Tout sélectionner

[    1.848814] i2c_hid i2c-FTE1001:00: error in i2c_hid_init_report size:633 / ret_size:0
[    1.852224] i2c_hid i2c-FTE1001:00: error in i2c_hid_init_report size:131 / ret_size:0
A noter que sur le noyau qui marche se sont aussi les dernières lignes que je vois avant le démarrage du bureau. (donc de X ? à noter également que j'utilise bumblebee)
Avatar du membre
Grhim
Membre très actif
Membre très actif
Messages : 1075
Enregistré le : 30 mai 2016, 01:00
Localisation : Zurich
Status : Hors ligne

20 juil. 2016, 00:56

serais-ce toujours le meme probleme qu'ici ? https://www.debian-fr.org/t/boot-imposs ... oyau/70201

as tu essayer de booter sur live stable ou de te l'installer sur une partition ?? (histoire de voir si ca fait toujours pareil ? )

un bug avec le meme message d'erreur est répertorier ici https://bugs.launchpad.net/ubuntu/+sour ... ug/1558489 s'agirait - il de ton touche pad ??
Debian Testing-Sid / Debian Stable / Kali Linux / LXDE sur Gnome3 - KissOs - Raspberry 3b+ -
Avatar du membre
Junichirô
Membre actif
Membre actif
Messages : 868
Enregistré le : 26 avr. 2016, 01:10
Localisation : Baillif (Guadeloupe)
Contact :
Status : Hors ligne

20 juil. 2016, 06:40

snouf a écrit :Contrairement à marcastro 4.5.0-2 ne boot pas non plus, je pensais à un problème passager j'ai donc attendu une nouvelle version avant de me soucié du bug

L'ordi ne boot que sur 4.5.0-1 donc ce n'est pas ma même chose que lol ;)

Code : Tout sélectionner

uname -a
Linux ZenBook-Jonas 4.5.0-1-amd64 #1 SMP Debian 4.5.1-1 (2016-04-14) x86_64 GNU/Linux
Oui, ma question était idiote. C'était pour savoir si ton noyau 4.6 qui ne fonctionnait pas était le même que celui de lol pour le cas où il y aurait eu une nouvelle version corrective.
“Lorsque vous avez éliminé l’impossible, ce qui reste, si improbable soit-il, est nécessairement la vérité.”
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3373
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

20 juil. 2016, 07:26

Salut,
@snouf: C’est les 2/3 dernières lignes avant le "freeze" qui pourraient être intéressantes (pas les logs du noyau qui fonctionne).
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
snouf
Membre
Membre
Messages : 10
Enregistré le : 17 juil. 2016, 14:27
Status : Hors ligne

20 juil. 2016, 18:46

@Grhim :
1/oui c'est le même problème que je le post sur debian-fr.org
2/ Debian Sable me semble très mal géré l'EFI, J'ai du faire un retours en SAV après avoir tenté une installation de debian stable (je pense avoir écraser l'EFI en forçant l'installation de GRUB et ... aucun moyen de le restaurer. Asus a pris ça sous garantie ... ouf). Mais je vais tenter avec un live base sur sid ou testing.
3/ Peut-être est-ce mon touche pad mais ... comment savoir ? Se serait tout de même étonnant que le touche pad ne pose pas de problème sur 4.5.0-1 mais qu'il en pose sur 4.5.0-2 non ?

@Sherlock :
Pas si bête que ça on ne sais jamais quel est le niveau de celui qui pose la question ;) les bug viennent très souvent de l'interface chaise clavier :D)

@lol :
Oui ç'est pour ça que j'ai écris les dernières lignes que je vois. Le log du noyau est la pour que vous puissiez voir ce qui est charger après les lignes du "freeze". Le top serait de récupéré le log du noyau qui "freeze" mais je ne sais pas comment faire.
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3373
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

20 juil. 2016, 21:47

Re,
Grhim a écrit :serais-ce toujours le meme probleme qu'ici ? https://www.debian-fr.org/t/boot-imposs ... oyau/70201

as tu essayer de booter sur live stable ou de te l'installer sur une partition ?? (histoire de voir si ca fait toujours pareil ? )

un bug avec le meme message d'erreur est répertorier ici https://bugs.launchpad.net/ubuntu/+sour ... ug/1558489 s'agirait - il de ton touche pad ??
Si c'est un touchpad, le bug remonté par Ghrim est étrangement semblable au tiens... :wink:
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Avatar du membre
Grhim
Membre très actif
Membre très actif
Messages : 1075
Enregistré le : 30 mai 2016, 01:00
Localisation : Zurich
Status : Hors ligne

20 juil. 2016, 23:25

merci lol ;p

@ snouf > a la vu de ton log le prob se situerais ici

Code : Tout sélectionner

[    2.675406] WARNING: CPU: 0 PID: 6 at /build/linux-HoPide/linux-4.5.1/drivers/gpu/drm/i915/intel_pm.c:3553 skl_update_other_pipe_wm+0x15d/0x170 [i915]()
[    2.675414] WARN_ON(!wm_changed)
faut voir ce qu'on trouve avec ca ...mais apparement /linux-4.5.1/drivers/gpu/drm/i915/intel_pm ...
Debian Testing-Sid / Debian Stable / Kali Linux / LXDE sur Gnome3 - KissOs - Raspberry 3b+ -
snouf
Membre
Membre
Messages : 10
Enregistré le : 17 juil. 2016, 14:27
Status : Hors ligne

23 juil. 2016, 11:36

@lol: merci, a noté que sous 4.5.1-1 le touchpad est mal supporté (pas de multitouch) mais comme je ne m'en sert pas j'ai pas creusé.

@Grhim: mmmh j'ai un peu cherché mais rien trouver de très convaincant.

J’essaierai bien un live avec un kernel identique mais ... y'a des lives dérivés de testing ? Sinon je pense que je vais attendre un nouveau noyaux et voire si le problème est toujours présent a ce moment là.
snouf
Membre
Membre
Messages : 10
Enregistré le : 17 juil. 2016, 14:27
Status : Hors ligne

23 juil. 2016, 12:15

Alors j'ai désinstallé bumblebee, eu quelque problème avec X (résolu en désinstallant les driver nvidia) et hop ça fonctionne sur tous le noyaux

Par contre j'ai les ventilos a fond :(

[edit] réinstallation de bumblebee (et nvidia prorio) et 4.5.0-1 est le seul à démarré !
Avatar du membre
Grhim
Membre très actif
Membre très actif
Messages : 1075
Enregistré le : 30 mai 2016, 01:00
Localisation : Zurich
Status : Hors ligne

23 juil. 2016, 13:50

snouf a écrit :Alors j'ai désinstallé bumblebee, eu quelque problème avec X (résolu en désinstallant les driver nvidia) et hop ça fonctionne sur tous le noyaux

Par contre j'ai les ventilos a fond :(

[edit] réinstallation de bumblebee (et nvidia prorio) et 4.5.0-1 est le seul à démarré !
toujours les meme probleme avec Nvidia... de mon cotè je reste avec le driver <nouveau>
Debian Testing-Sid / Debian Stable / Kali Linux / LXDE sur Gnome3 - KissOs - Raspberry 3b+ -
marcastro
Membre actif
Membre actif
Messages : 674
Enregistré le : 22 avr. 2016, 12:05
Localisation : 83560 Saint Julien
Jappix : marcastro@xmpp.jp
Status : Hors ligne

24 juil. 2016, 12:27

J'aimerais comprendre: dans les dépôts testing il est proposé le kernel linux-image-4.6.0-1-amd64. Or apt-get upgrade,dist-upgrade, que je pratique quotidiennement, ne m'a jamais proposé l'installation de ce noyau en remplacement du kernel actuel 4.5.0-2-amd64

Code : Tout sélectionner

avram@stretch-amd64: 12:25:18: ~$ uname -a
Linux stretch-amd64 4.5.0-2-amd64 #1 SMP Debian 4.5.5-1 (2016-05-29) x86_64 GNU/Linux
avram@stretch-amd64: 12:25:24: ~$ 
pourquoi?
sur le forum depuis 2007.
testing 4.19-amd64#1 sid 4.19-amd64 stretch4.19- bpo nvidia-driver marcastro@xmpp.jp et climatosceptique.
marcastro
Membre actif
Membre actif
Messages : 674
Enregistré le : 22 avr. 2016, 12:05
Localisation : 83560 Saint Julien
Jappix : marcastro@xmpp.jp
Status : Hors ligne

24 juil. 2016, 12:47

bon,y a du nouveau;je viens à l'instant de réinstaller le kernel 4.6 et au boot il a replanté;je fais un Ctrl+Alt+F1 et je réinstalle mon pilote nvidia avec sgfxi et du coup il n'y a plus de problème,ma machine démarre correctement sur le kernel 4.6.C'était donc un pb de pilote nvidia.
Mais pourquoi le 4.6 n'est pas proposé au dist-upgrade?

Code : Tout sélectionner

avram@stretch-amd64: 12:49:15: ~$ uname -a
Linux stretch-amd64 4.6.0-1-amd64 #1 SMP Debian 4.6.4-1 (2016-07-18) x86_64 GNU/Linux
avram@stretch-amd64: 12:49:22: ~$ 
sur le forum depuis 2007.
testing 4.19-amd64#1 sid 4.19-amd64 stretch4.19- bpo nvidia-driver marcastro@xmpp.jp et climatosceptique.
snouf
Membre
Membre
Messages : 10
Enregistré le : 17 juil. 2016, 14:27
Status : Hors ligne

25 juil. 2016, 11:14

Personnellement je l'ai eu en dist-upgrade, je n'ai pas fait d'installation "manuel" et "apt-cache policy" me donne le paquet en priorité 500.

Pour l'instant je tourne avec <nouveau> mais ... problème de ventilo ("résolu" avec asusfanctrld.sh https://github.com/nflx/asusfanctrld) mais j'ai également la mise en veille ne fonctionne pas.

Je n'ai pas trop envie d'utiliser sgfxi (surtout que je ne sais pas si ça marche avec nvidia optimus).
snouf
Membre
Membre
Messages : 10
Enregistré le : 17 juil. 2016, 14:27
Status : Hors ligne

11 août 2016, 19:47

En plus des problème de ventilos avec <nouveau> j'avais des problème de mise en veille et même d'arrêt du PC, j'avais donc réinstallé les driver proprio et tournait sur mon vieux noyau.

Mais il y a environ une semaine j'ai supprimé mon vieux noyau par erreur :( --> repassage au nouveau et des problèmes liés. Avec il y a une petite heure des problèmes de pixel fous qui clignottait, puis d'écran secondaire tout entier)

Mais j'ai trouvé un contournement qui marche bien mieux !
1/ Désinstaller les drivers proprio
2/ blacklister <nouveau>

Code : Tout sélectionner

#/etc/modprobe.d/nvidia.conf
blacklist nouveau
Plus de problème de ventilo, plus de problème de mise en veille, plus de gpu nvidia :D et probablement un gain en autonomie (mais comme elle est largement suffisante je ne pourrais pas donner de retour sur ce point)
Répondre