Problèmes avec Grub [Resolu] Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
jandelalune
Membre
Membre
Messages : 144
Enregistré le : 29 janv. 2018, 19:01
Status : Hors ligne

Salut et bonne année à tous

De retour parmi vous , cette fois pour un problème de dual boot

Le matériel concerné : un ordinateur HP Victus avec W11 pré installé, AMD 5600H, 512 Go SSD, 16 Go de RAM

J’ai résolu les questions Windows qui me posaient difficultés sur les forums Windows

Mon objectif suivant : installer debian Buster en dual boot avec W11, autant pour la garantie pendant les deux premières années que pour les quelques travaux que je n’arrive toujours pas à faire avec debian, en particulier la liaison avec mon tel Samsung (ils semblent irrémédiablement incompatibles !!)

Mais revenons à ma préoccupation du jour :

Aprés avoir procédé à la création d’un espace disponible confortable pour debian avec l’outil de Windows j’ai créé une clef bootable de Buster (téléchargé sur Internet) avec Rufus

C’est à l’aide de cette clef et la procédure qu’elle propose que j’ai ensuite installé buster sur mon ordinateur flambant neuf

D’entrée mon dual boot a planté à l’ouverture de debian et depuis j’ai essayé de corriger avec des réinstallations dont une avec une clef netinstall de Buster et aujourd’hui encore un essai de réinstallation de grub avec toujours le même résultat : debian est bien en tête dans la fenêtre de démarrage et, Sélectionné, il démarre mais après 2 ou trois écrans il s’arrête à chaque fois sans plus de précisions ni messages et je dois redémarrer (CtrlAltSuppr) pour sélectionner Windows : mon ordi est beaucoup trop rapide pour me permettre de lire les écrans

Pourtant dans l’ordre de démarrage debian est bien en tête et quand j’ai besoin de Windows (actuellement essentiellement pour arréter mon ordi) je le sélectionne dans la fenêtre de démarrage sans problème

J’ai essayé plusieurs réinstallation successives dont une avec ma clef de boot créée avec une procédure netinstall et pour finir aujourd’hui une réinstallation de grub mais résultats toujours identiques

J'ai beaucoup lu sur les difficultés du logiciel libre avec Microsoft mais j'ai lu à plusieurs reprises que même avec Debian des solutions ont été développées ??

Là je suis arrivé au bout de mes maigres compétences. Quelques conseils, infos ou autres pour sortir de cet imbroglio me serait fort utiles : naturellement je reste à votre disposition pour tout complément qui pourrait être utile

Merci d’avance
Cordialement
PascalHambourg
Contributeur
Contributeur
Messages : 635
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

jandelalune a écrit : 16 janv. 2022, 19:44 Mon objectif suivant : installer debian Buster en dual boot avec W11
Pourquoi buster qui est l'ancienne version stable ?
Il vaut mieux utiliser la version stable actuelle, bullseye, surtout si l'ordinateur est récent.
jandelalune a écrit : 16 janv. 2022, 19:44 debian est bien en tête dans la fenêtre de démarrage
Quelle fenêtre de démarrage ? Le menu de boot du firmware UEFI de l'ordinateur ? Le menu de GRUB ? Autre chose ?
Si c'est le menu de GRUB, as-tu essayé de démarrer Debian en mode recovery/dépannage via le sous-menu "options avancées pour Debian" ?
Si la machine a un GPU AMD, il faudra probablement installer les firmwares non libres du paquet firmware-amd-graphics.
jandelalune a écrit : 16 janv. 2022, 19:44 après 2 ou trois écrans il s’arrête
Quels écrans ?
jandelalune a écrit : 16 janv. 2022, 19:44 mon ordi est beaucoup trop rapide pour me permettre de lire les écrans
Tu ne peux pas filmer l'écran avec ton smartphone, passer la vidéo au ralenti et mettre en pause pour lire ? Evite de poster des photos en haute résolution ici, une description ou une transcription du texte est préférable.
Sans informations plus précises sur ce qui est affiché, on ne pourra pas t'aider.
jandelalune
Membre
Membre
Messages : 144
Enregistré le : 29 janv. 2018, 19:01
Status : Hors ligne

Bonjour PascalHambourg et merci pour ta réponse

Après de nombreux essais avec Buster, ta réponse est venue à point pour conforter mon envie d'essayer Bulleyes

J'ai donc nettoyé mon installation de Buster : suppression des partitions debian redevenues espace disponible et suppression de Grub dans l'ESP EFI de Windows : j'ai trouvé sur Internet tout ce qu'il me fallait pour cela

Et j'ai repris mon install avec Bulleye : Bingo j'ai maintenant un dual boot fonctionnel

Merci & surement à bientôt car j'ai limpression que j'aurai encore des soucis, avec Debian 11
Cordialement
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3880
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

Si le problème est réglé, merci de passer le sujet en résolu
Répondre