Plus de wifi - "Aucun réseau disponible"

Demande d'aide : c'est ici.
Répondre
bulle
Messages : 4
Enregistré le : 15 févr. 2021, 19:16
Status : Hors ligne

15 févr. 2021, 19:44

Bonjour,

Cela fait quelques semaines que je n'ai plus de wifi. Lorsque je veux sélectionner un réseau je n'ai "Aucun réseau disponible" alors que mes colocs n'ont pas de problème à se connecter. Je ne vois plus les box de mes voisins non plus. Pas de problème pour le filaire en revanche.

J'ai essayé de chercher sur internet mais je ne suis pas hyper familière avec linux en général, alors je suis un peu perdue.

Voilà quelques commandes qui pourront peut-être éclairer sur ma situation :

Code : Tout sélectionner

# uname -a
Linux bulle 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux

# /sbin/iwconfig
wlp2s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=200 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
enp3s0    no wireless extensions.

lo        no wireless extensions.

# nmcli general
STATE     CONNECTIVITY  WIFI-HW  WIFI    WWAN-HW  WWAN   
connecté  plein         activé   activé  activé   activé 

# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 3c:97:0e:f1:75:4f brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state DORMANT mode DORMANT group default qlen 1000
    link/ether 48:5a:b6:cb:55:d7 brd ff:ff:ff:ff:ff:ff

# lspci -v -s 02:00.0 
02:00.0 Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)
	Subsystem: Lenovo BCM43142 802.11b/g/n
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at f0500000 (64-bit, non-prefetchable) [size=32K]
	Capabilities: [40] Power Management version 3
	Capabilities: [58] Vendor Specific Information: Len=78 <?>
	Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [d0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [13c] Virtual Channel
	Capabilities: [160] Device Serial Number 00-00-b6-ff-ff-cb-48-5a
	Capabilities: [16c] Power Budgeting <?>
	Kernel driver in use: wl
	Kernel modules: wl
Merci de votre aide :)
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1207
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

16 févr. 2021, 10:41

Bonjour et Bienvenue @bulle :006:

Je ne suis pas très à l'aise avec le WIFI
bulle a écrit : 15 févr. 2021, 19:44 # /sbin/iwconfig
wlp2s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=200 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
mais il semblerait (je peux me tromper) que ton interface soit éteinte,
ce qui serait une explication plausible vu que cela fonctionnait avant....???

Certains portables (ou autres...) disposent d'un interrupteur physique pour couper l'alim du wifi et une touche "bleue" Fn pour le désactiver.

Donc c'est par-là que je commencerais mon investigation.

Je crois que si le wifi est matériellement disponible , la commande :

ifup wlp2s0

devrait activer l'usage de l'interface.

iwlist wlp2s0 scanning

devrait permettre d'afficher les réseaux à portée.

En espérant que cela te soit utile :rolleyes:
Debian testing/stable - XFCE
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3628
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

16 févr. 2021, 19:58

En complément des conseils de dezix, il faudrait aussi vérifier qu'il ne te manque pas un firmware.
Avec la commande

Code : Tout sélectionner

#dmesg | grep firmware
tu devrais voir ce qui se passe avec les firmwares

Le power management, c'est la capacité qu'ont certaines clefs à gérer leur consommation d'énergie automatiquement.
PascalHambourg
Contributeur
Contributeur
Messages : 486
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

16 févr. 2021, 20:34

dezix a écrit : 16 févr. 2021, 10:41 il semblerait (je peux me tromper) que ton interface soit éteinte,
Non, elle n'est pas éteinte sinon elle ne serait pas visible.
dezix a écrit : 16 févr. 2021, 10:41 Certains portables (ou autres...) disposent d'un interrupteur physique pour couper l'alim du wifi et une touche "bleue" Fn pour le désactiver
Non, l'interrupteur ne coupe pas l'alimentation du wifi. Comme le bouton ou la touche (ou combinaison de touches) spéciale, il ne fait qu'envoyer un signal à la carte wifi pour activer ou désactiver la radio. On peut voir son état avec le programme rfkill.

Code : Tout sélectionner

rfkill list
dezix a écrit : 16 févr. 2021, 10:41 ifup wlp2s0
devrait activer l'usage de l'interface.
Seulement si l'interface est gérée par ifupdown, c'est-à-dire le "service" networking, et donc configurée dans le fichier /etc/network/interfaces. Dans ce cas elle est ignorée par NetworkManager qui la marque "non géré".
En complément de la commande nmcli déjà mentionnée, on pourrait regarder la sortie de

Code : Tout sélectionner

nmcli device
pour vérifier si la carte wifi est gérée par NetworkManager.
piratebab a écrit : 16 févr. 2021, 19:58 il faudrait aussi vérifier qu'il ne te manque pas un firmware
On pourrait penser que ce n'est pas nécessaire car le noyau, dans sa grande sagesse, ne crée une interface wifi que si les firmwares nécessaires à son fonctionnement sont présents. C'est ce que j'ai longtemps cru, conforté par l'expérience. Et un jour je suis tombé sur une carte wifi (ne je me rappelle plus le modèle) dont le pilote créait l'interface sans vérifier et n'essayait de charger le firmware que lors de l'activation de l'interface (qui échouait en son absence). C'est vraiment vicieux. Ceci dit, ici l'interface est administrativement active (UP), donc le problème devrait être ailleurs.
bulle
Messages : 4
Enregistré le : 15 févr. 2021, 19:16
Status : Hors ligne

16 févr. 2021, 23:14

Merci pour vos réponses :)

@dezix :
Pour le bouton physique j'avais déjà exploré cette option, mais je n'en ai pas pour le wifi, uniquement pour le mode avion (que j'ai bien sûr désactivé).
Et pour les deux commandes :

Code : Tout sélectionner

# /sbin/ifup wlp2s0
ifup: unknown interface wlp2s0
# /sbin/iwlist wlp2s0 scanning
wlp2s0    Interface doesn't support scanning : Invalid argument
@piratebab :
Voilà ce que j'obtiens (et que je ne comprends pas du tout ^^) :

Code : Tout sélectionner

# dmesg | grep firmware
[   18.065094] r8169 0000:03:00.0: firmware: direct-loading firmware rtl_nic/rtl8168e-3.fw
@PascalHambourg :
Pour rfkill j'ai "commande introuvable", mais quand j'essaie de l'installer ça me dit que j'ai déjà la version la plus récente (2.33.1-0.1).
Et sinon :

Code : Tout sélectionner

# nmcli device
DEVICE  TYPE      STATE       CONNECTION          
enp3s0  ethernet  connecté    Connexion filaire 1 
wlp2s0  wifi      déconnecté  --                  
lo      loopback  non-géré    --  
PascalHambourg
Contributeur
Contributeur
Messages : 486
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

17 févr. 2021, 11:57

bulle a écrit : 16 févr. 2021, 23:14 Pour rfkill j'ai "commande introuvable"
Le $PATH est-il correctement défini pour le compte root ? J'ai l'impression que non si tu dois spécifier le chemin /sbin/iwconfig ou /sbin/ifup. Sinon, comment passes-tu root ? "su" tout seul n'initialise pas l'environnement dont $PATH, il faut utiliser "su -" ou "su -l".
bulle
Messages : 4
Enregistré le : 15 févr. 2021, 19:16
Status : Hors ligne

17 févr. 2021, 15:12

En effet ça marche avec "su -" plutôt que "su" ! :)

Code : Tout sélectionner

# rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Au sujet de $PATH, avec "su" tout seul j'ai :

Code : Tout sélectionner

# echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
Et avec "su -" :

Code : Tout sélectionner

# echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
Est-ce qu'il faut que je change la configuration ? Ou est-ce qu'il me suffit d'utiliser "su-" à chaque fois ?
PascalHambourg
Contributeur
Contributeur
Messages : 486
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

17 févr. 2021, 15:26

Il faut utiliser "su -" à chaque fois.

Bon, pas de blocage hard ou soft du wifi. Ce qui me chagrine, c'est ça :

Code : Tout sélectionner

# /sbin/iwlist wlp2s0 scanning
wlp2s0    Interface doesn't support scanning
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3628
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

17 févr. 2021, 17:05

Et le firmware est bien chargé, sinon il y aurait une autre ligne qui indiquerait une erreur de chargement
bulle
Messages : 4
Enregistré le : 15 févr. 2021, 19:16
Status : Hors ligne

19 févr. 2021, 20:40

PascalHambourg a écrit : 17 févr. 2021, 15:26 Ce qui me chagrine, c'est ça :

Code : Tout sélectionner

# /sbin/iwlist wlp2s0 scanning
wlp2s0    Interface doesn't support scanning
Est ce que ça veut dire que tu penses que c'est un problème matériel ?
C'est vrai que mon PC n'est plus tout jeune (il a presque 7 ans).

J'essaie de trouver une clé wifi pour tester si ça marche avec, mais ce n'est plus très commun apparemment ^^
PascalHambourg
Contributeur
Contributeur
Messages : 486
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

21 févr. 2021, 12:56

bulle a écrit : 19 févr. 2021, 20:40 Est ce que ça veut dire que tu penses que c'est un problème matériel ?
Non, je pense que c'est plutôt logiciel. Mais je ne vois pas d'où peut venir le problème.
Répondre