Panne suite au passage du chat sur le clavier ?

Demande d'aide : c'est ici.
Répondre
Avatar du membre
debianjam
Membre
Membre
Messages : 156
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

05 juil. 2019, 11:27

Bonjour
L'ordinateur a eu un problème d'extinction auquel je ne me suis pas intéressé car je n'ai rien trouvé facilement sur le sujet, j'ai simplement coupé après maintes tentatives infructueuses. Il y avait à chaque fois un message d'erreur de compte utilisateur qui aurait dû je ne sais plus quoi exactement pas très sympathique à retenir, je n'ai pas accès à mon historique web depuis android je pourrai essayer de le consulter prochainement depuis un cybercafé et de préciser.
Aujourd'hui j'allume je renseigne login et mot de passe normalement mais ensuite je reste sur un écran de la couleur de fond habituelle sans bureau, la souris est active et on dirait de taille réduite.
Comment puis je essayer de réparer svp ?
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

06 juil. 2019, 21:21

Bonjour,
si tu veux savoir ce qui se passe alors que ton interface graphique n'affiche rien, passe sur un terminal en pressant simultanément les touches CTRL + ALT + F1, et tu te connectes.
Pour revanir à l'interface graphique c'est ctrl + alt + F7
Avatar du membre
dezix
Membre
Membre
Messages : 417
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

06 juil. 2019, 23:10

salut debianjam

regarde de ce côté :

viewtopic.php?f=8&t=1724&p=21003#p21003

ça doit être une histoire de session corrompue

je ne connais que XFCE. mais c'est sûrement comparable avec les autres bureaux
Debian testing/stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 156
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

07 juil. 2019, 16:43

merci pour votre coup de pouce
après ctrl alt f1 j'ai appliqué

Code : Tout sélectionner

rm -rf ~/.cache/sessions
rm: impossible de supprimer 'rf' : aucun fichier ou dossier de ce type
rm: impossible de supprimer 'home/utilisateur1/.cache/sessions' : est un dossier utilisateur1@debian: ~$
après ctrl alt f7 je retrouve le bureau et je peux consulter l'historique de navigation qui me rappelle ma recherche de solution pour le message d'erreur initial
le gestionnaire de cession doit être mis en mode attente lors d'une requête de mise hors tension
j'ai fait une tentative de redémarrage mais il semblerait que le problème de manque de bureau se reproduit à chaque fois
comment revoir ça complètement svp ?
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

07 juil. 2019, 22:58

Jamais vu ce message d'erreur.

Quel gestionnaire de bureau utilises tu ?
J'en ai toujours 2 d'installés (KDE et LXDE); comme ça j'en ai toujours un en secours si KDE me fait des misères.
Avatar du membre
Dunatotatos
Membre
Membre
Messages : 411
Enregistré le : 11 mai 2016, 20:56
Localisation : Arabie Saoudite
Status : Hors ligne

08 juil. 2019, 09:17

debianjam a écrit :
07 juil. 2019, 16:43

Code : Tout sélectionner

rm -rf ~/.cache/sessions
rm: impossible de supprimer 'rf' : aucun fichier ou dossier de ce type
rm: impossible de supprimer 'home/utilisateur1/.cache/sessions' : est un dossier utilisateur1@debian: ~$
:crazy:
Peux-tu vérifier ce qui est appelé par `rm`?

Code : Tout sélectionner

$ type rm
Never trust Windows output.
Avatar du membre
debianjam
Membre
Membre
Messages : 156
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

08 juil. 2019, 10:13

Code : Tout sélectionner

utilisateur1@debian:~$ type rm
rm est /bin/rm
Avatar du membre
Dunatotatos
Membre
Membre
Messages : 411
Enregistré le : 11 mai 2016, 20:56
Localisation : Arabie Saoudite
Status : Hors ligne

09 juil. 2019, 11:13

Cette erreur au sujet de rm est d'une étrangeté sans nom. Certainement pas liée à ton problème graphique, mais tout de même.

Sinon, peux-tu (depuis un tty, comme piratebab l'a décrit ci-dessus), poster la sortie de `systemctl status lightdm` ? Je ne sais pas quel service de connexion tu utilises. Si cette commande te retourne une erreur au sujet d'un service inconnu, tu peux tenter la même avec kdm, gdm, ou ssdm.
Regarde aussi le contenu de /var/log/Xorg.0.log, surtout les ligne contenant un (EE).
Never trust Windows output.
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

09 juil. 2019, 12:25

Pour compléter la réponse de Duna, et d'éviter d'éplucher un long fichier de log, fait un premier tri avec cat /var/log/Xorg.0.log | grep EE
Avatar du membre
debianjam
Membre
Membre
Messages : 156
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

09 juil. 2019, 21:15

Ce serait cette page graphique de login qui serait en cause ? car quand on rejoint le terminal avec CTRL alt F1 qu'on renseigne le login et le mot de passe puis CTRL alt f7 on obtient le bureau. Je préférerais presque supprimer cette page graphique et démarrer avec le terminal
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

10 juil. 2019, 15:56

ce serait donc ton gestionaire de lancment du breau qui aurait perdu sa config.
il faudrait déja savoir lequel tu utilises!
sinon, installe un nouveau, il viendra se substituer à l'ancien.
Par exemple apt-get install sddm
Avatar du membre
debianjam
Membre
Membre
Messages : 156
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

17 juil. 2019, 10:47

bonjour, en réponse à Dunatotatos

Code : Tout sélectionner

utilisateur1@debian:~$ systemctl status lightdm
● lightdm.service - Light Display Manager
   Loaded: loaded (/lib/systemd/system/lightdm.service; enabled; vendor preset: 
   Active: active (running) since Wed 2019-07-17 09:38:31 CEST; 1h 7min ago
     Docs: man:lightdm(1)
  Process: 561 ExecStartPre=/bin/sh -c [ "$(cat /etc/X11/default-display-manager
 Main PID: 565 (lightdm)
    Tasks: 5 (limit: 4915)
   CGroup: /system.slice/lightdm.service
           ├─565 /usr/sbin/lightdm
           └─588 /usr/lib/xorg/Xorg :0 -seat seat0 -auth /var/run/lightdm/root/:
lines 1-10/10 (END)
j'ai réalisé la commande de piratebab :

Code : Tout sélectionner

utilisateur1@debian:~$ apt-get install sddm
j'obtiens un avertissement :

Un gestionnaire graphique de session est un programme qui permet de se │
│ connecter depuis le système X Window. │
│ │
│ Un seul gestionnaire graphique de session peut s'occuper d'un serveur X │
│ donné, bien que plusieurs gestionnaires puissent être installés │
│ simultanément. Veuillez choisir celui qui sera utilisé par défaut. │
│ │
│ Plusieurs gestionnaires graphiques peuvent être lancés en même temps, │
│ s'ils gèrent des serveurs X différents ; pour cela, configurez │
│ correctement chacun des gestionnaires graphiques, modifiez leurs scripts │
│ de lancement dans /etc/init.d, et désactivez le test de gestionnaire │
│ graphique par défaut. │
│ │
│ <Ok>

je n'ai rien fait de plus, le fonctionnement au démarrage est toujours problématique après le login sur la page graphique je passe sur le terminal avec ctrl alt f1 à nouveau login et ctrl alt f7 pour atteindre le bureau
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

17 juil. 2019, 15:06

installe sddm.
ensuite avec dpkg-reconfigure sddm tu pourras choisir le lanceur que tu souhaites activer, et ça désactive les autres (et comme ça, tu sauras ceux qui sont installé)
Avatar du membre
debianjam
Membre
Membre
Messages : 156
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

21 juil. 2019, 18:34

ok îratebab merci j'ai donc fait enter sur la page d'avertissement et il s'est installé, j'ai eu le choix entre lightdm et sddm j'ai choisi le second. j'ai maintenant une page de démarrage avec une horloge et les utilisateurs lorsque mais je m'identifie le problème reste le même : un écran vide. Lorsque je clique gauche le marqueur de souris diminue de taille et lorsque je clique droit il ne se passe rien.
Je refais donc ctrl alt f1 puis ctrl alt f7 après avoir l'identification. Peut-on améliorer la situation svp ?
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

22 juil. 2019, 09:45

Et si tu réactive lightdm, avec un dpkg-reconfigure lihtdm, il n'a pas conservé les paramètres d'identification ?
Pour comprendre ce qui coince, il faut plus d'infos.
Essaie de lancer sddm depuis la console, il te dira peut étre ce qui coince.
Avatar du membre
debianjam
Membre
Membre
Messages : 156
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

24 juil. 2019, 12:35

Code : Tout sélectionner

utilisateur1@debian:~$ su
Mot de passe : 
root@debian:/home/utilisateur1# dpkg-reconfigure sddm
Please be sure to run "dpkg --configure lightdm".
root@debian:/home/utilisateur1# 
root@debian:/home/utilisateur1# dpkg --configure lightdm
dpkg: erreur de traitement du paquet lightdm (--configure) :
 le paquet lightdm est déjà installé et configuré
Des erreurs ont été rencontrées pendant l'exécution :
 lightdm
Avatar du membre
debianjam
Membre
Membre
Messages : 156
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

14 août 2019, 11:21

c'est toujours pareil, c'est pas que ce soit gênant c'est une procédure finalement juste un peu contaignante moi qui voulais au départ supprimer tout login je n'ai jamais réussi à le faire et maintenant je dois m'identifier login et mot de passe puis ctrl-alt-f1 puis m'identifier login et mot de passe puis ctrl-alt-f7 merci à pirate bab sinon je ne ferais rien.
Est ce que le passage à debian 10 existe ? est ce que ça solutionne mon problème ? est ce que je dois faire une installation neuve ?
MicP
Modérateur
Modérateur
Messages : 550
Enregistré le : 16 avr. 2016, 22:14
Status : Hors ligne

14 août 2019, 11:35

Bonjour

As-tu essayé d'éteindre et de redémarrer le chat ?
Avatar du membre
debianjam
Membre
Membre
Messages : 156
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

14 août 2019, 12:54

answer to micp vous pouvez essayez vous même https://photos.app.goo.gl/es4wLDpx9hHn9qjN7
Avatar du membre
dezix
Membre
Membre
Messages : 417
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

14 août 2019, 17:18

MicP a écrit :
14 août 2019, 11:35
Bonjour

As-tu essayé d'éteindre et de redémarrer le chat ?
dans ce genre là ?

Image

:077:
Debian testing/stable - XFCE
Répondre