Change language de systeme

Demande d'aide : c'est ici.
Répondre
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

:006: Changement de langue du système. Comment j'ai fait. Réglage de l'emplacement (langue)
etc/default/locale
via MC anciennement avec le polonais c'était :
# File generated by update-locale
LANG="pl_PL.UTF-8"
je change pour
LANG="fr_FR.UTF-8"
le mieux est (vous devez installer des packs de langue)
commander

Code : Tout sélectionner

sudo apt update && sudo apt upgrade; apt install -f

il est réticent, car maintenant j'ai trois langues, franco-anglais-polonais. Ce n'est pas une tragédie, mais un peu étrange. Quand je vis en France, je préférerais avoir un système français avec la possibilité de vérifier l'orthographe polonaise et française dans LibreOffice. En polonais, car avec la correction de plus de 1000 pages de texte - sans cela, cela prendrait du temps. Ha, ha... Déjà dans ROSA (linux russe) j'avais un mélange polonais-français-russe (et russe en alphabet cyrillique), et c'est possible. :shok: :wacko: Mais peut-être qu'il y a un moyen pour que je n'aie Debian qu'en français. Quelqu'un sait comment ?? :pardon: :cray:
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

:rolleyes: :blush: :wacko: J'ai installé quelques packs de langues et le mélange de langues s'estompe de plus en plus. De toute façon - est-ce si irritant - le plus important est de comprendre. Les gruaux avec des nouilles et des sauces aigre-douces ne me dérangent pas. :spiteful:
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

:006: :wacko: Malheureusement, j'ai été obligé de revenir au polonais car il y avait des erreurs. Mais déjà corrigé.

...ce ci-dessous est déjà corrigé
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "fr_FR.UTF-8"
are supported and installed on your system.

Code : Tout sélectionner

inxi -Sxxx | grep dm
christophe@christophe ~> inxi -Sxxx | grep dm
dm: LightDM 1.26.0 Distro: Debian GNU/Linux bookworm/sid
J'ai lu sur Internet qu'il y a généralement des problèmes dans Debian lorsqu'on change la langue pour une autre que celle qui a été définie lors de l'installation. Peut-être que c'est vrai, parce que le système ne s'effondre pas. :crazy: :rolleyes:
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
Répondre