Failed to start raise network interfaces Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Papierciseaux
Messages : 4
Enregistré le : 19 nov. 2021, 09:14
Status : Hors ligne

voici comment est configuré mon interface
debian.png
je tiens a dire que je suis un debutant et malgrès mes recherches je n'arrive pas a trouver de solution
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
PascalHambourg
Contributeur
Contributeur
Messages : 528
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

1) Poste le contenu du fichier avec copier/coller plutôt qu'une capture d'écran graphique. C'est plus léger, lisible et pratique.
2) L'adresse de gateway en 10 sur enp0s8 n'est pas cohérente avec le sous-réseau en 192. Il faut supprimer cette ligne gateway si la route par défaut est via l'autre interface en DHCP.

S'il y a encore des erreurs, tu peux poster (en copier-coller) la sortie des commandes suivantes :

Code : Tout sélectionner

systemctl status networking
ip addr
ip route
ifup -a -v
Papierciseaux
Messages : 4
Enregistré le : 19 nov. 2021, 09:14
Status : Hors ligne

et je suis sur debian 11 apparament la commande ifup nexiste plus
PascalHambourg
Contributeur
Contributeur
Messages : 528
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

Une copie d'écran est si peu pratique que je n'avais pas vu les erreurs de syntaxe pourtant évidente : il manque les # de commentaire devant les deux premières lignes et le nom de l'interface après les "iface" de tes deux interfaces ethernet.

Par contre les interfaces sont visiblement gérées par autre chose. Si c'est NetworkManager, par défaut il devrait ne pas interférer avec les interfaces correctement définies dans le fichier interfaces. Si c'est un autre gestionnaire de réseau (connman, dhcpcd, wicd...) je ne garantis rien.
Papierciseaux
Messages : 4
Enregistré le : 19 nov. 2021, 09:14
Status : Hors ligne

PascalHambourg a écrit : 19 nov. 2021, 10:38 Une copie d'écran est si peu pratique que je n'avais pas vu les erreurs de syntaxe pourtant évidente : il manque les # de commentaire devant les deux premières lignes et le nom de l'interface après les "iface" de tes deux interfaces ethernet.

Par contre les interfaces sont visiblement gérées par autre chose. Si c'est NetworkManager, par défaut il devrait ne pas interférer avec les interfaces correctement définies dans le fichier interfaces. Si c'est un autre gestionnaire de réseau (connman, dhcpcd, wicd...) je ne garantis rien.
J'utilise dhcpd pour configurer le service

je vais reinstaller mon debian vu qu'en essayant de regler le problème j'ai triturer beaucoup de choses je vais essayer de refaire l'installation en attendant
PascalHambourg
Contributeur
Contributeur
Messages : 528
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

Tu parles de dhcpcd (client DHCP et gestionnaire de réseau) ou de dhcpd (serveur DHCP) ? dhcpd ne sert pas à configurer les interfaces de la machine elle-même, seulement les autres machines clientes DHCP.
Papierciseaux
Messages : 4
Enregistré le : 19 nov. 2021, 09:14
Status : Hors ligne

PascalHambourg a écrit : 19 nov. 2021, 11:05 Tu parles de dhcpcd (client DHCP et gestionnaire de réseau) ou de dhcpd (serveur DHCP) ? dhcpd ne sert pas à configurer les interfaces de la machine elle-même, seulement les autres machines clientes DHCP.
Pardon, je voulais dire serveur dhcp (sujet pas résolu)
Répondre