première page imprimée invalid page range

Demande d'aide : c'est ici.
Répondre
Avatar du membre
debianjam
Membre
Membre
Messages : 350
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

salut
je rencontre souvent le problème suivant :
l'imprimante brother HL2070n commence son travail impression par une page avec deux lignes en tête comme ceci
si j'enchaîne l'impression des pages paires puis impaires (ouu inversement), le seconde partie de l'impression commence normalement
c'est tout ce que je peux dire en plus que c'est à la longue pénible même si je commence à m'y habituer depuis des années que c'est comme ça

Invalid page range: opc device-uri=dnssd
(décalé vers la droite) Invalid page range: opc device-uri=dnssd
GNOME-Classic:GNOME mémoire : 3,7Gio ; i5 3450 @3.10Ghz x4 ; c.g. NV106 (intégrée Intel Ivybridge Desktop) ou asus gt730 2Gio
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1491
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

Bonjour,

Je n'ai aucune idée précise sur ce problème,
mais on peut raisonnablement imaginer un problème de :
  1. Pilote => Paquet printer-driver-brlaser à tester sinon le site du constructeur Téléchargement | HL-2070N | France | Brother propose un paquet pour ton modèle
  2. Configuration mais je ne sais pas vraiment où cela se tient ; commencer par /etc/cups/
J'espère que cela te mette sur la bonne voie.

:006:
Debian stable - XFCE
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1491
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

Piste supplémentaire :

dnssd doit être un système de détection automatique des imprimantes (je découvre)
Debian stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 350
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

je teste le premier pilote brother pour la distribution debian : brhl2070nlpr-2.0.1-1.i386.deb (2007)
voici en copier coller la méthode d'installation indiquée installation possible seulement par terminal :

Download LPR driver.

Login as a superuser ( or use "sudo" option if required).

Check if pre-required procedures are completed
For Debian/Ubuntu 64bit

Install the driver.
Turn on the printer and connect the usb, network or parallel cable.
Go to the directory where the driver is.
Install LPR driver.The install process may take some time. Please wait until it is complete.
Command : dpkg -i --force-all (lpr-drivername)
Check if the LPR driver is installed.
Command : dpkg -l | grep Brother

Confirm/Configure a file according to your connection.


Check the configuration filename for your distribution.
Example:
openSUSE, Ubuntu, Debian : /etc/printcap
Redhat, fedora, Mandriva : /etc/printcap.local

Edit the file according to your connection.
For USB Connection (Default)
Check if the parameter of ":lp" is ":lp=/dev/usb/lp0"
For Network Connection
replace ":lp" line to the following 2 lines
:rm=(ip address of your printer)\
:rp=lp\
For Parallel Connection
replace ":lp" line to the following line
:lp=/dev/lp0\

Restart the print system.
Command (for lpr): /etc/init.d/lpr restart
Command (for lprng) : /etc/init.d/lprng restart

Try a test print.
GNOME-Classic:GNOME mémoire : 3,7Gio ; i5 3450 @3.10Ghz x4 ; c.g. NV106 (intégrée Intel Ivybridge Desktop) ou asus gt730 2Gio
Avatar du membre
debianjam
Membre
Membre
Messages : 350
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

première commande
dpkg -i --force-all (lpr-drivername)
est ce que je vais donc écrire ?
dpkg -i --force-all (lpr-brhl2070nlpr-2.0.1-1.i386.deb)
ou
dpkg -i --force-all (lpr-brhl2070nlpr-2.0.1-1.i386)
GNOME-Classic:GNOME mémoire : 3,7Gio ; i5 3450 @3.10Ghz x4 ; c.g. NV106 (intégrée Intel Ivybridge Desktop) ou asus gt730 2Gio
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1491
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

À mon humble avis ce serait :

dpkg -i --force-all lpr-brhl2070nlpr-2.0.1-1.i386.deb

donc sans parenthèses

Le manuel fournit cet exemple : dpkg -i vim_4.5-3.deb
Debian stable - XFCE
Répondre