probleme de DNS sur mon serveur Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3756
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

Bonjour,
je fais ma premiere config de DNS, et je galere.
J'ai installé nextcloud dans /war/www/nextcloud
Je veux y accder par l'url www.mondomain.fr/nextcloud

J'ai configuré les DNS OVH en type A
DNS check me trouve bien mondomain.fr, mais pas nextcloud.mondomain.fr

qu'est ce que j'ai raté ?
PascalHambourg
Contributeur
Contributeur
Messages : 531
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

Si tu veux que ton site soit accessible via www.mondomain.fr/nextcloud, alors tu dois créer un enregistrement A et/ou AAAA (ou un enregistrement CNAME mais ne compliquons pas les choses) pour le nom de domaine figurant dans cet URL : www.mondomain.fr et non pas mondomain.fr ni nextcloud.mondomain.fr
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3756
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

Bonjour Pascal, j'ai bien créé un A et un AAA pour mondomaine.fr
La configuration du virtualhost est la suivante
<VirtualHost *:80>
ServerName files.domain-name.io
ServerAlias www.files.domain-name.io

# auto redirect HTTP to HTTPS
Redirect permanent / https://files.domain-name.io/
</VirtualHost>

<VirtualHost *:443>
ServerName files.domain-name.io
ServerAlias www.files.domain-name.io

DocumentRoot /var/www/nextcloud/

Protocols h2 http/1.1

# auto redirect www to non-www
<If "%{HTTP_HOST} == 'www.files.domain-name.io'">
Redirect permanent / https://files.domain-name.io/
</If>

# log files
ErrorLog /var/log/apache2/files.domain-name.io-error.log
CustomLog /var/log/apache2/files.domain-name.io-access.log combined

SSLEngine On
SSLCertificateFile /etc/letsencrypt/live/files.domain-name.io/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/files.domain-name.io/privkey.pem

# HSTS
<IfModule mod_headers.c>
Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"
</IfModule>

<Directory /var/www/nextcloud/>
Options +FollowSymlinks
AllowOverride All

<IfModule mod_dav.c>
Dav off
</IfModule>

SetEnv HOME /var/www/nextcloud
SetEnv HTTP_HOME /var/www/nextcloud
</Directory>
</VirtualHost>
en adaptant le nom de domaine évidement
J'ai réussi à crééer un certificat avec certbot pour mon domaine.fr
si je tente de me connecter à mondomaine.fr/next cloud, j'ai l'erreur suivante
Une erreur est survenue pendant une connexion à natal-letal.fr. SSL a reçu un enregistrement qui dépasse la longueur maximale autorisée.

Code d’erreur : SSL_ERROR_RX_RECORD_TOO_LONG
Si je lance certbot avec mondomaine.fr/nextcloud, le caractere / pose problème.
et j'ai essayé certbot avec nexcloud.mondomaine.fr, , mais le challenge échoue.
PascalHambourg
Contributeur
Contributeur
Messages : 531
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

piratebab a écrit : 24 oct. 2021, 09:48 j'ai bien créé un A et un AAA pour mondomaine.fr
Les déclarations ServerName et ServerAlias de tes vhosts contiennent "files.domain-name.io" et "www.files.domain-name.io", pas "mondomaine.fr". Donc ces vhosts ne seront pas utilisés pour une requête pour "mondomaine.fr", c'est le vhost par défaut qui sera utilisé.
piratebab a écrit : 24 oct. 2021, 09:48 Code d’erreur : SSL_ERROR_RX_RECORD_TOO_LONG
Au pif, ça peut être causé par le serveur qui répond en HTTP au lieu de HTTPS. Apache ou le vhost sur le port 443 peut être mal configuré pour TLS/SSL, ou bien il y a quelque chose en amont (iptables, relais de port ?) qui redirige le port 443 vers le port 80.
Tu peux vérifier avec

Code : Tout sélectionner

curl http://mondomaine.fr:443
piratebab a écrit : 24 oct. 2021, 09:48 Si je lance certbot avec mondomaine.fr/nextcloud, le caractere / pose problème.
Un certificat est publié pour un nom de domaine, pas un URL. /nextcloud n'a rien à faire là.
piratebab a écrit : 24 oct. 2021, 09:48 j'ai essayé certbot avec nexcloud.mondomaine.fr, , mais le challenge échoue.
Normal si tu n'as pas défini d'enregistrement DNS pour nexcloud.mondomaine.fr. Et de toute façon tes vhosts ne sont pas configurés pour ce nom de domaine.

Dernière chose : si tu définis des alias dans un vhost SSL, le certificat devra tous les inclure sinon il ne sera pas accepté pour les alias qu'il ne contient pas.
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3756
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

Merci pascal,
j'ai repris mon fichier VHOSt (je ne maitrise encore pas toutes les lignes.
Je peux me connecter avec
,
et je suis redirigé en https.
Répondre