démarre en mode console

Demande d'aide : c'est ici.
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3636
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

05 mars 2021, 15:54

il ne te reste que les drivers fbdev et vesa ?
Il n'en faut pas d'autres.
Quest ce que tu vois d'interessant dans le fichier Xorg.0.log. II démarre avecquel driver ?

Tu peux te concentrer sur les lignes qui commencent par EE (erreur)
marmocho
Membre
Membre
Messages : 38
Enregistré le : 08 févr. 2021, 21:07
Status : Hors ligne

05 mars 2021, 22:14

J'ai effectivement laissé ces deux fichiers fbdev et vesa.
Je ne saurai pas te dire avec quel driver ça démarre...
Et je ne trouve aucune ligne où est écrit EE. Il n'y a que du II ou ** ou == ainsi que des rectangle rouge, est-ce que ça correspondrai à EE?
C'est vraiment frustrant de ne pas réussir à copier le fichier sur une clef. Je vais creuser pour y arriver et vous poster le log!
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3636
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

06 mars 2021, 23:09

II s'est pour Information
Essaie de filtrer avec un cat /vat/log/Xorg.0.log | grep driver
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3636
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

07 mars 2021, 15:18

On va gagner du temps. Dis nous ce que tu as comme carte graphique
lspci | grep VGA

(les majuscules sont importantes), et on va te dire quel driver installer
tu avait quoi comme environnement de bureau gnoms ? KDE ? autres ?
marmocho
Membre
Membre
Messages : 38
Enregistré le : 08 févr. 2021, 21:07
Status : Hors ligne

08 mars 2021, 19:50

Je ne suis pas avec l'ordi, mais je pourrai renseigner ça demain.
Je viens aussi de me rendre compte que pour vous envoyer le log, je n'avais qu'à démarrer avec une live-usb... Je suis vraiment désolé de toutes ces complications pour me rendre compte de ça maintenant...
marmocho
Membre
Membre
Messages : 38
Enregistré le : 08 févr. 2021, 21:07
Status : Hors ligne

09 mars 2021, 18:18

Voila ce qu'on trouve dans var/log/Xorg.0.log

Code : Tout sélectionner

[  3875.445] 
X.Org X Server 1.19.2
Release Date: 2017-03-02
[  3875.454] X Protocol Version 11, Revision 0
[  3875.457] Build Operating System: Linux 4.19.0-13-amd64 x86_64 Debian
[  3875.461] Current Operating System: Linux ExMachina 4.9.0-14-amd64 #1 SMP Debian 4.9.246-2 (2020-12-17) x86_64
[  3875.461] Kernel command line: BOOT_IMAGE=/vmlinuz-4.9.0-14-amd64 root=/dev/mapper/syst_ExMachina-racine ro single
[  3875.466] Build Date: 09 December 2020  10:09:47AM
[  3875.469] xorg-server 2:1.19.2-1+deb9u7 (https://www.debian.org/support) 
[  3875.472] Current version of pixman: 0.34.0
[  3875.477] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  3875.477] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3875.488] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 21 14:59:44 2021
[  3875.488] (II) Loader magic: 0x563c18289e00
[  3875.488] (II) Module ABI versions:
[  3875.488] 	X.Org ANSI C Emulation: 0.4
[  3875.488] 	X.Org Video Driver: 23.0
[  3875.488] 	X.Org XInput driver : 24.1
[  3875.488] 	X.Org Server Extension : 10.0
[  3875.489] (--) using VT number 2

[  3875.489] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  3875.489] (II) xfree86: Adding drm device (/dev/dri/card0)
[  3875.629] (--) PCI:*(0:0:2:0) 8086:0412:1462:7817 rev 6, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[  3875.632] List of video drivers:
[  3875.634] 	amdgpu
[  3875.637] 	intel
[  3875.639] 	nouveau
[  3875.641] 	qxl
[  3875.643] 	radeon
[  3875.644] 	vmware
[  3875.646] 	modesetting
[  3875.647] 	fbdev
[  3875.648] 	vesa
[  3875.650] 	ati
[  3875.650] (II) LoadModule: "amdgpu"
[  3875.650] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[  3875.653] (II) Module amdgpu: vendor="X.Org Foundation"
[  3875.653] 	compiled for 1.19.0, module version = 1.2.0
[  3875.653] 	Module class: X.Org Video Driver
[  3875.653] 	ABI class: X.Org Video Driver, version 23.0
[  3875.653] (II) LoadModule: "intel"
[  3875.653] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  3875.657] (II) Module intel: vendor="X.Org Foundation"
[  3875.657] 	compiled for 1.19.0, module version = 2.99.917
[  3875.657] 	Module class: X.Org Video Driver
[  3875.657] 	ABI class: X.Org Video Driver, version 23.0
[  3875.657] (II) LoadModule: "nouveau"
[  3875.657] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[  3875.659] (II) Module nouveau: vendor="X.Org Foundation"
[  3875.659] 	compiled for 1.19.3, module version = 1.0.13
[  3875.659] 	Module class: X.Org Video Driver
[  3875.659] 	ABI class: X.Org Video Driver, version 23.0
[  3875.659] (II) LoadModule: "qxl"
[  3875.659] (II) Loading /usr/lib/xorg/modules/drivers/qxl_drv.so
[  3875.661] (II) Module qxl: vendor="X.Org Foundation"
[  3875.661] 	compiled for 1.19.0, module version = 0.1.4
[  3875.661] 	Module class: X.Org Video Driver
[  3875.661] 	ABI class: X.Org Video Driver, version 23.0
[  3875.661] (II) LoadModule: "radeon"
[  3875.661] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[  3875.665] (II) Module radeon: vendor="X.Org Foundation"
[  3875.665] 	compiled for 1.19.0, module version = 7.8.0
[  3875.665] 	Module class: X.Org Video Driver
[  3875.665] 	ABI class: X.Org Video Driver, version 23.0
[  3875.665] (II) LoadModule: "vmware"
[  3875.665] (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
[  3875.839] (II) Module vmware: vendor="X.Org Foundation"
[  3875.839] 	compiled for 1.19.0, module version = 13.2.1
[  3875.840] 	Module class: X.Org Video Driver
[  3875.840] 	ABI class: X.Org Video Driver, version 23.0
[  3875.840] (II) LoadModule: "modesetting"
[  3875.840] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  3875.840] (II) Module modesetting: vendor="X.Org Foundation"
[  3875.840] 	compiled for 1.19.2, module version = 1.19.2
[  3875.840] 	Module class: X.Org Video Driver
[  3875.840] 	ABI class: X.Org Video Driver, version 23.0
[  3875.840] (II) LoadModule: "fbdev"
[  3875.840] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  3875.840] (II) Module fbdev: vendor="X.Org Foundation"
[  3875.840] 	compiled for 1.19.0, module version = 0.4.4
[  3875.840] 	Module class: X.Org Video Driver
[  3875.840] 	ABI class: X.Org Video Driver, version 23.0
[  3875.840] (II) LoadModule: "vesa"
[  3875.840] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  3875.840] (II) Module vesa: vendor="X.Org Foundation"
[  3875.840] 	compiled for 1.19.0, module version = 2.3.4
[  3875.840] 	Module class: X.Org Video Driver
[  3875.840] 	ABI class: X.Org Video Driver, version 23.0
[  3875.840] (II) LoadModule: "ati"
[  3875.840] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[  3875.840] (II) Module ati: vendor="X.Org Foundation"
[  3875.840] 	compiled for 1.19.0, module version = 7.8.0
[  3875.840] 	Module class: X.Org Video Driver
[  3875.840] 	ABI class: X.Org Video Driver, version 23.0
[  3875.840] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  3875.841] (II) intel: Driver for Intel(R) HD Graphics
[  3875.841] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[  3875.841] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[  3875.841] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  3875.841] (II) FBDEV: driver for framebuffer: fbdev
[  3875.841] (II) VESA: driver for VESA chipsets: vesa
[  3875.877] (++) Using config file: "/root/xorg.conf.new"
[  3875.878] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3875.878] (==) ServerLayout "X.org Configured"
[  3875.878] (**) |-->Screen "Screen0" (0)
[  3875.878] (**) |   |-->Monitor "Monitor0"
[  3875.878] (**) |   |-->Device "Card0"
[  3875.878] (**) |-->Input Device "Mouse0"
[  3875.878] (**) |-->Input Device "Keyboard0"
[  3875.878] (==) Automatically adding devices
[  3875.878] (==) Automatically enabling devices
[  3875.878] (==) Automatically adding GPU devices
[  3875.878] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  3875.878] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  3875.878] 	Entry deleted from font path.
[  3875.878] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  3875.878] 	Entry deleted from font path.
[  3875.878] (**) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins,
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[  3875.878] (**) ModulePath set to "/usr/lib/xorg/modules"
[  3875.878] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  3875.878] (WW) Disabling Mouse0
[  3875.878] (WW) Disabling Keyboard0
[  3875.879] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
[  3875.879] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.917+git20161206-1 (Timo Aaltonen <tjaalton@debian.org>)
[  3875.879] (II) intel(0): SNA compiled for use with valgrind
[  3875.882] 
[  3875.887] 
Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.
[  3875.890] 
Your xorg.conf file is /root/xorg.conf.new

[  3875.892] To test the server, run 'X -config /root/xorg.conf.new'

[  3875.892] (EE) Server terminated with error (2). Closing log file.
Problème sur la sourie, le clavier et kbd (?) ...
marmocho
Membre
Membre
Messages : 38
Enregistré le : 08 févr. 2021, 21:07
Status : Hors ligne

09 mars 2021, 18:58

La carte graphique est la suivante

Code : Tout sélectionner

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3636
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

09 mars 2021, 19:56

Il y a un truc bizare:
Your xorg.conf file is /root/xorg.conf.new
Pourquoi il va chercher un fichier de conf dans root ?
Tu essaies de démarrer en mode graphique en utilisateur root ?

Peux tu nous montrer ce qu'il y a dans ce fichier
marmocho
Membre
Membre
Messages : 38
Enregistré le : 08 févr. 2021, 21:07
Status : Hors ligne

09 mars 2021, 20:38

/root/xorg.conf.new

Code : Tout sélectionner

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/X11/misc"
	FontPath     "/usr/share/fonts/X11/cyrillic"
	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/Type1"
	FontPath     "/usr/share/fonts/X11/100dpi"
	FontPath     "/usr/share/fonts/X11/75dpi"
	FontPath     "built-ins"
EndSection

Section "Module"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"              	# [<bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "Backlight"          	# <str>
        #Option     "CustomEDID"         	# <str>
        #Option     "DRI"                	# <str>
        #Option     "Present"            	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "VideoKey"           	# <i>
        #Option     "Tiling"             	# [<bool>]
        #Option     "LinearFramebuffer"  	# [<bool>]
        #Option     "HWRotation"         	# [<bool>]
        #Option     "VSync"              	# [<bool>]
        #Option     "PageFlip"           	# [<bool>]
        #Option     "SwapbuffersWait"    	# [<bool>]
        #Option     "TripleBuffer"       	# [<bool>]
        #Option     "XvPreferOverlay"    	# [<bool>]
        #Option     "HotPlug"            	# [<bool>]
        #Option     "ReprobeOutputs"     	# [<bool>]
        #Option     "XvMC"               	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "VirtualHeads"       	# <i>
        #Option     "TearFree"           	# [<bool>]
        #Option     "PerCrtcPixmaps"     	# [<bool>]
        #Option     "FallbackDebug"      	# [<bool>]
        #Option     "DebugFlushBatches"  	# [<bool>]
        #Option     "DebugFlushCaches"   	# [<bool>]
        #Option     "DebugWait"          	# [<bool>]
        #Option     "BufferCache"        	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
marmocho
Membre
Membre
Messages : 38
Enregistré le : 08 févr. 2021, 21:07
Status : Hors ligne

09 mars 2021, 20:44

marmocho a écrit : 09 mars 2021, 20:38 /root/xorg.conf.new

Code : Tout sélectionner

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/X11/misc"
	FontPath     "/usr/share/fonts/X11/cyrillic"
	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/Type1"
	FontPath     "/usr/share/fonts/X11/100dpi"
	FontPath     "/usr/share/fonts/X11/75dpi"
	FontPath     "built-ins"
EndSection

Section "Module"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"              	# [<bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "Backlight"          	# <str>
        #Option     "CustomEDID"         	# <str>
        #Option     "DRI"                	# <str>
        #Option     "Present"            	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "VideoKey"           	# <i>
        #Option     "Tiling"             	# [<bool>]
        #Option     "LinearFramebuffer"  	# [<bool>]
        #Option     "HWRotation"         	# [<bool>]
        #Option     "VSync"              	# [<bool>]
        #Option     "PageFlip"           	# [<bool>]
        #Option     "SwapbuffersWait"    	# [<bool>]
        #Option     "TripleBuffer"       	# [<bool>]
        #Option     "XvPreferOverlay"    	# [<bool>]
        #Option     "HotPlug"            	# [<bool>]
        #Option     "ReprobeOutputs"     	# [<bool>]
        #Option     "XvMC"               	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "VirtualHeads"       	# <i>
        #Option     "TearFree"           	# [<bool>]
        #Option     "PerCrtcPixmaps"     	# [<bool>]
        #Option     "FallbackDebug"      	# [<bool>]
        #Option     "DebugFlushBatches"  	# [<bool>]
        #Option     "DebugFlushCaches"   	# [<bool>]
        #Option     "DebugWait"          	# [<bool>]
        #Option     "BufferCache"        	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
J'ai pu en effet essayé des startx en root... pas bien?
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3636
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

10 mars 2021, 00:00

disons que ça ne nous aide pas à comprendre quel est le probleme avec l'utilisateur normal. essaie de faire un boot normal. Dans startx ou quoique ce soit. Tu éteint l'ordi, reboote sur le live, et copie le log de xorg
marmocho
Membre
Membre
Messages : 38
Enregistré le : 08 févr. 2021, 21:07
Status : Hors ligne

10 mars 2021, 09:11

$ startx

Code : Tout sélectionner

[  3875.445] 
X.Org X Server 1.19.2
Release Date: 2017-03-02
[  3875.454] X Protocol Version 11, Revision 0
[  3875.457] Build Operating System: Linux 4.19.0-13-amd64 x86_64 Debian
[  3875.461] Current Operating System: Linux ExMachina 4.9.0-14-amd64 #1 SMP Debian 4.9.246-2 (2020-12-17) x86_64
[  3875.461] Kernel command line: BOOT_IMAGE=/vmlinuz-4.9.0-14-amd64 root=/dev/mapper/syst_ExMachina-racine ro single
[  3875.466] Build Date: 09 December 2020  10:09:47AM
[  3875.469] xorg-server 2:1.19.2-1+deb9u7 (https://www.debian.org/support) 
[  3875.472] Current version of pixman: 0.34.0
[  3875.477] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  3875.477] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3875.488] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 21 14:59:44 2021
[  3875.488] (II) Loader magic: 0x563c18289e00
[  3875.488] (II) Module ABI versions:
[  3875.488] 	X.Org ANSI C Emulation: 0.4
[  3875.488] 	X.Org Video Driver: 23.0
[  3875.488] 	X.Org XInput driver : 24.1
[  3875.488] 	X.Org Server Extension : 10.0
[  3875.489] (--) using VT number 2

[  3875.489] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  3875.489] (II) xfree86: Adding drm device (/dev/dri/card0)
[  3875.629] (--) PCI:*(0:0:2:0) 8086:0412:1462:7817 rev 6, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[  3875.632] List of video drivers:
[  3875.634] 	amdgpu
[  3875.637] 	intel
[  3875.639] 	nouveau
[  3875.641] 	qxl
[  3875.643] 	radeon
[  3875.644] 	vmware
[  3875.646] 	modesetting
[  3875.647] 	fbdev
[  3875.648] 	vesa
[  3875.650] 	ati
[  3875.650] (II) LoadModule: "amdgpu"
[  3875.650] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[  3875.653] (II) Module amdgpu: vendor="X.Org Foundation"
[  3875.653] 	compiled for 1.19.0, module version = 1.2.0
[  3875.653] 	Module class: X.Org Video Driver
[  3875.653] 	ABI class: X.Org Video Driver, version 23.0
[  3875.653] (II) LoadModule: "intel"
[  3875.653] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  3875.657] (II) Module intel: vendor="X.Org Foundation"
[  3875.657] 	compiled for 1.19.0, module version = 2.99.917
[  3875.657] 	Module class: X.Org Video Driver
[  3875.657] 	ABI class: X.Org Video Driver, version 23.0
[  3875.657] (II) LoadModule: "nouveau"
[  3875.657] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[  3875.659] (II) Module nouveau: vendor="X.Org Foundation"
[  3875.659] 	compiled for 1.19.3, module version = 1.0.13
[  3875.659] 	Module class: X.Org Video Driver
[  3875.659] 	ABI class: X.Org Video Driver, version 23.0
[  3875.659] (II) LoadModule: "qxl"
[  3875.659] (II) Loading /usr/lib/xorg/modules/drivers/qxl_drv.so
[  3875.661] (II) Module qxl: vendor="X.Org Foundation"
[  3875.661] 	compiled for 1.19.0, module version = 0.1.4
[  3875.661] 	Module class: X.Org Video Driver
[  3875.661] 	ABI class: X.Org Video Driver, version 23.0
[  3875.661] (II) LoadModule: "radeon"
[  3875.661] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[  3875.665] (II) Module radeon: vendor="X.Org Foundation"
[  3875.665] 	compiled for 1.19.0, module version = 7.8.0
[  3875.665] 	Module class: X.Org Video Driver
[  3875.665] 	ABI class: X.Org Video Driver, version 23.0
[  3875.665] (II) LoadModule: "vmware"
[  3875.665] (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
[  3875.839] (II) Module vmware: vendor="X.Org Foundation"
[  3875.839] 	compiled for 1.19.0, module version = 13.2.1
[  3875.840] 	Module class: X.Org Video Driver
[  3875.840] 	ABI class: X.Org Video Driver, version 23.0
[  3875.840] (II) LoadModule: "modesetting"
[  3875.840] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  3875.840] (II) Module modesetting: vendor="X.Org Foundation"
[  3875.840] 	compiled for 1.19.2, module version = 1.19.2
[  3875.840] 	Module class: X.Org Video Driver
[  3875.840] 	ABI class: X.Org Video Driver, version 23.0
[  3875.840] (II) LoadModule: "fbdev"
[  3875.840] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  3875.840] (II) Module fbdev: vendor="X.Org Foundation"
[  3875.840] 	compiled for 1.19.0, module version = 0.4.4
[  3875.840] 	Module class: X.Org Video Driver
[  3875.840] 	ABI class: X.Org Video Driver, version 23.0
[  3875.840] (II) LoadModule: "vesa"
[  3875.840] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  3875.840] (II) Module vesa: vendor="X.Org Foundation"
[  3875.840] 	compiled for 1.19.0, module version = 2.3.4
[  3875.840] 	Module class: X.Org Video Driver
[  3875.840] 	ABI class: X.Org Video Driver, version 23.0
[  3875.840] (II) LoadModule: "ati"
[  3875.840] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[  3875.840] (II) Module ati: vendor="X.Org Foundation"
[  3875.840] 	compiled for 1.19.0, module version = 7.8.0
[  3875.840] 	Module class: X.Org Video Driver
[  3875.840] 	ABI class: X.Org Video Driver, version 23.0
[  3875.840] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  3875.841] (II) intel: Driver for Intel(R) HD Graphics
[  3875.841] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[  3875.841] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[  3875.841] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  3875.841] (II) FBDEV: driver for framebuffer: fbdev
[  3875.841] (II) VESA: driver for VESA chipsets: vesa
[  3875.877] (++) Using config file: "/root/xorg.conf.new"
[  3875.878] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3875.878] (==) ServerLayout "X.org Configured"
[  3875.878] (**) |-->Screen "Screen0" (0)
[  3875.878] (**) |   |-->Monitor "Monitor0"
[  3875.878] (**) |   |-->Device "Card0"
[  3875.878] (**) |-->Input Device "Mouse0"
[  3875.878] (**) |-->Input Device "Keyboard0"
[  3875.878] (==) Automatically adding devices
[  3875.878] (==) Automatically enabling devices
[  3875.878] (==) Automatically adding GPU devices
[  3875.878] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  3875.878] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  3875.878] 	Entry deleted from font path.
[  3875.878] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  3875.878] 	Entry deleted from font path.
[  3875.878] (**) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins,
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[  3875.878] (**) ModulePath set to "/usr/lib/xorg/modules"
[  3875.878] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  3875.878] (WW) Disabling Mouse0
[  3875.878] (WW) Disabling Keyboard0
[  3875.879] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
[  3875.879] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.917+git20161206-1 (Timo Aaltonen <tjaalton@debian.org>)
[  3875.879] (II) intel(0): SNA compiled for use with valgrind
[  3875.882] 
[  3875.887] 
Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.
[  3875.890] 
Your xorg.conf file is /root/xorg.conf.new

[  3875.892] To test the server, run 'X -config /root/xorg.conf.new'

[  3875.892] (EE) Server terminated with error (2). Closing log file.
Je ne comprends pas pourquoi on retrouve les drivers alors que je les ai virés. Et ça dit toujours que xorg.conf est dans root.
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3636
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

10 mars 2021, 09:58

Il charge le module vesa.
Essaie de virer ou de renommer ce fichier xorg.conf dans root
Un serveur x n'a plus besoin de ce fichier depuis longtemps
marmocho
Membre
Membre
Messages : 38
Enregistré le : 08 févr. 2021, 21:07
Status : Hors ligne

10 mars 2021, 12:06

Rien à faire, même en supprimant le fichier xorg.conf.new de /root/, le log de var/log/Xorg.0.log dit toujours la même chose et le démarrage est le même...
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3636
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

10 mars 2021, 17:28

C'est mysterieux ton histoire. On va installer les drivers libre intel et recréer un xorg.conf

Code : Tout sélectionner

#apt install xserver-xorg-video-intel
si ça n'est pas suffisant:

Code : Tout sélectionner

X -configure
Si tu n'as rien qui ressemble à un xorg.conf dans /etc/X11, il l'a créé ailleurs et il faut que tu déplaces le fichier

Code : Tout sélectionner

cp /root/xorg.conf.new /etc/X11/xorg.conf
marmocho
Membre
Membre
Messages : 38
Enregistré le : 08 févr. 2021, 21:07
Status : Hors ligne

10 mars 2021, 19:05

Toujours pareil...
J'ai copier tous les fichiers (xorg.conf dans /etc/X11/ et xorg.conf.new dans /root/ (qu'ai même couper d'ailleurs pour redémarrer ensuite) et le Xorg.0.log si besoin. Mais tout ça ne donne rien de mieux, On retrouve toujours le fameux .new chez root...
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3636
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

10 mars 2021, 20:18

Alors là, je seche. Si quelqu'un a une idée ....
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3636
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

11 mars 2021, 09:17

Je suis subitement pris d’un doute. Lorsque tu dis que ça démarre en mode console, est-ce un vrai mode console. Pas en mode rescue ou il te demande de taper ctrl D ou le mot de passe root.
en mode console, tu arrives sur une ligne qui te permet de démarrer en mode utilisateur normal.
marmocho
Membre
Membre
Messages : 38
Enregistré le : 08 févr. 2021, 21:07
Status : Hors ligne

11 mars 2021, 10:21

Voici le premier post
marmocho a écrit : 28 févr. 2021, 19:00 Salut à tou-te-s,
suite à une mise à jour d'une debian9, l'ordi démarre en mode console tty1.Aaprès m'avoir demandé mon login et mot de passe utilisateur en mode console, il reste en mode console.
Je tape startx et voici ce que j'obtiens: Image
L'un-e d'entre vous pourrait m'en dire quelque chose?
Merci bien
Comme je le dis dans le premier message, l'ordi se lance sur l'écran :

Code : Tout sélectionner

Debian GNU/Linux 9 Nom_Ordi tty1
Nom_Ordi login: Nom_User
Password:
Last login: Wed Mar 10 18:54:21 CET 2021 on tty1
Linux Nom_Ordi 4.9.0-14-amd64 #1 SMP Debian GNU Linux are free software;
the exact distribution terms for each program are described in the individual files in usr/share/doc/*/copyraight.
Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent permitted by applicable law.
You have new mail.
Nom_User@Nom_Ordi:~$
Est-ce qu'est bien ce qu'on appelle le mode console tty1?
Si la réponse est oui, c'est qu'on aura pas plus avancé, n'est-ce pas?
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3373
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

11 mars 2021, 16:45

Hello,
Essayer avec un fichier Xorg.conf vide.

Tu n'utilises pas le bon fichier, tu ne devrais pas faire de startx en "root"
[ 3875.877] (++) Using config file: "/root/xorg.conf.new"
Tu peux essayer avec un Xorg. conf vide

Code : Tout sélectionner

# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
# > /etc/X11/xorg.conf
# shutdown -r now

Ou avec un Xorg.conf minimal:

Code : Tout sélectionner

Section "Device"
    Identifier  "intel"
    Driver      "intel"
EndSection
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Répondre