pilote propriétaire nvidia gforce 730

Demande d'aide : c'est ici.
Répondre
Avatar du membre
debianjam
Membre
Membre
Messages : 320
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

14 mars 2021, 00:31

salut
j'ai fait un apt autoremove, ça a déclenché comme suit :

Code : Tout sélectionner

root@debian:~# apt autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  dkms glx-alternative-mesa glx-alternative-nvidia glx-diversions libgles1
  libnvidia-cbl libnvidia-cfg1 libnvidia-eglcore libnvidia-glcore
  libnvidia-glvkspirv libnvidia-ml1 libnvidia-rtcore libopengl0 libxnvctrl0
  linux-compiler-gcc-8-x86 linux-headers-5.9.0-0.bpo.5-amd64
  linux-headers-5.9.0-0.bpo.5-common linux-headers-amd64 linux-kbuild-5.9
  nvidia-alternative nvidia-driver-bin nvidia-egl-common
  nvidia-installer-cleanup nvidia-kernel-common nvidia-kernel-dkms
  nvidia-kernel-support nvidia-legacy-check nvidia-modprobe nvidia-settings
  nvidia-support nvidia-vulkan-common update-glx
0 mis à jour, 0 nouvellement installés, 32 à enlever et 0 non mis à jour.
Après cette opération, 258 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 179207 fichiers et répertoires déjà installés.)
Suppression de nvidia-kernel-dkms (460.39-1~bpo10+1) ...

------------------------------
Deleting module version: 460.39
completely from the DKMS tree.
------------------------------
Done.
Suppression de dkms (2.6.1-4) ...
Suppression de libnvidia-cfg1:amd64 (460.39-1~bpo10+1) ...
Suppression de nvidia-kernel-support (460.39-1~bpo10+1) ...
Suppression de nvidia-settings (460.32.03-1~bpo10+1) ...
Suppression de libgles1:amd64 (1.1.0-1) ...
Suppression de libnvidia-cbl:amd64 (460.39-1~bpo10+1) ...
Suppression de libnvidia-eglcore:amd64 (460.39-1~bpo10+1) ...
Suppression de libnvidia-glcore:amd64 (460.39-1~bpo10+1) ...
Suppression de libnvidia-glvkspirv:amd64 (460.39-1~bpo10+1) ...
Suppression de nvidia-driver-bin (460.39-1~bpo10+1) ...
Suppression de libnvidia-ml1:amd64 (460.39-1~bpo10+1) ...
Suppression de libnvidia-rtcore:amd64 (460.39-1~bpo10+1) ...
Suppression de libopengl0:amd64 (1.1.0-1) ...
Suppression de libxnvctrl0:amd64 (460.32.03-1~bpo10+1) ...
Suppression de linux-headers-amd64 (5.9.15-1~bpo10+1) ...
Suppression de linux-headers-5.9.0-0.bpo.5-amd64 (5.9.15-1~bpo10+1) ...
Suppression de linux-compiler-gcc-8-x86 (5.9.15-1~bpo10+1) ...
Suppression de linux-headers-5.9.0-0.bpo.5-common (5.9.15-1~bpo10+1) ...
Suppression de linux-kbuild-5.9 (5.9.15-1~bpo10+1) ...
Suppression de nvidia-egl-common (460.39-1~bpo10+1) ...
Suppression de nvidia-kernel-common (20151021+12~bpo10+1) ...
Suppression de nvidia-modprobe (460.32.03-1~bpo10+1) ...
Suppression de nvidia-support (20151021+12~bpo10+1) ...
Suppression de nvidia-vulkan-common (460.39-1~bpo10+1) ...
Suppression de nvidia-alternative (460.39-1~bpo10+1) ...
Suppression de glx-alternative-nvidia (1.2.0~bpo10+1) ...
update-alternatives: avertissement: forçage de la réinstallation de l'alternative /usr/lib/mesa-diverted car le groupe de liens glx est cassé
update-alternatives: avertissement: création de /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1 abandonnée car le fichier associé /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv1_CM.so.1 (du groupe de liens glx) n'existe pas
Suppression de glx-diversions (1.2.0~bpo10+1) ...
Suppression de glx-alternative-mesa (1.2.0~bpo10+1) ...
Suppression de nvidia-legacy-check (460.39-1~bpo10+1) ...
Suppression de nvidia-installer-cleanup (20151021+12~bpo10+1) ...
Suppression de update-glx (1.2.0~bpo10+1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-10) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.133+deb10u1) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-14-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
2020/Debian10(buster)64 ; G3.30.2 ; mémoire : 3,7Gio ; i5 3450 @3.10Ghz x4 ; c.g. NV106 (intégrée Intel Ivybridge Desktop) ou asus gt730 2Gio
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1207
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

14 mars 2021, 01:12

Tu as fourni :
debianjam a écrit : 04 mars 2021, 16:16

Code : Tout sélectionner

utilisateur1@debian:~$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
donc ton modèle c'est : GK208

ici => nouveau.freedesktop.org/CodeNames : NVE0 family (Kepler)
on trouve ce modèle.

Donc ta carte est prise en charge pour la 2D par le paquet : xserver-xorg-video-nouveau

Dans sa description, on peut lire :
Ce paquet fournit la gestion 2D, ce qui inclut l'accélération EXA, Xv et RandR. Les fonctionnalités 3D sont fournies par le paquet libgl1-mesa-dri

Donc selon toute vraisemblance,
ta carte devrait fonctionner correctement avec simplement ces 2 paquets et leurs strictes dépendances.
Debian testing/stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 320
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

14 mars 2021, 10:51

salut
ces deux paquets sont installés vu dans synaptic : xserver-xorg-video-nouveau et libgl1-mesa-dri
il se peut, j'ai cette impression, que la suppression des paquets nvidia opérée par apt autoremove ait redonné de la vivacité (difficile à mesurer mais je dirais environ 10% ou 20%) au fonctionnement de l'ordinateur ou de son affichage, cela est il possible, est ce l'effet de batteries mieux rechargées ou moins de confusion dans le fonctionnement des pilotes ?

j'ai appliqué la commande vue dans la page des codes nvidia mais il n'y a pas de réponse

Code : Tout sélectionner

utilisateur1@debian:~$ dmesg | grep -i chipset
dmesg: échec de lecture du tampon de noyau: Opération non permise
utilisateur1@debian:~$ su -
Mot de passe : 
root@debian:~# dmesg | grep -i chipset0
root@debian:~#
2020/Debian10(buster)64 ; G3.30.2 ; mémoire : 3,7Gio ; i5 3450 @3.10Ghz x4 ; c.g. NV106 (intégrée Intel Ivybridge Desktop) ou asus gt730 2Gio
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1207
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

14 mars 2021, 12:36

et maintenant que te renvoient :

Code : Tout sélectionner

$ apt list *nvidia* | grep install

$ dpkg-query -l | grep -i nvidia
Debian testing/stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 320
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

14 mars 2021, 12:40

NB : je ne souhaite pas obligatoirement utiliser un pilote propriétaire si le pilote nouveau suffit et fonctionne pour mes utilisations dans mon installation
voici les réponses :

Code : Tout sélectionner

root@debian:~# apt list *nvidia* | grep install

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

nvidia-installer-cleanup/stable 20151021+9 amd64 [configuration restante]
root@debian:~# dpkg-query -l | grep -i nvidia
rc  glx-alternative-nvidia                1.2.0~bpo10+1                                amd64        allows the selection of NVIDIA as GLX provider
rc  nvidia-alternative                    460.39-1~bpo10+1                             amd64        allows the selection of NVIDIA as GLX provider
rc  nvidia-installer-cleanup              20151021+12~bpo10+1                          amd64        cleanup after driver installation with the nvidia-installer
rc  nvidia-kernel-common                  20151021+12~bpo10+1                          amd64        NVIDIA binary kernel module support files
rc  nvidia-kernel-support                 460.39-1~bpo10+1                             amd64        NVIDIA binary kernel module support files
rc  nvidia-legacy-check                   460.39-1~bpo10+1                             amd64        check for NVIDIA GPUs requiring a legacy driver
rc  nvidia-support                        20151021+12~bpo10+1                          amd64        NVIDIA binary graphics driver support files
root@debian:~# 
2020/Debian10(buster)64 ; G3.30.2 ; mémoire : 3,7Gio ; i5 3450 @3.10Ghz x4 ; c.g. NV106 (intégrée Intel Ivybridge Desktop) ou asus gt730 2Gio
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1207
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

14 mars 2021, 13:32

Apparemment, le ménage n'a pas était fait à fond.

Dans synaptic tu as un filtre qui affiche les "résidus" d'install (config restante)
tu peux sélectionner tous ces paquets pour Suppression complète (purge)

après cela tu peux revérifier les paquets installés qui ne sont plus nécessaires et les supprimer complètement.
et
revérifie les résidus d'install histoire d'être certain d'avoir un système clean

Ensuite, tu peux aussi refaire : # apt autoclean
pour supprimer les archives .deb qui ne sont plus utiles.
Debian testing/stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 320
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

15 mars 2021, 11:52

salut
je ne comprends pas grand chose à ce système de filtres
2020/Debian10(buster)64 ; G3.30.2 ; mémoire : 3,7Gio ; i5 3450 @3.10Ghz x4 ; c.g. NV106 (intégrée Intel Ivybridge Desktop) ou asus gt730 2Gio
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1207
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

15 mars 2021, 12:05

Il n'y a aucune difficulté,
dans le panneau latéral tu as entre autre :
  • État
  • Filtres personnalisés
Image

Il n'y a rien à modifier juste sélectionner une entrée (bouton)
puis choisir la bonne liste pour afficher les paquets correspondants
Debian testing/stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 320
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

15 mars 2021, 12:50

merci je vois mieux comme ça
alors il y a ceci :
Capture d’écran du 2021-03-15 12-49-01.png


donc je proède à l'élimination complète de tous :
Capture d’écran du 2021-03-15 12-56-56.png


et voici apt autoclean :

Code : Tout sélectionner

root@debian:~# apt autoclean
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Del vlc-plugin-qt 3.0.11-0+deb10u1 [1 146 kB]
Del libldap-common 2.4.47+dfsg-3+deb10u5 [90,0 kB]
Del linux-libc-dev 5.10.13-1~bpo10+1 [1 284 kB]
Del vlc-bin 3.0.11-0+deb10u1 [161 kB]
Del vlc-plugin-video-output 3.0.11-0+deb10u1 [269 kB]
Del libldap-2.4-2 2.4.47+dfsg-3+deb10u5 [225 kB]
Del linux-compiler-gcc-8-x86 5.10.13-1~bpo10+1 [254 kB]
Del vlc-l10n 3.0.11-0+deb10u1 [5 834 kB]
Del libvlc-bin 3.0.11-0+deb10u1 [125 kB]
Del vlc-plugin-video-splitter 3.0.11-0+deb10u1 [140 kB]
Del vlc-plugin-skins2 3.0.11-0+deb10u1 [564 kB]
Del chromium-sandbox 88.0.4324.146-1~deb10u1 [145 kB]
Del vlc-plugin-samba 3.0.11-0+deb10u1 [127 kB]
Del vlc-plugin-visualization 3.0.11-0+deb10u1 [146 kB]
Del vlc-plugin-base 3.0.11-0+deb10u1 [2 947 kB]
Del libzstd1 1.3.8+dfsg-3+deb10u1 [236 kB]
Del chromium-common 88.0.4324.146-1~deb10u1 [1 418 kB]
Del libvlccore9 3.0.11-0+deb10u1 [533 kB]
Del vlc-data 3.0.11-0+deb10u1 [448 kB]
Del vlc-plugin-notify 3.0.11-0+deb10u1 [126 kB]
Del chromium 88.0.4324.146-1~deb10u1 [54,3 MB]
Del libvlc5 3.0.11-0+deb10u1 [174 kB]
Del vlc 3.0.11-0+deb10u1 [141 kB]
root@debian:~# 
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
2020/Debian10(buster)64 ; G3.30.2 ; mémoire : 3,7Gio ; i5 3450 @3.10Ghz x4 ; c.g. NV106 (intégrée Intel Ivybridge Desktop) ou asus gt730 2Gio
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1207
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

15 mars 2021, 13:10

Maintenant que tu as fait un bon ménage,

dpkg-query -l | grep -i nvidia ne doit plus rien renvoyer

je pense que tu pourrais si cela ne fonctionne toujours pas comme espéré,
refaire un :

dpkg-reconfigure xserver-xorg-video-nouveau libgl1-mesa-dri

pour refaire une config clean sans aucune interférence due à d'anciennes config (vu que tu as tout supprimé)
Debian testing/stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 320
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

18 mars 2021, 09:14

Salut
Merci fait le 18/03
2020/Debian10(buster)64 ; G3.30.2 ; mémoire : 3,7Gio ; i5 3450 @3.10Ghz x4 ; c.g. NV106 (intégrée Intel Ivybridge Desktop) ou asus gt730 2Gio
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1207
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

18 mars 2021, 09:54

debianjam a écrit : 18 mars 2021, 09:14 Merci fait le 18/03

... et ça marche bien maintenant ?
Debian testing/stable - XFCE
Répondre