Générateur de sources.list du wiki périmé ou non ? Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
--gilles--
Membre actif
Membre actif
Messages : 505
Enregistré le : 24 août 2016, 19:35
Localisation : Gnome 3.36 - debian 11 bullseye
Status : Hors ligne

06 déc. 2020, 10:25

Bonjour, j'ai cette erreur dans « Logiciels » ( gnome-software ) pour passer une machine avec buster en automatique de 10.6 à 10.7 :

Impossible de télécharger les mises à jour depuis « extensions.gnome.org »:
failed to download https://extensions.gnome.org//static/extensions.json:
Cannot resolve hostname


D'après des recherches Internet, je dois regarder :

journalctl _COMM=gnome-software -b

Ce qui donne :

déc. 06 09:50:43 mon-ordinateur gnome-software[1359]: not handling error failed for action refresh: failed to refresh cache: W: Le dépôt « http://ftp.fr.debian.org/debian buster InRelease » a modifié sa valeur « Version » de « 10.6 » à « 10.7 »
E: Le dépôt http://ftp.fr.debian.org/debian buster/updates Release n'a pas de fichier Release.
W: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
W: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.



Si je comprends bien mon sources.list que j'avais recopié sur le wiki ne serait plus bon, il faudrait maintenant du https, c'est ce que j'ai compris dans le man d'apt-secure. Ou est-ce autre chose ?
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell
--gilles--
Membre actif
Membre actif
Messages : 505
Enregistré le : 24 août 2016, 19:35
Localisation : Gnome 3.36 - debian 11 bullseye
Status : Hors ligne

06 déc. 2020, 11:49

Si c'était cela, il faut l'https, j'ai mis

deb https://deb.debian.org/debian/ buster main
deb https://deb.debian.org/debian-security buster/updates main
deb https://deb.debian.org/debian/ buster-updates main


comme sources.list et j'ai pu mettre à jour en automatique avec Logiciels.
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3541
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

06 déc. 2020, 15:01

La doc officielle debian est en http, pas de https

https://wiki.debian.org/SourcesList

Code : Tout sélectionner

deb http://deb.debian.org/debian buster main contrib non-free
deb-src http://deb.debian.org/debian buster main contrib non-free

deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ buster/updates main contrib non-free

deb http://deb.debian.org/debian buster-updates main contrib non-free
deb-src http://deb.debian.org/debian buster-updates main contrib non-free
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1151
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

08 déc. 2020, 10:37

Salut !
--gilles-- a écrit :
06 déc. 2020, 10:25
Impossible de télécharger les mises à jour depuis « extensions.gnome.org »:
failed to download https://extensions.gnome.org//static/extensions.json:
Cannot resolve hostname
Ce que je ne comprends pas (je ne suis plus utilisateur de Gnome :101: je le fuis depuis 3 :076: )

c'est que ton Message d'erreur ne fasse pas référence à : http://deb.debian.org/....

mais à : https://extensions.gnome.org//static/extensions.json

qui semble mal formé ???? => ...gnome.org//static... les 2 slash ne doivent pas passer :017:
Debian testing/stable - XFCE
--gilles--
Membre actif
Membre actif
Messages : 505
Enregistré le : 24 août 2016, 19:35
Localisation : Gnome 3.36 - debian 11 bullseye
Status : Hors ligne

10 déc. 2020, 14:04

Bonjour desix et piratebab, en fait c'est bien lié à Gnome, plus exactement à Logiciels ( gnome-software ), c'est une sécurisation en plus que demande gnome-software si on choisi l'option mise à jour manuelle :


https://debian-facile.org/git/ProjetsDF ... 8-admin.md

Image

Comme la personne pour qui j'ai installé est un super-newbie, il y a 5 ans il ignorait comment copier-coller, je ne vais pas lui demander de toucher au Terminal, ni lui mettre les mises à jour en tâche de fond avec les unattended-upgrade, si il ouvre firefox pendant une mise à jour où firefox est concerné, il va dire que l'ordinateur ne marche plus et il va m'appeler, il se contentera de la mise à jour manuelle.
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1151
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

10 déc. 2020, 16:21

--gilles-- a écrit :
10 déc. 2020, 14:04
Comme la personne pour qui j'ai installé est un super-newbie
:good:

Ha! Oui !... on connaît ça ! :yahoo:

Faut une bonne dose de :033: et de patience ...
:drinks:

@+

:006:
Debian testing/stable - XFCE
Répondre