OCS DEBIAN

Demande d'aide : c'est ici.
Répondre
Theo R
Messages : 2
Enregistré le : 07 oct. 2020, 08:55
Status : Hors ligne

07 oct. 2020, 09:10

Bonjour,

Je suis en alternance en BTS SIO, j'ai été amené a monté un serveur OCS sur un OS debian ça a été une premiere pour moi j'ai été vite perdu ^^ mais aujourd'hui OCS fonctionne via le web, j'utilise MariaDB pour la BDD, mais un problème ce pose depuis le début j'ai des ordinateurs qui ne remonte pas ou qui remonte que quand l'ordinateur est en cours d'utilisation... Alors que le but premier est d'inventorié les ordinateurs du parc informatique.
En faisant des test comme dit plus haut j'allume une machine cliente ocs étant installé ce lance ect, il remonte bien sur mon ocs, j’éteins la machine 10 minutes plus tard la machine n'est plus dans mon ocs

Ma problématique est la suivante : Certaine machines sont inventorié et ne bougent plus alors que de nouvelle machines sont inventorié que quand elles sont en cours d'utilisation, d'où ça peut venir ? de mon serveur OCS ? de l'agent OCS ?

Bien Cordialement Theo R
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3476
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

08 oct. 2020, 16:35

Bonjour,
est ce que tu as pu identifier si il y a un lien entre les machines qui restent identifiées, et entre celles qui ne le sont pas (même OS, même sous réseau ...).Sinon, de prime abord, je fouillerai du coté de la config du serveur OCS.
Un autre truc à tester: est ce que ton serveur OCS écrit bien tout dans la BDD ? Est ce qu'il ne garderait pas en cache l'info un petit moment avant de l'écrire dans la BDD, et ainsi la rendre persistante ?
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3476
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

08 oct. 2020, 16:43

autre question ;: comment ton serveur detecte t il les clients ? par IP ?
Theo R
Messages : 2
Enregistré le : 07 oct. 2020, 08:55
Status : Hors ligne

09 oct. 2020, 08:49

Bonjour,

Alors on a un parc informatique assez important qui va de windows XP a 10 passant par du 7 et d'autres ... aussi on est passé d'un OCS sous windows 7 en 2.1 pour migrer le serveur que j'ai monté sous debian en version 2.7 donc l'agent sur les anciens PC est en 2.1 ça peut jouer je pense, les nouveaux PC sont avec l'agent 2.7, le serveur écrit bien tout dans la BDD, et mon serveur détecte les clients via leurs adresses MAC. :)
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3476
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

09 oct. 2020, 10:14

Tu n'as pas répondu à la question sur quellle famille de PC pose probleme.
Tout ce configure cotéserveur, et compris les agents windows.
Au fait, sont ils bien installé en mode service afin d'étre completement transparent pour l'utilsateur.
Vérifie les paramètres dans https://wiki.ocsinventory-ng.org/03.Bas ... al-options
Répondre