Récupérer Deluge 2.0.3-3 dans les dépôts

Demande d'aide : c'est ici.
Répondre
airone
Membre
Membre
Messages : 24
Enregistré le : 30 oct. 2016, 21:49
Status : Hors ligne

21 sept. 2020, 14:11

Salut à la communauté debianeuse.
Je suis actuellement sous Jessie 8* et je cherche à installer Deluge 2.0.3-3 mais je ne trouve (fort logiquement) dans mes dépôts que la version 1..3.10 que j'utilise actuellement mais qui me pénalise pour certains trackers car elle ne supporte pas TLS 1.2
En consultant cette page https://packages.debian.org/sid/all/deluge/download du site il est fortement conseillé de passer par synaptic plutôt que de l'installer soi-même.
Une bonne âme pourrait-elle me dire comment procéder pour récupérer la 2.0.3.-3 dans mes dépôts, siouplé ?
Vous me seriez d'une grande aide. :blush:

* Je sais que je devrais mettre à jour ma debian mais d'une part j'ai eu un mal fou à l'installer quand je me suis décidé à abandonner windows à cause d'une configuration de pc assez "exotique" donc je préfère en l'état bidouiller le mojns possible tant que ça marche et d'autre part parce que je ferai le pas quand j'aurai changé de machine pour une plus récente et performante.
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1069
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

21 sept. 2020, 16:31

Bonjour,

Apparemment tu te rends compte que rester en Jessie n'est pas la meilleure situation pour utiliser des paquets provenant de Sid ;
ton installation a 4 métros de retard et cela risque d'être assez compliqué (même pas sûr que ce soit possible) à cause des dépendances (niveau bibliothèques).

Dans tous les cas, faire une sauvegarde complète de ton installation avant de tenter quoique ce soit,
sinon tu devras peut-être tout réinstaller.

Je ne sais pas ce que tu as du faire de spécial pour ton installation présente sur ce matériel "éxotique",
mais perso
je ferais la MàJ de Jessie, ma sauvegarde,
l'upgrade vers Stretch, une éventuelle autre sauvegarde,
l'upgrade vers Buster, une sauvegarde
et à partir de là — sur un système à jour — installer Deluge (sid).

Si vraiment tu ne te sens pas de mettre à jour (je ne vois pas pourquoi avec le parachute de la sauvegarde)
avec le même parachute tu peux tenter l'option directe.


Dans tous les cas pour utiliser/installer des paquets de SID,
tu dois avoir "sid" dans tes sources

pour cela tu rajoutes dans : /etc/apt/sources.list

Code : Tout sélectionner

# Sid
#	2020-09-21 Ajoué pour Deluge avec ajout de /etc/apt/preferences.d/sid.pref
# 	=> priority=100 pour tous -> uniquement si non-dispo dans Distro par défaut (Jessie)
deb http://ftp.fr.debian.org/debian/ sid main
(pour deluge je ne crois pas que contrib non-free soient nécessaires ; les commentaires c'est pour te rafraîchir les idées ... un jour)

Ensuite tu crées et édites : /etc/apt/preferences.d/sid.pref

avec p.ex :

# nano /etc/apt/preferences.d/sid.pref

Avec le contenu suivant :

Code : Tout sélectionner

Package: *
Pin: release n=sid
Pin-Priority: 100
ça fait que tu vas pouvoir installer (aussi) automatiquement tous les paquets qui ne sont pas dans ta distrib par défaut (Jessie si tu n'upgrades pas)
c'est le truc dangereux !


Ensuite, il faut forcer APT à installer la version "sid" de Deluge


Pour cela, tu crées et édites : /etc/apt/preferences.d/deluge.pref

avec :

# nano /etc/apt/preferences.d/deluge.pref

et le contenu :

Code : Tout sélectionner

Explanation: Suivre la version de sid (unstable)
Package: deluge
Pin: release n=sid
Pin-Priority: 1001

Une fois cela enregistré, tu rafraîchis les listes avec :

# apt-get update


Maintenant, que tu es paré pour la grande aventure ou les grosses galères ???

Tu peux commencer prudemment par une simulation avec l'option "-s"

# apt-get install -s deluge

et si tu le sens bien ... action avec :

# apt-get install deluge


Te voilà informé ... à toi de faire tes choix ! :003:
Debian testing/stable - XFCE
airone
Membre
Membre
Messages : 24
Enregistré le : 30 oct. 2016, 21:49
Status : Hors ligne

21 sept. 2020, 17:18

Salut dezix et un grand merci à toi pour les explications et le temps pris pour me répondre.
Pour la faire courte, mon pc ne boote pas sur un clé usb, j'ai du passer par un graveur/lecteur cd pour installer debian que j'avais gravé dessus et il avait fallu que je m'y reprenne à plusieurs reprises. Puis au lancement une fois installé, de gros problèmes de lenteur dus au fait que je n'ai pas de carte vidéo dédiée mais un chipset (j'en avais parlé ici à l'époque) et ça a été galère pour trouver le bon driver pour que ça fonctionne.
De ce que je comprends, ce n'est pas conseillé de ne pas mettre à jour d'abord ma distro avant de bidouiller pour deluge et ça ne me surprend pas c'est même logique. Et en l'état je ne me sens pas assez compétent pour tenter la mise à jour complète ou de la zapper et risquer de mettre le bazard partout. Ma version 1.3.10 de Deluge fonctionne sur la majorité des trackers, tant pis pour celui où ce n'est pas le cas je m'en passerai.
Je vais mettre ta réponse en favoris dans mon FF, attendre d'avoir un nouveau pc où je mettrai une Debian à jour, et garder celui où je me ferai la main en essayant des mises à jour sans stresser de tout planter, même avec des sauvegardes.
C'est un trop gros chantier pour moi eu égard à mes (in) compétences pour un gain hypothétique et minime (Deluge).
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1069
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

21 sept. 2020, 18:16

Je comprends bien les doutes quand on ne se sens pas "à la hauteur" (on en est tous là à un moment ou un autre)
mais si cela peut te rassurer,
maintenant que ton système est installé,
tu n'as plus besoin de lecteur CD (ou de clé USB) pour passer à la version supérieure de Debian.

L'upgrade se fait en modifiant le sources.list puis en mettant à jour avec ton gestionnaire de paquets habituel (Synaptic ou autre).

Normalement, les pilotes installés pour ton matériel seront mis à jour avec/comme le reste du système.

C'est uniquement si tu avais installé un pilote (ou n'importe quoi d'autre) manuellement <=> hors dépôts Debian
que tu auras à refaire la même installation avec une version compatible avec ta nouvelle version de Debian.

Si ton matériel actuel le permet,
tu pourrais aussi te faire la main sur une machine virtuelle de Virtualbox.

Une machine virtuelle ne va pas utiliser le pilote de ta "vraie" carte graphique,
mais si tu as conservé l'iso qui t'a servi à l'installation initiale de ton PC,
tu peux l'utiliser directement (sans lecteur CD réel) pour repartir dans des conditions assez proches ;
tu pourras y installer les mêmes paquets et faire les upgrades > stretch > Buster et Deluge en sid.

Tout cela sans risque et avec un système d'instantanés (sauvegarde) qui permet de revenir à une étape antérieure pour refaire si ça n'a pas fonctionné.

De cette façon, tu serais bien mieux préparé pour ta prochaine installation réelle.

J'espère que cela t'inspireras.

@+ :006:
Debian testing/stable - XFCE
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3476
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

21 sept. 2020, 20:37

Avec autant de retard sur tes mises à jour, ce serait même plus simple de faire une install fraîche. Si tu as assez de place sur ton disque, tu peux installer une debian fraiche à côté de l’actuelle, et c’est au boot que tu choisiras (pense à faire une sauvegarde de ton disque au cas où tu fasses une bêtise en installant ta nouvelle debian)
Tu pourras ainsi prendre un peu de temps pour bien personnaliser ta nouvelle install tout en ayant toujours l’ancienne d’opérationnelle.

Avec une install de debian aussi ancienne, j'espère que tu es super protégé par un pare feu, un proxy ... vis-à-vis d’internet.
airone
Membre
Membre
Messages : 24
Enregistré le : 30 oct. 2016, 21:49
Status : Hors ligne

21 sept. 2020, 20:57

@ dezix,
C'est toujours inspirant quand on reçoit un coup de paluche et qu'on progresse en compréhension. Je ne savais pas que pour passer de Jessie aux suivantes ça se passait par Synaptic, ça rassure ! La VM je connais mais avec ma config' famélique, ça rame tellement que ça dissuade d'en user sauf si c'est vraiment utile donc comme j'ai conservé l'iso je me ferai la main comme ça.
Le seul truc que j'ai du installer "manuellement" à l'époque c'est non pas un driver contrairement à mes souvenirs mais un firmware et j'avais bien galéré avant qu'on me dépanne ici :viewtopic.php?p=7939#p7939. Souvenirs souvenirs !
Une sauvegarde il faut que j'y pense aussi, jamais fait.

@ piratebab,
Merci pour ton conseil, mais je suis déjà en dual boot avec windows xp (je le garde pour certaines applications et quelques jeux) donc je n'ai plus de place et quand bien même j'en aurais, jongler avec windows et deux debian ce serait trop chaud pour mon petit niveau.
Sinon, ni pare feu ni proxy, mais je suis par nature vigilant donc je ne vais pas trainer sur des sites chelous ou à risque, je n'ouvre jamais de pièces jointes siu je ne connais pas l'expéditeur etc....
Je sais bien que ce n'est pas idéal,, a fortiori pour des informaticiens qui aiment bien que ce soit carré, propre et sécurisé -ils ont raison !).J'ai quand même entre-temps mis à jour mon FF en passant à la version Quantum 60.7.1

Un de ces 4 je me paierai une petite formation linuxienne histoire de savoir installer une distro sans ramer au premier pépin et faire de la ligne de commande mais le provisoire qui dure...
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1069
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

22 sept. 2020, 08:55

airone a écrit :
21 sept. 2020, 17:18
Je vais mettre ta réponse en favoris dans mon FF

Tu sais que tu as aussi des Favoris dans l'interface du forum => Bouton déroulant avec la petite clé-à-molette près du bouton Répondre au bas de la discussion :dirol:


:006:
Debian testing/stable - XFCE
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3476
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

22 sept. 2020, 09:51

Une idée en me rasant ce matin, appimage
il te permet d’installer une version d’un logiciel sans mettre le bazar dans les dépendances.
Regarde s’il existe une version appimage (ou flatpack) pour deluge.
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1069
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

22 sept. 2020, 10:19

Bonne idée !

J'ai regardé sur : https://dev.deluge-torrent.org/wiki/Download
il n'y a pas :((

ici : https://www.appimagehub.com/browse/cat/ ... er/latest/

il y en a plusieurs dont QBitTorrent qui fait aussi partie de la distribution debian

C'est probablement plus simple et rapide ;-)
Debian testing/stable - XFCE
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1069
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

22 sept. 2020, 10:43

Pour qBitTorrent c'est peut-être mieux ici :

Extrait du wiki officiel...
qBittorrent is also available semi-officially on FlatHub: https://flathub.org/apps/details/org.qb ... Bittorrent

Ici : https://flatpak.org/setup/Debian/
les instructions (pour Jessie il faut les backports )
Debian testing/stable - XFCE
airone
Membre
Membre
Messages : 24
Enregistré le : 30 oct. 2016, 21:49
Status : Hors ligne

22 sept. 2020, 20:55

Merci à vous pour les bons tuyaux, rasé ou pas, je vais plonger tête baissée et studieuse dedans, et tenter de voir comment ça marche. Ca fait un moment que je n'ai pas mis les mains de le cambouis et je m'aperçois qu'on rouille vite si on ne pratique pas régulièrement.
Muchas gracias muchachos !.
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1069
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

22 sept. 2020, 23:26

¡De nada Hombre!
Debian testing/stable - XFCE
Répondre