Pango-ERROR Harfbuzz version too old (1.4.2) Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Avatar du membre
Grhim
Membre très actif
Membre très actif
Messages : 1027
Enregistré le : 30 mai 2016, 01:00
Localisation : International Space Station
Status : Hors ligne

19 mai 2020, 01:47

Salut tout le monde

l'interface de bootstrap ne se lance pas :

Code : Tout sélectionner

(Bootstrap Studio:150592): Pango-ERROR **: 01:37:03.990: Harfbuzz version too old (1.4.2)
recherche sur pango

Code : Tout sélectionner

$ aptitude search libpango
i A libpango-1.0-0                                                                                                 - Layout and rendering of internationalized text                                                                           
p   libpango-perl                                                                                                  - Perl module to layout and render international text                                                                      
p   libpango1.0-dev                                                                                                - Development files for the Pango                                                                                          
p   libpango1.0-doc                                                                                                - Documentation files for the Pango                                                                                        
p   libpango3.0-cil                                                                                                - CLI binding for Pango                                                                                                    
i A libpangocairo-1.0-0                                                                                            - Layout and rendering of internationalized text                                                                           
i A libpangoft2-1.0-0                                                                                              - Layout and rendering of internationalized text                                                                           
i A libpangomm-1.4-1v5                                                                                             - C++ Wrapper for pango (shared libraries)                                                                                 
p   libpangomm-1.4-dev                                                                                             - C++ Wrapper for pango (development files)                                                                                
p   libpangomm-1.4-doc                                                                                             - C++ Wrapper for pango (documentation)                                                                                    
p   libpangox-1.0-0                                                                                                - pango library X backend                                                                                                  
p   libpangox-1.0-dev                                                                                              - pango library X backend - development files                                                                              
i A libpangoxft-1.0-0                                                                                              - Layout and rendering of internationalized text   
= me dit que sur les deux je garde le 1.4

Code : Tout sélectionner

i A libpangoft2-1.0-0                                                                                              - Layout and rendering of internationalized text                                                                           
i A libpangomm-1.4-1v5                                                                                             - C++ Wrapper for pango (shared libraries)                                                                                
vérification :

Code : Tout sélectionner

# aptitude -s remove libpangoft2-1.0-0

Les paquets suivants seront ENLEVÉS :                   
  cpp-7{u} libasan4{u} libpangoft2-1.0-0 linux-headers-4.18.0-kali2-common{u} linux-kbuild-4.18{u} python3-winrm{u} ruby-did-you-mean{u} 
0 paquets mis à jour, 0 nouvellement installés, 7 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 78,6 Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 libgksu2-0 : Dépend: libpangoft2-1.0-0 (>= 1.14.0) but it is not going to be installed
 libclutter-1.0-0 : Dépend: libpangoft2-1.0-0 (>= 1.30) but it is not going to be installed
 libgtk-3-0 : Dépend: libpangoft2-1.0-0 (>= 1.41.0) but it is not going to be installed
 libgtk2.0-0 : Dépend: libpangoft2-1.0-0 (>= 1.28.3) but it is not going to be installed
 gir1.2-pango-1.0 : Dépend: libpangoft2-1.0-0 (= 1.44.7-4) but it is not going to be installed
 libmutter-6-0 : Dépend: libpangoft2-1.0-0 (>= 1.14.0) but it is not going to be installed
 libcanberra-gtk-module : Dépend: libpangoft2-1.0-0 (>= 1.14.0) but it is not going to be installed
 libpangoxft-1.0-0 : Dépend: libpangoft2-1.0-0 (= 1.44.7-4) but it is not going to be installed
 gimp : Dépend: libpangoft2-1.0-0 (>= 1.29.4) but it is not going to be installed
 spectools : Dépend: libpangoft2-1.0-0 (>= 1.14.0) but it is not going to be installed
 gksu : Dépend: libpangoft2-1.0-0 (>= 1.14.0) but it is not going to be installed
 libpangocairo-1.0-0 : Dépend: libpangoft2-1.0-0 (= 1.44.7-4) but it is not going to be installed
 python-gtk2 : Dépend: libpangoft2-1.0-0 (>= 1.21.4) but it is not going to be installed
 libcanberra-gtk0 : Dépend: libpangoft2-1.0-0 (>= 1.14.0) but it is not going to be installed
 libgvc6 : Dépend: libpangoft2-1.0-0 (>= 1.14.0) but it is not going to be installed
 yersinia : Dépend: libpangoft2-1.0-0 (>= 1.14.0) but it is not going to be installed
 python-gtksourceview2 : Dépend: libpangoft2-1.0-0 (>= 1.14.0) but it is not going to be installed
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     libpangoft2-1.0-0 [1.44.7-4 ]         

une idée de votre coté ?
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3335
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

19 mai 2020, 08:51

Salut Grhim,
bienvenu au club. Tu es en testing ou SID ?
J'ai régulièrement ce type de soucis lié à Pyton3.8.
Généralement ça se résous en quelques jours, voire semaines.
Sauf pour openshot que j'ai du désinstaller car non compatible python3.8
Essaie de piocher libpango dans une saveur plus récente de debian (experimental ?)
apt-cache policy est mon ami en ce moment
--gilles--
Membre
Membre
Messages : 482
Enregistré le : 24 août 2016, 19:35
Localisation : Gnome 3.36 - debian 11 bullseye
Status : Hors ligne

19 mai 2020, 18:14

Je pense plutôt que le problème vient d'ici : Harfbuzz version too old (1.4.2)

Donne-nous : aptitude search '~i arfbuzz'

Harfbuzz est une nouvelle biblio pour les caractères :
https://www.freedesktop.org/wiki/Software/HarfBuzz/

https://fr.wikipedia.org/wiki/HarfBuzz
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell
Avatar du membre
Grhim
Membre très actif
Membre très actif
Messages : 1027
Enregistré le : 30 mai 2016, 01:00
Localisation : International Space Station
Status : Hors ligne

19 mai 2020, 19:56

salut Gilles

Code : Tout sélectionner

$ !!
aptitude search '~i harfbuzz'
i A libharfbuzz-icu0                                          - OpenType text shaping engine ICU backend                            
i A libharfbuzz0b                                             - OpenType text shaping engine (shared library) 
piratebab a écrit :
19 mai 2020, 08:51
bienvenu au club. Tu es en testing ou SID ?
testing/Sid sur cette machine-ci
je n'aurais accès a la stable que demain pour vérifié ...

ça date de il n'y a pas long car j'ai dû faire deux grosse mise a jour entre le mois dernier et ce mois ci
Avatar du membre
Grhim
Membre très actif
Membre très actif
Messages : 1027
Enregistré le : 30 mai 2016, 01:00
Localisation : International Space Station
Status : Hors ligne

20 mai 2020, 17:29

bon et bien , l'interface de bootstrap studio est passé en version 5 stable , ça fonctionne de nouveau ... ne peux plus utiliser la version 4 ...les lib ne sont pas compatibles
Répondre