tester son sources.list

Demande d'aide : c'est ici.
Répondre
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3366
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

29 avr. 2020, 23:32

Pour l'autre question à part tenter un apt-cache policy * | grep stable
je ne vois pas
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 930
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

30 avr. 2020, 00:12

piratebab a écrit :
29 avr. 2020, 23:32
Pour l'autre question à part tenter un apt-cache policy * | grep stable
je ne vois pas
Non ça le fait pas car ça liste les lignes dans "Table de version" sans donner d'indication sur quoique-ce soit d'installé.

C'est un truc pas évident,
j'ai essayé de créer un filtre perso dans Synaptic mais là aussi ça me sort la liste complète des paquets.

J'ai recherché aussi du côté de : /var/lib/apt/lists/
mais ça ne contient que les listes des dépôts sans indication de ce qui est installé ou pas.
Debian testing/stable - XFCE
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3366
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

30 avr. 2020, 07:58

Le filtrage avec grep testing est effectivement trop simpliste.
L'info est bien contenue dans la sortie apt-cache policy; extrait de la sortie de apt-cache policy *apt

Code : Tout sélectionner

aptitude-doc-ru:
  Installé : (aucun)
  Candidat : 0.8.12-3
 Table de version :
     0.8.12-3 985
        985 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        985 http://ftp.fr.debian.org/debian testing/main i386 Packages
         98 http://ftp.fr.debian.org/debian sid/main amd64 Packages
         98 http://ftp.fr.debian.org/debian sid/main i386 Packages
     0.8.11-7 530
        530 http://ftp.fr.debian.org/debian stable/main amd64 Packages
        530 http://ftp.fr.debian.org/debian stable/main i386 Packages
Tu sais si c'est installé ou pas, et quelle version est disponible dans chaque dépot. Mais à trier automatiquement, ça demande un peu de travail
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3366
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

02 juin 2020, 11:42

Avatar du membre
dezix
Modérateur
Modérateur
Messages : 930
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

02 juin 2020, 14:17

piratebab a écrit :
02 juin 2020, 11:42
openshot vs fdenlive
https://linuxfr.org/users/funix/journau ... s-kdenlive
Y-a-pas [s]vidéo[/s] photo ! :dirol:

Sauf pour les experts
Debian testing/stable - XFCE
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3366
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

02 juin 2020, 17:00

malheureusement, je ne peux plus installer openshot, pas compatible avec python 3.8
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 930
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

02 juin 2020, 19:40

Oui, je crois qu'il y a une incohérence ... peut-être un problème de déclaration des dépendances d'un paquet ?

car, j'ai :

Code : Tout sélectionner

$ apt policy python3
python3:
  Installé : 3.8.2-3
  Candidat : 3.8.2-3
 Table de version :
 *** 3.8.2-3 500
        500 http://ftp.fr.debian.org/debian bullseye/main amd64 Packages
        100 http://ftp.fr.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
et

Code : Tout sélectionner

# apt-get -s install openshot | egrep -v "^(Inst|Conf|Remv)"
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 python3-openshot : Dépend: python3 (< 3.8) mais 3.8.2-3 devra être installé

J'ai donc python 3.8.2-3
et

Code : Tout sélectionner

# apt-rdepends  python3-openshot | grep python
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python3-openshot
  Depends: libpython3.7 (>= 3.7.0)
  Depends: python3 (>= 3.7~)
  Depends: python3:any
libpython3.7
  Depends: libpython3.7-stdlib (= 3.7.7-1+b1)
libpython3.7-stdlib
  Depends: libpython3.7-minimal (= 3.7.7-1+b1)
libpython3.7-minimal
python3
  Depends: libpython3-stdlib (= 3.8.2-3)
  Depends: python3.8 (>= 3.8.2-1~)
  PreDepends: python3-minimal (= 3.8.2-3)
libpython3-stdlib
  Depends: libpython3.8-stdlib (>= 3.8.2-1~)
libpython3.8-stdlib
  Depends: libpython3.8-minimal (= 3.8.3-1)
libpython3.8-minimal
python3.8
  Depends: libpython3.8-stdlib (= 3.8.3-1)
  Depends: python3.8-minimal (= 3.8.3-1)
python3.8-minimal
  Depends: libpython3.8-minimal (= 3.8.3-1)
python3-minimal
  PreDepends: python3.8-minimal (>= 3.8.2-1~)
python3:any
c'est donc un vrai sac de nœud ! :017:

Ne serait-ce pas :
Depends: libpython3.7-stdlib (= 3.7.7-1+b1)
et
Depends: libpython3.7-minimal (= 3.7.7-1+b1)

qui bloquent ?

Non ils sont installés :

Code : Tout sélectionner

# apt policy  libpython3.7-stdlib
libpython3.7-stdlib:
  Installé : 3.7.7-1+b1
  Candidat : 3.7.7-1+b1
 Table de version :
 *** 3.7.7-1+b1 500
        500 http://ftp.fr.debian.org/debian bullseye/main amd64 Packages
        100 http://ftp.fr.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status


# apt policy  libpython3.7-minimal 
libpython3.7-minimal:
  Installé : 3.7.7-1+b1
  Candidat : 3.7.7-1+b1
 Table de version :
 *** 3.7.7-1+b1 500
        500 http://ftp.fr.debian.org/debian bullseye/main amd64 Packages
        100 http://ftp.fr.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status

Debian testing/stable - XFCE
Avatar du membre
Grhim
Membre très actif
Membre très actif
Messages : 1067
Enregistré le : 30 mai 2016, 01:00
Localisation : Zurich
Status : Hors ligne

02 juin 2020, 21:59

piratebab a écrit :
29 avr. 2020, 19:17
Petite vérif complémentaire avec netselect, 100% OK
je viens de retrouver ceci https://soltveit.org/fastest-debian-mirror/

et c'est bien ce que dit https://packages.debian.org/stable/net/netselect
speed tester for choosing a fast network server

This package provides a utility that can perform parallelized tests on distant servers using either UDP traceroutes or ICMP queries.
Debian Testing-Sid / Debian Stable / Kali Linux / Gnome3 - KissOs - Raspberry 3b+ -
MicP
Modérateur
Modérateur
Messages : 593
Enregistré le : 16 avr. 2016, 22:14
Status : Hors ligne

03 juin 2020, 05:30

Bonjour

Juste pour info, au cas où :

Avec la commande apt il existe une option qui permet d'éditer le fichier /etc/apt/sources.list
et qui fait des vérifications sommaires avant de permettre l'enregistrement des modifications.

Pour éditer le fichier /etc/apt/sources.list
avec les privilèges du compte root
il faudra lancer la ligne de commande suivante :

Code : Tout sélectionner

apt edit-sources
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

03 juin 2020, 08:42

Salut,
Pas mal ce truc, merci.
Ça fonctionne comme un visudo (vérification de syntaxe)

Code : Tout sélectionner

# apt edit-sources
E: Le type « debx » est inconnu sur la ligne 6 dans la liste des sources /etc/apt/sources.list
E: La liste des sources ne peut être lue.
Impossible de lire /etc/apt/sources.list. Faut-il l'éditer à nouveau ? [O/n]

Et en plus il est aimable...
Votre fichier « /etc/apt/sources.list » a changé, veuillez lancer « apt-get update ».
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3366
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

03 juin 2020, 16:21

Code : Tout sélectionner

apt search ~b
permet d'afficher les paquets cassé. Le problem c'est qu'il liste même sont qui ne sont pas intallés
Répondre