Versions Buster de Certbot bientôt obsolete

Demande d'aide : c'est ici.
Répondre
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3134
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

01 févr. 2020, 07:41

Salut,

Cela fait plusieurs fois que je reçois un mail d'alerte de Letsencrypt au sujet de ma version de certbot.

Il se trouve qu'en juin prochain, si Debian ne passe pas à une version supérieurs de Certbot dans Buster, nous devrons soit utiliser la version de Unstable, soit le binaire téléchargé de Certbot.
User agent: CertbotACMEClient/0.31.0 (certbot; Debian GNU/Linux 10 (buster)) Authenticator/standalone Installer/None (renew; flags: n) Py/3.7.3
...
Beginning June 1, 2020, we will stop allowing new domains to validate using
the ACMEv1 protocol. You should upgrade to an ACMEv2 compatible client before
then, or certificate issuance will fail. For most people, simply upgrading to
the latest version of your existing client will suffice.
...

Effectivement j'ai la version 0.31 de Buster installée.

Code : Tout sélectionner

# apt-cache policy certbot | grep Installé
  Installé : 0.31.0-1

Il faudra donc passer par la version de bullseye 1.1.0 (Unstable aujourd'hui) d'ici juin.
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3134
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

02 févr. 2020, 10:26

Pour les fainéants:

Ajouter bullseye dans les sources

Code : Tout sélectionner

# cat /etc/apt/sources.list.d/bullseye.list
deb http://deb.debian.org/debian bullseye main

Avec les fichiers préferences qui vont bien:
# cat /etc/apt/preferences.d/bullseye

Code : Tout sélectionner

Package: *
Pin: release n=bullseye
Pin-Priority: 10
# cat /etc/apt/preferences.d/certbot

Code : Tout sélectionner

Package: certbot
Pin: release n=bullseye
Pin-Priority: 1001

Package: python3-certbot
Pin: release n=bullseye
Pin-Priority: 1001

Package: python3-acme
Pin: release n=bullseye
Pin-Priority: 1001
Important! Avant de vous lancer dans un upgrade, mettez à jour et vérifiez que vos préférences sont correctes...
# apt update && apt-cache policy

Code : Tout sélectionner

Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
  10 http://deb.debian.org/debian bullseye/main amd64 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://deb.debian.org/debian buster-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian buster/main amd64 Packages
     release v=10.2,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :
     certbot -> 1.1.0-1 avec la priorité 1001
     python3-acme -> 1.1.0-1 avec la priorité 1001
     python3-certbot -> 1.1.0-1 avec la priorité 1001

Et enfin:
Si certbot est déjà installé
apt update && apt upgrade -y
Si certbot n'est pas installé:
apt update && apt upgrade -y && apt install -y certbot
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 671
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

02 févr. 2020, 15:42

Merci Lol,
ça devrait bientôt me servir.

:yahoo:
Debian testing/stable - XFCE
Répondre