[TESTING] GIMP est bugué :(( Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Avatar du membre
dezix
Membre
Membre
Messages : 465
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

11 sept. 2019, 17:07

Bonjour,

Pas de chance, je ne me sers pas très souvent de GIMP,
et quand j'en ai besoin => il est malade :((

le problème est signalé : https://bugs.debian.org/cgi-bin/bugrepo ... bug=939754

Une solution temporaire est proposée :

The crash seems to be caused by gimp_gegl_mask_is_empty() in
app/gegl/gimp-gegl-mask.c

I cherry-picked 986a298a from upstream (which is also contained in
2.10.10+) and rebuilt gimp. This fixes the issue for me. This patch,
however, needs gegl >= 0.4.14 which is stuck in unstable ATM.

gegl 0.4.14-1 built fine for me on bullseye/amd64.

Debdiff attached.

For convenience, binaries bullseye/amd64 can be found at:

deb https://debian.sur5r.net/bts939754 bullseye main
deb-src https://debian.sur5r.net/bts939754 bullseye main

The repository is signed by E3CA1A89941C42E6.
(Fingerprint BFD90F4DAAEFA72B67BBAF48E3CA1A89941C42E6)
Mais je ne suis pas trop certain de ce qu'il faut faire pour le réparer.

Donc si quelques bonnes âmes peuvent me traduire la solution pour blaireau de base,
ça m'évitera à moi et à d'autres peut-être de faire des boulettes.

Merci.
Debian testing/stable - XFCE
Avatar du membre
dezix
Membre
Membre
Messages : 465
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

11 sept. 2019, 17:36

J'ai trouvé un système plus simple et qui fonctionne :

J'ai réactivé les sources de stable et rétrogradé le paquet : gimp
à la version 2.10.8-2
et ça remarche.

C'est faisable avec Synaptic => Paquet > forcer la version

Si quelqu'un voit une contre-indication/risque à cette solution,
merci d'en avertir.

@+
Debian testing/stable - XFCE
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2938
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

12 sept. 2019, 08:34

Pas de risque à retrograder un paquet tant que tu ne forces pas une dépendance.
Avatar du membre
dezix
Membre
Membre
Messages : 465
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

12 sept. 2019, 09:27

Salut Piratebab,

merci

@+
Debian testing/stable - XFCE
Répondre