debian 7 install GLIBC_2.14 GLIBC_2.15

Demande d'aide : c'est ici.
Répondre
Pyroman_Goliath
Messages : 3
Enregistré le : 06 juil. 2019, 23:57
Status : Hors ligne

07 juil. 2019, 00:00

Bonjour à tous.

Alors avant de commencé, un petit rappel de ma part.
Oui je suis sur Debian 7. Oui c'est une vieille version obsolète. Oui elle est plus à jour. Oui je suis un vieux :), Oui ,Oui oui, etc etc etc....

Bref, si je suis ici, c'est que je suis dans une impasse, et que j'ai essayé pas mal de solution qui n'ont rien abouti.
Certe pas mal de chose sont un peu dépassé, MAIS, si je suis dans ce genre de cas, c'est que les moyens me manque, que ce sois Hardware, personnel, technique, etc etc....
Donc je n'accepte pas les réponses du genre. "fais une MAJ pour réglé t'on problème". J'en veux pas :021:

Alors je suis en train de faire une installation de Debian 7 en x64 sur une machine réelle. (ACTUELLEMENT), Une installation au propre durant un petit moment.

Malgré que la version soit vieille, j'ai réussi à trouvé des paquets ici, que j'ai ajouté à ma sources.list dans "/etc/apt"
"deb http://archive.debian.org/debian/ wheezy contrib main"

Et à leur actuelle, ou je bloque, c'est pour l'installation d'un serveur factorio (aussi une vieille version en 14.19). Mais mon souci ne concernant pas le serveur factorio en lui même.

Mais plutôt aux paquets que le serveur factorio à besoin pour fonctionner. Car oui durant une époque, j'avais réussi à le faire fonctionner. Mais j'ai oublié de prendre des notes, Voila :(Image

Et donc à l'heure actuelle, lorsque je veux éxécuté le serveur factiorio (non je ne vais pas le tuer :)). J'ai un message d’erreur , me disant que je dois installé:

GLIBC_2.14 et GLIBC_2.15.

Sauf que je ne trouve rien de concret pour l'installation de ces paquets.
Et j'ai besoin de vous pour trouvé ces paquets et les installers.

Voila, j'attends vos réponses avec impatience.
En vous remerciant.
Avatar du membre
vv222
Modérateur
Modérateur
Messages : 351
Enregistré le : 18 avr. 2016, 20:14
Localisation : Bretagne
Contact :
Status : Hors ligne

07 juil. 2019, 13:48

Pyroman_Goliath a écrit :
07 juil. 2019, 00:00
Et donc à l'heure actuelle, lorsque je veux éxécuté le serveur factiorio (non je ne vais pas le tuer :)). J'ai un message d’erreur , me disant que je dois installé:

GLIBC_2.14 et GLIBC_2.15.
C’est un message qui t’indique la version de la bibliothèque C qui doit être disponible sur ton système.
Sur Debian, elle est fournie par le paquet "libc6".

En Wheezy elle est trop ancienne, il s’agit de la version 2.13.
Donc ça ne va pas te faire plaisir, mais la seule solution dans ton cas est de passer à une version plus récente de Debian. Au minimum Jessie (Debian 8) qui vient avec la version 2.19 de cette bibliothèque.
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2906
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

07 juil. 2019, 23:04

Comme s'appelle ce truc qui installe les paquets avec toutes leur dépendances ? C'est fait pour étre compatible avec toutes les distributions linux, mais le nom m'échappe .
édit:
trouvé! appimage
Pyroman_Goliath
Messages : 3
Enregistré le : 06 juil. 2019, 23:57
Status : Hors ligne

08 juil. 2019, 10:49

Merci beaucoup, je vous tient au courant très vite
Pyroman_Goliath
Messages : 3
Enregistré le : 06 juil. 2019, 23:57
Status : Hors ligne

10 juil. 2019, 18:15

bonjour, une personne m'a conseiller ceci "https://linuxfr.org/users/tilk/journaux ... e-la-glibc". En ce moment j'ai une gros semaine, je vais commencé à bossé dessus ce week-end. Je vous tient au courant très vite.
Mais si par exemple, je devais passer sous debian 8, ou est ce que je peux voir la différence par rapport à debian 7.

Je vous remercie, a plus tard.
Répondre