Install Mariadb-ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Avatar du membre
Grhim
Membre actif
Membre actif
Messages : 939
Enregistré le : 30 mai 2016, 01:00
Localisation : Terra
Diaspora* : Grhim@fessedebouc.fr
Jappix : testouille@xmpp.jp
Status : Hors ligne

14 avr. 2019, 00:37

salut tout le monde ,

Je suis en pleine installation de Mariadb/Mysql , je rencontre une erreur assez étonnante,
j'ai bien évidement regarder plusieurs forum spécialisée dans mariadb/mysql mais je n'arrive pas à aller plus loin ...

l'install apt c'est bien dérouler mais je n'ai pas de demande de creation de mot de passe comme expliquer ici : https://tecadmin.net/install-mariadb-on ... 9-stretch/

je suis bloquer à :

Code : Tout sélectionner

mysql_secure_installation
[sudo] Mot de passe de Grhim : 

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
      SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we'll need the current
password for the root user.  If you've just installed MariaDB, and
you haven't set the root password yet, the password will be blank,
so you should just press enter here.

Enter current password for root (enter for none): 
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Enter current password for root (enter for none): 
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

.....
Aborting!

Cleaning up...

Code : Tout sélectionner

mysql mysql -u root
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

Code : Tout sélectionner

systemctl status mariadb
[sudo] Mot de passe de Grhim : 
● mariadb.service - MariaDB 10.3.13 database server
   Loaded: loaded (/lib/systemd/system/mariadb.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:mysqld(8)
           https://mariadb.com/kb/en/library/systemd/

j'ai bien noté l'info concernant la première utilisation via mariadb que le mot de passe root n'existe pas ....

Code : Tout sélectionner

sudo mysqladmin password newpassword
[sudo] Mot de passe de Grhim : 
mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!

qu'es-ce que j'ai louper ?

doit-je creer socket mysqld ? > (Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!)
-- D3b1@n Stable + Testing-Unstable -.- Enlightenment / KDE Plasma - Kali -
Avatar du membre
dezix
Membre
Membre
Messages : 346
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

14 avr. 2019, 12:17

Grhim a écrit :
14 avr. 2019, 00:37
salut tout le monde ,
....
qu'es-ce que j'ai louper ?


Salut Grhim,


Je ne suis pas un expert en la matière

mais en repassant les notes prises pour un serveur web installé en VM

après install des pkges

$ sudo mysql -p -u root

Puis création d'un utilisateur

CREATE USER '<user>' @'%' IDENTIFIED BY '<mdp>';

où on peut remplacer % par l'IP (je ne sais plus de quoi exactement ??? )

Dans mon contexte je crée un utilisateur(serveur debian) pour chaque site ce qui limite/cloisonne les accès,
donc j'utilise cet utilisateur pour aussi accéder à la DB du site en question.

J'espère que c'est assez clair pour toi

@+
Debian testing - SparkyLinux - XFCE
Avatar du membre
Dunatotatos
Membre
Membre
Messages : 405
Enregistré le : 11 mai 2016, 20:56
Localisation : Arabie Saoudite
Status : Hors ligne

14 avr. 2019, 14:33

Toutes les erreurs te disent que mysql est injoignable, et systemctl t'indique même qu'il est "dead".
Grhim a écrit :
14 avr. 2019, 00:37

Code : Tout sélectionner

systemctl status mariadb
[sudo] Mot de passe de Grhim : 
● mariadb.service - MariaDB 10.3.13 database server
   Loaded: loaded (/lib/systemd/system/mariadb.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:mysqld(8)
           https://mariadb.com/kb/en/library/systemd/

Démarre-le

Code : Tout sélectionner

 # systemctl start mariadb
et tout devrait aller mieux.

EDIT: N'oublie pas `systemctl enable mariadb` pour le démarrage au boot.
Never trust Windows output.
Avatar du membre
Grhim
Membre actif
Membre actif
Messages : 939
Enregistré le : 30 mai 2016, 01:00
Localisation : Terra
Diaspora* : Grhim@fessedebouc.fr
Jappix : testouille@xmpp.jp
Status : Hors ligne

14 avr. 2019, 20:41

salut a tout les deux ,
dezix a écrit :
14 avr. 2019, 12:17
Dunatotatos a écrit :
14 avr. 2019, 14:33
quoi que je fasse l'erreur est toujours là ....

Code : Tout sélectionner

# systemctl start mariadb
Job for mariadb.service failed because a fatal signal was delivered to the control process.
See "systemctl status mariadb.service" and "journalctl -xe" for details.

par contre j'arrive a démarrer mysql avec # msqld

Code : Tout sélectionner

● mariadb.service - MariaDB 10.3.13 database server
   Loaded: loaded (/lib/systemd/system/mariadb.service; disabled; vendor preset: disabled)
   Active: activating (auto-restart) (Result: signal) since Sun 2019-04-14 20:20:34 CEST; 3s ago
     Docs: man:mysqld(8)
           https://mariadb.com/kb/en/library/systemd/
  Process: 18354 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
  Process: 18355 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
  Process: 18357 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ]  
  Process: 18432 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=killed, signal=ABRT)
 Main PID: 18432 (code=killed, signal=ABRT)
   Status: "Waiting for page cleaner"

avril 14 20:20:33  systemd[1]: mariadb.service: Failed with result 'signal'.
avril 14 20:20:33  systemd[1]: Failed to start MariaDB 10.3.13 database server.
...skipping...

j'ai regarder les fichier de conf mariadb, il y a bien la bin adress 127.0.0.0 active (elle n’est pas commentée [#])

le etc/resolv.conf est vide a part mon dns personalisé que je change regulierement (je ne sais pas si ca joue ? )

Code : Tout sélectionner

$ cat /etc/resolv.conf
# Raspberry_Web_Server_M83 by G.
#search localdomain
nameserver 1.1.1.1
nameserver 1.0.0.1
-- D3b1@n Stable + Testing-Unstable -.- Enlightenment / KDE Plasma - Kali -
Avatar du membre
dezix
Membre
Membre
Messages : 346
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

14 avr. 2019, 23:51

Dans la conf du serveur,
j'ai :

bin adress 127.0.0.1

et non 127.0.0.0 comme tu l'as écrit

et mon resolv.conf est :

Code : Tout sélectionner

domain home
search home

nameserver 192.168.1.1
J'ai installé

Code : Tout sélectionner

$ dpkg-query -l | grep mariadb
ii  libmariadbclient18:amd64          10.1.37-0+deb9u1               amd64        MariaDB database client library
ii  mariadb-client-10.1               10.1.37-0+deb9u1               amd64        MariaDB database client binaries
ii  mariadb-client-core-10.1          10.1.37-0+deb9u1               amd64        MariaDB database core client binaries
ii  mariadb-common                    10.1.37-0+deb9u1               all          MariaDB common metapackage
ii  mariadb-server-10.1               10.1.37-0+deb9u1               amd64        MariaDB database server binaries
ii  mariadb-server-core-10.1          10.1.37-0+deb9u1               amd64        MariaDB database core server files
Tu es en 10.3.13 donc pas en stable et probablement en testing,
si c'est pour de l'auto-hébergement une stable aurait peut-être été mieux ???

Je crois que dans ton cas, je désinstallerais complétement (purge) tous les paquets mariadb/mysql pour repartir sur un truc clean.

Pour ce dont je me souviens tout fonctionnait bien dès l'installation,
j'ai juste eu à me connecter en root et créer mon utilisateur.

En écrivant ce qui précède, me reviens un truc -- je ne suis pas certain que c'est pour mysql -- du genre :

"on ne doit pas se connecter en root mais créer un utilisateur "

ça ne te dit rien ?

Voilà, ce n'est pas grand-chose mais c'est tout ce que j'ai en magasin,
j'espère que cela pourra t'aider

@+
Debian testing - SparkyLinux - XFCE
Avatar du membre
Grhim
Membre actif
Membre actif
Messages : 939
Enregistré le : 30 mai 2016, 01:00
Localisation : Terra
Diaspora* : Grhim@fessedebouc.fr
Jappix : testouille@xmpp.jp
Status : Hors ligne

15 avr. 2019, 01:06

dezix a écrit :
14 avr. 2019, 23:51
Dans la conf du serveur,
j'ai :

bin adress 127.0.0.1

et non 127.0.0.0 comme tu l'as écrit
Tu as parfaitement raison de la souligner !! , j'ai écrit trop vite pour lui !!

Par contre, c'est en regardant de plus prêt le resolv.conf que j'ai fondu de honte !! je ne m'autorise pas en local sur ce raspberry....
une fois le search localdomain remit , tadaaaa :

Code : Tout sélectionner

:~$ sudo mysql_secure_installation
[sudo] Mot de passe de Grhim : 

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
      SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we'll need the current
password for the root user.  If you've just installed MariaDB, and
you haven't set the root password yet, the password will be blank,
so you should just press enter here.

Enter current password for root (enter for none): 
OK, successfully used password, moving on...

Setting the root password ensures that nobody can log into the MariaDB
root user without the proper authorisation.

Set root password? [Y/n] Y
New password: 
Re-enter new password: 
Password updated successfully!
Reloading privilege tables..
 ... Success!


By default, a MariaDB installation has an anonymous user, allowing anyone
to log into MariaDB without having to have a user account created for
them.  This is intended only for testing, and to make the installation
go a bit smoother.  You should remove them before moving into a
production environment.

Remove anonymous users? [Y/n] Y
 ... Success!

Normally, root should only be allowed to connect from 'localhost'.  This
ensures that someone cannot guess at the root password from the network.

Disallow root login remotely? [Y/n] Y
 ... Success!

By default, MariaDB comes with a database named 'test' that anyone can
access.  This is also intended only for testing, and should be removed
before moving into a production environment.

Remove test database and access to it? [Y/n] Y
 - Dropping test database...
 ... Success!
 - Removing privileges on test database...
 ... Success!

Reloading the privilege tables will ensure that all changes made so far
will take effect immediately.

Reload privilege tables now? [Y/n] Y
 ... Success!

Cleaning up...

All done!  If you've completed all of the above steps, your MariaDB
installation should now be secure.

Thanks for using MariaDB!


donc ERROR 2002 est l'impossibilité à se connecter en local

merci de l'aide :good:
-- D3b1@n Stable + Testing-Unstable -.- Enlightenment / KDE Plasma - Kali -
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2821
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

15 avr. 2019, 09:24

Bel exemple de compromis à trouver entre sécurité et utilisabilité (je ne sais pas trop si ça se dit comme ça)
Trop de sécurité tue l'utilisabilité ..
Répondre