Retourner en http Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

04 févr. 2019, 10:39

Bonjour, je viens encore vous embêter un peu lol..
J'ai créer un certificat ssl et mit mon serveur ocs en https mais étant donné que je veux le déployer il faut que je retourne en http mais je ne sais pas comment faire..
Avatar du membre
Dunatotatos
Membre
Membre
Messages : 416
Enregistré le : 11 mai 2016, 20:56
Localisation : Arabie Saoudite
Status : Hors ligne

04 févr. 2019, 11:07

Qu'est-ce que "OCS" ? Pourquoi dois-tu retourner en HTTP ? Ton serveur "OCS" est déjà "déployé", s'il est en HTTPS... À moins que je ne comprenne pas ce que tu veux dire par "déployer".
Bref, il manque des détails ^^
Never trust Windows output.
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

04 févr. 2019, 11:10

Salut à toi, oui désolé je me suis très mal exprimer, en faite j'ai un projet avec OCSInventory et GLPI (Inventaire de Parc Informatique) pour un script de démarrage automatique via gpo je dois désactiver ma redirection automatique du server en https pour qu'elle retourne en http.
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

04 févr. 2019, 11:40

Salut,
La question c'est donc GLPI en http et non OCS, c'est ça?
Apache/Nginx? Tu as suivi un tuto? Donne le lien, on gagnera du temps... :icon_e_wink:
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

04 févr. 2019, 11:46

Non c'est bien OCS quand j'essaye d'y acceder en http, il me redirige automatique en https : Image Image

Après modification des fichiers 000-default.conf et default-ssl.conf je n'arrive toujours pas a me connecter en http car il fait encore la redirection : Image Image Image
Avatar du membre
Dunatotatos
Membre
Membre
Messages : 416
Enregistré le : 11 mai 2016, 20:56
Localisation : Arabie Saoudite
Status : Hors ligne

04 févr. 2019, 12:04

VirtualHost *:80 ne devrait pas rediriger vers http://..., puisqu'on y est déjà.
Never trust Windows output.
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

04 févr. 2019, 14:04

J'ai supprimé la ligne, restart le service mais toujours la même redirection en https..
Avatar du membre
Dunatotatos
Membre
Membre
Messages : 416
Enregistré le : 11 mai 2016, 20:56
Localisation : Arabie Saoudite
Status : Hors ligne

04 févr. 2019, 15:11

HTTPS ne fonctionnera pas sans certificat. De plus, avec la directive SSLEngine Off, les réponses de Apache seront en HTTP sur le port 443.
Tu peux soit ne pas accéder au site en HTTPS, soit fournir un certificat, et faire proposer une redirection vers HTTP (ou juste servir le site en HTTPS, c'est toujours mieux).
Never trust Windows output.
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

04 févr. 2019, 15:52

Comme je le disais je ne veut pas accéder au site en https :)
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

04 févr. 2019, 16:01

Salut,
Plutôt que des captures d'écran pas terribles hébergées ailleurs, préfère les balises de code, c'est bien plus adapté.
En ce qui me concerne je refuse d'aller voir des captures...

Code : Tout sélectionner

# cat /etc/apache2/sites-enabled/000-default.conf
<VirtualHost *:80>
        # Bla bla bla
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
Donne le vhost s'il te plaît, et surtout pas de capture d'écran! :diablo:

Prend aussi l'habitude de répondre aux questions...
lol a écrit :
04 févr. 2019, 11:40
Tu as suivi un tuto? Donne le lien, on gagnera du temps... :icon_e_wink:
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

04 févr. 2019, 16:48

Salut lol désolé mais pour le tuto je ne suis plus du tout sur. Et je privilégiais les captures pour plus de rapidité mais pas de soucis si tu préfères comme sa. Il me semble avoir suivi ce tuto : https://blog.infiniclick.fr/articles/in ... t-ssl.html

Code : Tout sélectionner

/etc/apache2/sites-enabled/000-default.conf
<VirtualHost *:80>
		Redirect permanent "/" "https://192.168.1.26/"
		ServerAdmin webmaster@localhost
		DocumentRoot /var/www/html
		ErrorLog ${APACHE_LOG_DIR}/error.log
		CustomLog ${APACHE_LOG_DIR}/access.log combined
		</VirtualHost>
Je dois donc enlever le Redirect permanent mais apres.. ?
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

04 févr. 2019, 19:11

Hello,
Ne t'excuse pas. Pense juste à faciliter la vie de ceux qui pourraient t'aider...
Rorro a écrit :
04 févr. 2019, 16:48
Je dois donc enlever le Redirect permanent mais apres.. ?
A priori, oui, c'est tout.
Il y a un fichier .htaccess à la racine du site?
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

05 févr. 2019, 08:16

Salut lol, le problème venait du cache de mon navigateur une fois l'avoir supprimé j'ai pu me connecter en http, merci beaucoup !
Répondre