Probleme OCS Inventory Agent/Serveur (Remontée SNMP) Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

21 janv. 2019, 11:04

Bonjour je ne sais pas si des personnes ici connaissent bien OCS mais j'ai un problème. Je n'ai pas de remontée snmp venant de mon poste agent windows, la remontée de l'inventaire ce fait bien (en https, donc ssl activé), le certificat a l'air valide, l'IPDiscover trouve bien les adresses de mon réseau mais impossible de les identifier, je ne sais pas comment faire, si vous pouvez bien m'aider..

Merci d'avance et bonne journée !
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

21 janv. 2019, 11:39

Bonjour,
je n'utilise pas OCS. Pour ton problème snmp, je commencerais par analyser les trames réseau reçue sur le serveur (avec wireshark par exemple)
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

21 janv. 2019, 13:43

Salut,
Il peut y avoir plein de raisons, ce n'est pas simple à déboguer sans plus d'infos.
Tu as des pare-feu côté "agent" et côté serveur ?
Comme le suggère Piratebab, l'analyse des trames réseau entre les deux machine te permettrais déjà d'y voir plus clair.

L'agent ping le serveur sans soucis ?
Tu as essayé en http pour commencer ?
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

21 janv. 2019, 14:20

Au niveau du Firewall des deux côtés tout est bon, l'agent ping bien le serveur car il y a bien la récuparation de l'inventaire sur le serveur, http sa marche mais pour le snmp c'est https obligé, d'après mon testeur de snmp il y aurait bien une erreur Image J'installe WireShark pour essayer d'en savoir plus
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

21 janv. 2019, 14:20

En tout cas merci de votre aide
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

21 janv. 2019, 14:33

Voilà le problème qui surgit, je ne sais pas d'ou le problème pourrait venir du coup car comme je le disais quand je lance un ping il ce fait très bien ^^" Image
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

21 janv. 2019, 15:57

Re,
Ça ressemble bien à un problème réseau... "No response" dans ton "snmp checker" + "destination unreachable" sur le ping!
Quelle est la topologie réseau? Les machines sont sur le même réseau physique? Il y a une VM dans les 2 machines?
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

21 janv. 2019, 16:00

Oui le serveur Debian est une VM, Les machines sont sur le même réseau et dans le même sous réseau ; 192.168.1.0 /24
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

21 janv. 2019, 16:10

As-tu testé le port snmp sur la debian elle-même ?
Quelque chose du genre (à adapter à ta configuration évidemment):
snmpwalk –v1 –c public localhost
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

21 janv. 2019, 16:24

Hmm je me serais trompé mais pourtant il me semblai bien avoir ajouté sur interface web sur ocs la chaine "public" :/Image
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

21 janv. 2019, 16:48

Re,
Je ne sais pas. Mais d'expérience il faut y aller pas à pas.
Tu as suivi un tuto ?
Je suppose que tu as tout d'abord installé snmp et snmpd ?
A cette étape il est primordial de tester que snmpd fonctionne (sur localhost et sur l'IP "publique").
Passer à l'installation de OCS inventory A/S ne sert à rien si le daemon snmpd ne fonctionne pas.

Code : Tout sélectionner

# snmpwalk -v1 -c public localhost
iso.3.6.1.2.1.1.1.0 = STRING: "Linux debian 4.9.0-5-amd64 #1 SMP Debian 4.9.65-3+deb9u2 (2018-01-04) x86_64"
...
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

21 janv. 2019, 16:57

Oui j'avais oublié d'installer le paquet (désolé novice ^^") Mais j'ai encore la même erreur dans mon SNMP Checker.. ^^"
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

21 janv. 2019, 18:54

Si tu ne veux pas descendre au niveau des trames réseau, tu peux utiliser nmap pour tester si les ports sont joignables, et quel service est en écoute derrière.
nmap fonctionne sous linux et sous windows, tu peux ainsi tester des 2 coté.
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

22 janv. 2019, 08:27

Bonjour je viens au nouvelles, j'ai suivis tes conseils pirate encore merci pour le support Pirate et lol ImageImageImageImage
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

22 janv. 2019, 08:34

Un petit test de snmpwalk, je peux faire ma machine mais pas mon autre (pour ajouter du détail) ImageImage
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

22 janv. 2019, 21:28

Tu n'as aucun port qui ressemble à du SNMP qui soit vu par nmap.
Quelque chose sur ton réseau bloque, par ex un proxy ou un parefeu
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

24 janv. 2019, 09:12

Bonjour merci de la réponse, après avoir activer le port 161/162 sur le serveur Debian et le service snmp sur Windows, sa ne marche toujours pas.. Je ne sais vraiment pas d'ou sa peut venir.. Image

EDIT : J'ai aussi fait la commande : snmpwalk -v 2c -c public 192.168.1.134
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

24 janv. 2019, 15:10

Est ce que nmap lancé depuis le client voit bien un service en écoute derrière les ports SNMP ?
Fait un coup de netstat sur le serveur pour voir quel port est en écoute (ou connecté)
Avatar du membre
Rorro
Membre
Membre
Messages : 25
Enregistré le : 17 janv. 2019, 11:05
Status : Hors ligne

24 janv. 2019, 16:03

Salut je te montre ce que sa donne Côté Client :

Code : Tout sélectionner

Starting Nmap 7.70 ( https://nmap.org ) at 2019-01-24 15:58 Paris, Madrid

NSE: Loaded 148 scripts for scanning.

NSE: Script Pre-scanning.

Initiating NSE at 15:58

Completed NSE at 15:58, 0.00s elapsed

Initiating NSE at 15:58

Completed NSE at 15:58, 0.00s elapsed

Initiating ARP Ping Scan at 15:58

Scanning 192.168.1.26 [1 port]

Completed ARP Ping Scan at 15:58, 0.91s elapsed (1 total hosts)

Initiating Parallel DNS resolution of 1 host. at 15:58

Completed Parallel DNS resolution of 1 host. at 15:58, 5.50s elapsed

Initiating SYN Stealth Scan at 15:58

Scanning 192.168.1.26 [1000 ports]

Discovered open port 443/tcp on 192.168.1.26

Discovered open port 22/tcp on 192.168.1.26

Discovered open port 80/tcp on 192.168.1.26

Completed SYN Stealth Scan at 15:58, 0.07s elapsed (1000 total ports)

Initiating Service scan at 15:58

Scanning 3 services on 192.168.1.26

Completed Service scan at 15:58, 12.93s elapsed (3 services on 1 host)

Initiating OS detection (try #1) against 192.168.1.26

Retrying OS detection (try #2) against 192.168.1.26

Retrying OS detection (try #3) against 192.168.1.26

Retrying OS detection (try #4) against 192.168.1.26

Retrying OS detection (try #5) against 192.168.1.26

NSE: Script scanning 192.168.1.26.

Initiating NSE at 15:58

Completed NSE at 15:59, 13.96s elapsed

Initiating NSE at 15:59

Completed NSE at 15:59, 0.00s elapsed

Nmap scan report for 192.168.1.26

Host is up (0.022s latency).

Not shown: 997 closed ports

PORT    STATE SERVICE  VERSION

22/tcp  open  ssh      OpenSSH 7.4p1 Debian 10+deb9u4 (protocol 2.0)

| ssh-hostkey: 

|   2048 e9:9e:94:f4:27:87:12:67:3b:bc:01:33:d3:34:e9:bf (RSA)

|   256 06:c8:b7:fe:93:a3:4d:7e:ef:85:53:16:bf:d7:7f:6d (ECDSA)

|_  256 59:ca:a0:6c:e7:93:41:9c:a8:84:99:2d:61:12:7c:ef (ED25519)

80/tcp  open  http     Apache httpd 2.4.25

| http-methods: 

|_  Supported Methods: GET HEAD POST OPTIONS

|_http-server-header: Apache/2.4.25 (Debian)

|_http-title: Did not follow redirect to https://192.168.1.26/

443/tcp open  ssl/http Apache httpd 2.4.25 ((Debian))

| http-methods: 

|_  Supported Methods: GET HEAD POST OPTIONS

|_http-server-header: Apache/2.4.25 (Debian)

|_http-title: Apache2 Debian Default Page: It works

| ssl-cert: Subject: commonName=192.168.1.26/organizationName=CAYON/stateOrProvinceName=SA\xC3\x83\xC2\x94NE-ET-LOIRE/countryName=FR

| Issuer: commonName=192.168.1.26/organizationName=CAYON/stateOrProvinceName=SA\xC3\x83\xC2\x94NE-ET-LOIRE/countryName=FR

| Public Key type: rsa

| Public Key bits: 2048

| Signature Algorithm: sha256WithRSAEncryption

| Not valid before: 2019-01-21T08:27:40

| Not valid after:  2020-01-21T08:27:40

| MD5:   418f 2986 3e79 97d1 b635 0927 734f 4e17

|_SHA-1: 51c8 7856 6623 03e2 b41f c669 038b bc94 1f17 09e0

|_ssl-date: TLS randomness does not represent time

| tls-alpn: 

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|   http/1.1

|_  http/1.1

MAC Address: 00:15:5D:CC:3A:2E (Microsoft)

No exact OS matches for host (If you know what OS is running on it, see https://nmap.org/submit/ ).

TCP/IP fingerprint:

OS:SCAN(V=7.70%E=4%D=1/24%OT=22%CT=1%CU=41033%PV=Y%DS=1%DC=D%G=Y%M=00155D%T

OS:M=5C49D2C1%P=i686-pc-windows-windows)SEQ(SP=109%GCD=1%ISR=107%TI=Z%CI=Z%

OS:II=I%TS=8)SEQ(CI=Z%II=I%TS=8)SEQ(CI=Z%II=I)OPS(O1=M5B4ST11NW7%O2=M5B4ST1

OS:1NW7%O3=M5B4NNT11NW7%O4=M5B4ST11NW7%O5=M5B4ST11NW7%O6=M5B4ST11)WIN(W1=71

OS:20%W2=7120%W3=7120%W4=7120%W5=7120%W6=7120)ECN(R=Y%DF=Y%T=40%W=7210%O=M5

OS:B4NNSNW7%CC=Y%Q=)T1(R=Y%DF=Y%T=40%S=O%A=S+%F=AS%RD=0%Q=)T2(R=N)T3(R=N)T4

OS:(R=Y%DF=Y%T=40%W=0%S=A%A=Z%F=R%O=%RD=0%Q=)T5(R=Y%DF=Y%T=40%W=0%S=Z%A=S+%

OS:F=AR%O=%RD=0%Q=)T6(R=Y%DF=Y%T=40%W=0%S=A%A=Z%F=R%O=%RD=0%Q=)T7(R=Y%DF=Y%

OS:T=40%W=0%S=Z%A=S+%F=AR%O=%RD=0%Q=)U1(R=Y%DF=N%T=40%IPL=164%UN=0%RIPL=G%R

OS:ID=5DF4%RIPCK=G%RUCK=G%RUD=G)IE(R=Y%DFI=N%T=40%CD=S)



Network Distance: 1 hop

Service Info: Host: GCSRVOCS.groupe.cayon; OS: Linux; CPE: cpe:/o:linux:linux_kernel



TRACEROUTE

HOP RTT      ADDRESS

1   21.88 ms 192.168.1.26



NSE: Script Post-scanning.

Initiating NSE at 15:59

Completed NSE at 15:59, 0.00s elapsed

Initiating NSE at 15:59

Completed NSE at 15:59, 0.00s elapsed

Read data files from: C:\Program Files (x86)\Nmap

OS and Service detection performed. Please report any incorrect results at https://nmap.org/submit/ .

Nmap done: 1 IP address (1 host up) scanned in 50.89 seconds

           Raw packets sent: 1108 (52.762KB) | Rcvd: 1223 (55.150KB)

Côté serveur : Image
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2883
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

24 janv. 2019, 18:50

sur le netstat de ton serveur, je ne vois rien concernant snmp . Est ce que le service snmp est démarré ?
service snmpd statut ?
Répondre