Migration sous Debian : stretch

Demande d'aide : c'est ici.
Répondre
Avatar du membre
jlD
Membre
Membre
Messages : 11
Enregistré le : 28 oct. 2018, 14:44
Status : Hors ligne

28 oct. 2018, 17:48

Bonjour
J'étais sous debian : wheezy, et il m' a pris de migrer sous stretch.
Donc
Je modifie le fichier /etc/apt/sources.list pour remplacer wheezy par stretch
Je lance les commandes
$ sudo apt-get upgrade
$ sudo apt-get dist-upgrade

Au bout d'un certain moment, la mise à jour est abandonnée, car il y a
trop d'erreur et notamment ceci :

Dépaquetage de texinfo (6.3.0.dfsg.1-1+b2) sur (4.13a.dfsg.1-10) ...
dpkg: avertissement: impossible de supprimer l'ancien répertoire
« /etc/texmf/fmt.d » : Directory not empty
dpkg: avertissement: impossible de supprimer l'ancien répertoire
« /etc/texmf » : Directory not empty

et puis la finale :

Paramétrage de libgdbm3:i386 (1.8.3-14) ...
dpkg: des problèmes de dépendances empêchent le traitement des actions
différées pour man-db :
man-db dépend de groff-base (>= 1.18.1.1-15) ; cependant :
Le paquet groff-base n'est pas encore configuré.
dpkg: erreur de traitement du paquet man-db (--configure) :
problèmes de dépendances - actions différées non exécutées
dpkg: des problèmes de dépendances empêchent le traitement des actions
différées pour man-db :
man-db dépend de groff-base (>= 1.18.1.1-15) ; cependant :
Le paquet groff-base n'est pas encore configuré.
dpkg: erreur de traitement du paquet man-db (--configure) :
problèmes de dépendances - actions différées non exécutées
dpkg: trop d'erreurs, arrêt
L'exécution a été arrêtée car il y avait trop d'erreurs.
E: Sub-process /usr/bin/dpkg returned an error code (1)

J'ai forcé l'installation de groff-base
j'ai lancé les commandes
$ sudo apt-get install groff-base
et
$ sudo apt-get dist-upgrade -o APT::Immediate-Configure=0

Et en fin de compte, la console me répond :
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^(.*?)(\\)?\${ <-- HERE ([^{}]+)}(.*)$/ at /usr/share/perl5/Debconf/Question.pm line 72.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE ([^}]+)}/ at /usr/share/perl5/Debconf/Config.pm line 30.
Extracting templates from packages: 100%
Preconfiguring packages ...
setting xserver-xorg-legacy/xwrapper/allowed_users from configuration file
dpkg: des problèmes de dépendances empêchent le traitement des actions différées pour man-db :
man-db dépend de groff-base (>= 1.18.1.1-15) ; cependant :
Le paquet groff-base n'est pas encore configuré.

dpkg: erreur de traitement de l'archive /var/cache/apt/archives/liblocale-gettext-perl_1.07-3+b1_i386.deb (--unpack) :
problèmes de dépendances - actions différées non exécutées
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/liblocale-gettext-perl_1.07-3+b1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Là, j'ai l'impression de tourner en rond. Que puis-je faire ?

Cordialement
Heureux qui comme Unique
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

29 oct. 2018, 09:38

Salut et bienvenu,

Ça arrive, tu as peut-être été un peu imprudent avec le apt-get dist-upgrade.
Une simulation aurait été intéressante...

Code : Tout sélectionner

# apt-get dist-upgrade -s
Bref... faut réparer maintenant.
Peux tu nous donner le contenu du fichier /etc/apt/sources.list AINSI que le contenu des fichiers dans /etc/apt/source.list.d s'il y en a.
Idem pour /etc/apt/preferences et les fichiers dans /etc/apt/preferences.d/.

Si tu lance cette commande:

Code : Tout sélectionner

# apt install -f
Tu as quel retour ?
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
PascalHambourg
Contributeur
Contributeur
Messages : 356
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

29 oct. 2018, 11:01

Tu as surtout été très imprudent de passer directement de Wheezy à Stretch en sautant Jessie. Il est fortement déconseillé de mettre à niveau sans passer par toutes les versions intermédiaires. Ces chemins de migration ne sont pas testés.
jlD a écrit : dpkg: avertissement: impossible de supprimer l'ancien répertoire
« /etc/texmf/fmt.d » : Directory not empty
C'est un avertissement (bénin), pas une erreur.

Note que si un paquet non essentiel comme man-db pose problème, tu peux le désinstaller puis le réinstaller plus tard après la fin de la mise à niveau.
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

29 oct. 2018, 13:03

Salut,
PascalHambourg a écrit :
29 oct. 2018, 11:01
Tu as surtout été très imprudent de passer directement de Wheezy à Stretch en sautant Jessie. Il est fortement déconseillé de mettre à niveau sans passer par toutes les versions intermédiaires. Ces chemins de migration ne sont pas testés.

Je n'avais même pas réalisé... :021:
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
jlD
Membre
Membre
Messages : 11
Enregistré le : 28 oct. 2018, 14:44
Status : Hors ligne

29 oct. 2018, 18:08

Bonjour et merci pour votre accueil
Oui, après coup, je me suis dit que j'aurais dû passer par la version jessie plutôt que de sauter directement à stretch : impatience de jeunesse :/

Dans /etc/apt/sources.list, il y a ceci :
#

deb http://ftp.fr.debian.org/debian/ stretch main
deb-src http://ftp.fr.debian.org/debian/ stretch main

deb http://security.debian.org/ stretch/updates main
deb-src http://security.debian.org/ stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main
deb http://ftp.fr.debian.org/debian stretch-backports main
deb-src http://ftp.fr.debian.org/debian stretch-backports main

Dans /etc/apt/sources.list.d, il y a 4 fichiers :
- 2 fichiers vides : heyarje-libav-11-wheezy.list et heyarje-libav-11-wheezy.list.save
- 2 fichiers : libdvdcss.list et libdvdcss.list.save, dans lesquels il y a :
deb http://download.videolan.org/pub/debian/stable/ /
deb-src http://download.videolan.org/pub/debian/stable/ /

Il n'y a pas de fichiers /etc/apt/preferences ni de fichiers dans /etc/apt/preferences.d/.

La commande # apt install -f ne me retourne rien du tout.

Merci pour votre intervention
Heureux qui comme Unique
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

30 oct. 2018, 06:41

Salut,
Je commencerais par simplifier ton sources.list comme ceci (Tu n'a pas besoin de sources de toute façon)

Code : Tout sélectionner

deb http://ftp.fr.debian.org/debian/ stretch main
#deb-src http://ftp.fr.debian.org/debian/ stretch main

deb http://security.debian.org/ stretch/updates main
#deb-src http://security.debian.org/ stretch/updates main

# stretch-updates, previously known as 'volatile'
#deb http://ftp.fr.debian.org/debian/ stretch-updates main
#deb-src http://ftp.fr.debian.org/debian/ stretch-updates main
#deb http://ftp.fr.debian.org/debian stretch-backports main
#deb-src http://ftp.fr.debian.org/debian stretch-backports main
Il faut aussi commenter ceci pour l'instant:
/etc/apt/sources.list.d/libdvdcss.list

Code : Tout sélectionner

#deb http://download.videolan.org/pub/debian/stable/ /
#deb-src http://download.videolan.org/pub/debian/stable/ /
A partir de là un apt-get update suivi d'un apt-get upgrade suivi enfin d'un apt-get dist-upgrade.
Donne nous si possible la sortie complète des deux dernières commandes.

Tu peux effectivement comme le dit PascalHambourg commencer par supprimer man-db qui t'empêche l'upgrade (tu le réinstallera éventuellement après.
ça donnerait donc:

Code : Tout sélectionner

# apt-get remove man-db
# apt-get update
# apt-get upgrade
# apt-get dist-upgrade.
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
jlD
Membre
Membre
Messages : 11
Enregistré le : 28 oct. 2018, 14:44
Status : Hors ligne

31 oct. 2018, 09:12

Salut lol
J'ai suivi tes directives.
Voici le retour de la commande apt-get upgrade :
dessort@DESSORT:~$ sudo apt-get upgrade
[sudo] password for dessort:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
comerr-dev : Dépend: libcomerr2 (= 1.43.4-2) mais 1.42.5-1.1+deb7u1 est installé
krb5-multidev : Dépend: libgssrpc4 (= 1.15-1+deb9u1) mais 1.10.1+dfsg-5+deb7u9 est installé
Dépend: libkadm5srv-mit11 (= 1.15-1+deb9u1) mais il n'est pas installé
Dépend: libkadm5clnt-mit11 (= 1.15-1+deb9u1) mais il n'est pas installé
libcairo-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libdevmapper1.02.1 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libglib-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libgtk2-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libhtml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libjson-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
liblocale-gettext-perl : Pré-Dépend: perlapi-5.14.2 mais il n'est pas installable
liblvm2app2.2 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libnet-cups-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-dbus-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-ssleay-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libp11-kit0 : Dépend: libc6 (< 2.14) mais 2.24-11+deb9u3 est installé
libpango-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libperl5.14 : Dépend: perl-base (= 5.14.2-21+deb7u6) mais 5.24.1-3+deb9u4 est installé
libpurple0 : Dépend: perlapi-5.14.2 mais il n'est pas installable
Recommande: libpurple-bin mais il n'est pas installé
libtext-charwidth-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libtext-iconv-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libuuid-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libxml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
locales : Dépend: libc-bin (> 2.24) mais 2.13-38+deb7u12 est installé
Dépend: libc-l10n (> 2.24) mais il n'est pas installé
nfs-common : Dépend: init-system-helpers (>= 1.18~) mais il n'est pas installé
Dépend: keyutils mais il n'est pas installé
perlmagick : Dépend: perlapi-5.14.2 mais il n'est pas installable
texinfo : Dépend: libtext-unidecode-perl mais il n'est pas installé
Dépend: libxml-libxml-perl mais il n'est pas installé
Dépend: tex-common (>= 6) mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

C'est ce que j'ai fait et cette commande me renvoit ceci :
... une longue liste de paquets qui se termine par :
dpkg: des problèmes de dépendances empêchent le traitement des actions différées pour man-db :
man-db dépend de groff-base (>= 1.18.1.1-15) ; cependant :
Le paquet groff-base n'est pas encore configuré.
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/liblocale-gettext-perl_1.07-3+b1_i386.deb (--unpack) :
problèmes de dépendances - actions différées non exécutées
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/liblocale-gettext-perl_1.07-3+b1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

et voici le retour de la commande apt-get dist-upgrade :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
comerr-dev : Dépend: libcomerr2 (= 1.43.4-2) mais 1.42.5-1.1+deb7u1 est installé
krb5-multidev : Dépend: libgssrpc4 (= 1.15-1+deb9u1) mais 1.10.1+dfsg-5+deb7u9 est installé
Dépend: libkadm5srv-mit11 (= 1.15-1+deb9u1) mais il n'est pas installé
Dépend: libkadm5clnt-mit11 (= 1.15-1+deb9u1) mais il n'est pas installé
libcairo-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libdevmapper1.02.1 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libglib-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libgtk2-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libhtml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libjson-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
liblocale-gettext-perl : Pré-Dépend: perlapi-5.14.2 mais il n'est pas installable
liblvm2app2.2 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libnet-cups-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-dbus-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-ssleay-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libp11-kit0 : Dépend: libc6 (< 2.14) mais 2.24-11+deb9u3 est installé
libpango-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libperl5.14 : Dépend: perl-base (= 5.14.2-21+deb7u6) mais 5.24.1-3+deb9u4 est installé
libpurple0 : Dépend: perlapi-5.14.2 mais il n'est pas installable
Recommande: libpurple-bin mais il n'est pas installé
libtext-charwidth-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libtext-iconv-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libuuid-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libxml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
locales : Dépend: libc-bin (> 2.24) mais 2.13-38+deb7u12 est installé
Dépend: libc-l10n (> 2.24) mais il n'est pas installé
nfs-common : Dépend: init-system-helpers (>= 1.18~) mais il n'est pas installé
Dépend: keyutils mais il n'est pas installé
perlmagick : Dépend: perlapi-5.14.2 mais il n'est pas installable
texinfo : Dépend: libtext-unidecode-perl mais il n'est pas installé
Dépend: libxml-libxml-perl mais il n'est pas installé
Dépend: tex-common (>= 6) mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Ce que j'ai fait et voilà le retour :
dpkg: des problèmes de dépendances empêchent le traitement des actions différées pour man-db :
man-db dépend de groff-base (>= 1.18.1.1-15) ; cependant :
Le paquet groff-base n'est pas encore configuré.

dpkg: erreur de traitement de l'archive /var/cache/apt/archives/liblocale-gettext-perl_1.07-3+b1_i386.deb (--unpack) :
problèmes de dépendances - actions différées non exécutées
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/liblocale-gettext-perl_1.07-3+b1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ben voilà de la lecture !!!
A+
Heureux qui comme Unique
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

31 oct. 2018, 16:11

Hello,
As-tu essayé de supprimer man-db?

Code : Tout sélectionner

apt-get remove man-db

Tu peux tenter aptitude, parfois (mais là il y a tellement de dépendance manquantes ou cassées que ça m'étonnerais... (-s pour une simulation. S'il enlève tout laisse tomber...).

Code : Tout sélectionner

aptitude upgrade -s

Je suggère de tenter en deux étapes car manifestement passer directement à Stretch casse tout...
Commence par passer à Jessie:

/etc/apt/sources.list

Code : Tout sélectionner

deb http://ftp.fr.debian.org/debian/ stretch main
deb http://security.debian.org/ stretch/updates main

Code : Tout sélectionner

apt-get update && apt-get upgrade && apt-dist upgrade

On verra pour Stretch plus tard...
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
Junichirô
Membre actif
Membre actif
Messages : 828
Enregistré le : 26 avr. 2016, 01:10
Localisation : Baillif (Guadeloupe)
Contact :
Status : Hors ligne

31 oct. 2018, 16:59

lol a écrit :
31 oct. 2018, 16:11
Je suggère de tenter en deux étapes car manifestement passer directement à Stretch casse tout...
Commence par passer à Jessie:

/etc/apt/sources.list

Code : Tout sélectionner

deb http://ftp.fr.debian.org/debian/ stretch main
deb http://security.debian.org/ stretch/updates main

Code : Tout sélectionner

apt-get update && apt-get upgrade && apt-dist upgrade

On verra pour Stretch plus tard...
Dans ce cas il vaut mieux remplacer stretch par jessie dans le sources.list
“Lorsque vous avez éliminé l’impossible, ce qui reste, si improbable soit-il, est nécessairement la vérité.”
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

31 oct. 2018, 18:04

oups...

Code : Tout sélectionner

deb http://ftp.fr.debian.org/debian/ stretch main
deb http://security.debian.org/ stretch/updates main
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
jlD
Membre
Membre
Messages : 11
Enregistré le : 28 oct. 2018, 14:44
Status : Hors ligne

01 nov. 2018, 16:00

Salut
Voici le retour de la commande
dessort@DESSORT:~$ sudo apt-get remove man-db
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
comerr-dev : Dépend: libcomerr2 (= 1.43.4-2) mais 1.42.5-1.1+deb7u1 devra être installé
krb5-multidev : Dépend: libgssrpc4 (= 1.15-1+deb9u1) mais 1.10.1+dfsg-5+deb7u9 devra être installé
Dépend: libkadm5srv-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
Dépend: libkadm5clnt-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
libcairo-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libdevmapper1.02.1 : Dépend: libudev1 (>= 183) mais il n'est pas installable
libglib-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libgtk2-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libhtml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libjson-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
liblocale-gettext-perl : Pré-Dépend: perlapi-5.14.2 mais il n'est pas installable
liblvm2app2.2 : Dépend: libudev1 (>= 183) mais il n'est pas installable
libnet-cups-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-dbus-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-ssleay-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libp11-kit0 : Dépend: libc6 (< 2.14) mais 2.24-11+deb9u3 devra être installé
libpango-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libperl5.14 : Dépend: perl-base (= 5.14.2-21+deb7u6) mais 5.24.1-3+deb9u4 devra être installé
libpurple0 : Dépend: perlapi-5.14.2 mais il n'est pas installable
Recommande: libpurple-bin mais il n'est pas installable
libtext-charwidth-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libtext-iconv-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libuuid-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libxml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
locales : Dépend: libc-bin (> 2.24) mais 2.13-38+deb7u12 devra être installé
Dépend: libc-l10n (> 2.24) mais il n'est pas installable
nfs-common : Dépend: init-system-helpers (>= 1.18~) mais il n'est pas installable
Dépend: keyutils mais il n'est pas installable
perlmagick : Dépend: perlapi-5.14.2 mais il n'est pas installable
texinfo : Dépend: libtext-unidecode-perl mais il n'est pas installable
Dépend: libxml-libxml-perl mais il n'est pas installable
Dépend: tex-common (>= 6) mais il n'est pas installable
yelp : Dépend: man-db (>= 2.5.1-1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
Ce que j'ai fait :
dessort@DESSORT:~$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... a échoué.
Les paquets suivants contiennent des dépendances non satisfaites :
comerr-dev : Dépend: libcomerr2 (= 1.43.4-2) mais 1.42.5-1.1+deb7u1 est installé
krb5-multidev : Dépend: libgssrpc4 (= 1.15-1+deb9u1) mais 1.10.1+dfsg-5+deb7u9 est installé
Dépend: libkadm5srv-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
Dépend: libkadm5clnt-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
libcairo-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libdevmapper1.02.1 : Dépend: libudev1 (>= 183) mais il n'est pas installable
libglib-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libgtk2-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libhtml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libjson-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
liblocale-gettext-perl : Pré-Dépend: perlapi-5.14.2 mais il n'est pas installable
liblvm2app2.2 : Dépend: libudev1 (>= 183) mais il n'est pas installable
libnet-cups-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-dbus-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-ssleay-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libp11-kit0 : Dépend: libc6 (< 2.14) mais 2.24-11+deb9u3 est installé
libpango-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libperl5.14 : Dépend: perl-base (= 5.14.2-21+deb7u6) mais 5.24.1-3+deb9u4 est installé
libpurple0 : Dépend: perlapi-5.14.2 mais il n'est pas installable
Recommande: libpurple-bin mais il n'est pas installable
libtext-charwidth-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libtext-iconv-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libuuid-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libxml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
locales : Dépend: libc-bin (> 2.24) mais 2.13-38+deb7u12 est installé
Dépend: libc-l10n (> 2.24) mais il n'est pas installable
nfs-common : Dépend: init-system-helpers (>= 1.18~) mais il n'est pas installable
Dépend: keyutils mais il n'est pas installable
perlmagick : Dépend: perlapi-5.14.2 mais il n'est pas installable
texinfo : Dépend: libtext-unidecode-perl mais il n'est pas installable
Dépend: libxml-libxml-perl mais il n'est pas installable
Dépend: tex-common (>= 6) mais il n'est pas installable
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances

: /
Heureux qui comme Unique
Avatar du membre
jlD
Membre
Membre
Messages : 11
Enregistré le : 28 oct. 2018, 14:44
Status : Hors ligne

01 nov. 2018, 16:06

J'ai modifier etc/apt/sources.list comme tu me l'as indiqué.
Et voici le retour de la commande
dessort@DESSORT:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
comerr-dev : Dépend: libcomerr2 (= 1.43.4-2) mais 1.42.5-1.1+deb7u1 est installé
krb5-multidev : Dépend: libgssrpc4 (= 1.15-1+deb9u1) mais 1.10.1+dfsg-5+deb7u9 est installé
Dépend: libkadm5srv-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
Dépend: libkadm5clnt-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
libcairo-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libdevmapper1.02.1 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libglib-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libgtk2-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libhtml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libjson-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
liblocale-gettext-perl : Pré-Dépend: perlapi-5.14.2 mais il n'est pas installable
liblvm2app2.2 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libnet-cups-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-dbus-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-ssleay-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libp11-kit0 : Dépend: libc6 (< 2.14) mais 2.24-11+deb9u3 est installé
libpango-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libperl5.14 : Dépend: perl-base (= 5.14.2-21+deb7u6) mais 5.24.1-3+deb9u4 est installé
libpurple0 : Dépend: perlapi-5.14.2 mais il n'est pas installable
Recommande: libpurple-bin mais il n'est pas installé
libtext-charwidth-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libtext-iconv-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libuuid-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libxml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
locales : Dépend: libc-bin (> 2.24) mais 2.13-38+deb7u12 est installé
Dépend: libc-l10n (> 2.24) mais il n'est pas installable
nfs-common : Dépend: init-system-helpers (>= 1.18~) mais il n'est pas installé
Dépend: keyutils mais il n'est pas installé
perlmagick : Dépend: perlapi-5.14.2 mais il n'est pas installable
texinfo : Dépend: libtext-unidecode-perl mais il n'est pas installé
Dépend: libxml-libxml-perl mais il n'est pas installé
Dépend: tex-common (>= 6) mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Ce que j'ai fait et voici le retour :
dessort@DESSORT:~$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... a échoué.
Les paquets suivants contiennent des dépendances non satisfaites :
comerr-dev : Dépend: libcomerr2 (= 1.43.4-2) mais 1.42.5-1.1+deb7u1 est installé
krb5-multidev : Dépend: libgssrpc4 (= 1.15-1+deb9u1) mais 1.10.1+dfsg-5+deb7u9 est installé
Dépend: libkadm5srv-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
Dépend: libkadm5clnt-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
libcairo-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libdevmapper1.02.1 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libglib-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libgtk2-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libhtml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libjson-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
liblocale-gettext-perl : Pré-Dépend: perlapi-5.14.2 mais il n'est pas installable
liblvm2app2.2 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libnet-cups-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-dbus-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-ssleay-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libp11-kit0 : Dépend: libc6 (< 2.14) mais 2.24-11+deb9u3 est installé
libpango-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libperl5.14 : Dépend: perl-base (= 5.14.2-21+deb7u6) mais 5.24.1-3+deb9u4 est installé
libpurple0 : Dépend: perlapi-5.14.2 mais il n'est pas installable
Recommande: libpurple-bin mais il n'est pas installé
libtext-charwidth-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libtext-iconv-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libuuid-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libxml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
locales : Dépend: libc-bin (> 2.24) mais 2.13-38+deb7u12 est installé
Dépend: libc-l10n (> 2.24) mais il n'est pas installable
nfs-common : Dépend: init-system-helpers (>= 1.18~) mais il n'est pas installé
Dépend: keyutils mais il n'est pas installé
perlmagick : Dépend: perlapi-5.14.2 mais il n'est pas installable
texinfo : Dépend: libtext-unidecode-perl mais il n'est pas installé
Dépend: libxml-libxml-perl mais il n'est pas installé
Dépend: tex-common (>= 6) mais il n'est pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances

: /
Comment se fait-il qu'il y ait tant de paquets "non installables" ?
Heureux qui comme Unique
Avatar du membre
jlD
Membre
Membre
Messages : 11
Enregistré le : 28 oct. 2018, 14:44
Status : Hors ligne

01 nov. 2018, 16:11

Pour finir, voici le retour de la dernière commande :
dessort@DESSORT:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
comerr-dev : Dépend: libcomerr2 (= 1.43.4-2) mais 1.42.5-1.1+deb7u1 est installé
krb5-multidev : Dépend: libgssrpc4 (= 1.15-1+deb9u1) mais 1.10.1+dfsg-5+deb7u9 est installé
Dépend: libkadm5srv-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
Dépend: libkadm5clnt-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
libcairo-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libdevmapper1.02.1 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libglib-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libgtk2-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libhtml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libjson-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
liblocale-gettext-perl : Pré-Dépend: perlapi-5.14.2 mais il n'est pas installable
liblvm2app2.2 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libnet-cups-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-dbus-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-ssleay-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libp11-kit0 : Dépend: libc6 (< 2.14) mais 2.24-11+deb9u3 est installé
libpango-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libperl5.14 : Dépend: perl-base (= 5.14.2-21+deb7u6) mais 5.24.1-3+deb9u4 est installé
libpurple0 : Dépend: perlapi-5.14.2 mais il n'est pas installable
Recommande: libpurple-bin mais il n'est pas installé
libtext-charwidth-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libtext-iconv-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libuuid-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libxml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
locales : Dépend: libc-bin (> 2.24) mais 2.13-38+deb7u12 est installé
Dépend: libc-l10n (> 2.24) mais il n'est pas installable
nfs-common : Dépend: init-system-helpers (>= 1.18~) mais il n'est pas installé
Dépend: keyutils mais il n'est pas installé
perlmagick : Dépend: perlapi-5.14.2 mais il n'est pas installable
texinfo : Dépend: libtext-unidecode-perl mais il n'est pas installé
Dépend: libxml-libxml-perl mais il n'est pas installé
Dépend: tex-common (>= 6) mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Ce que j'ai fait :
dessort@DESSORT:~$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... a échoué.
Les paquets suivants contiennent des dépendances non satisfaites :
comerr-dev : Dépend: libcomerr2 (= 1.43.4-2) mais 1.42.5-1.1+deb7u1 est installé
krb5-multidev : Dépend: libgssrpc4 (= 1.15-1+deb9u1) mais 1.10.1+dfsg-5+deb7u9 est installé
Dépend: libkadm5srv-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
Dépend: libkadm5clnt-mit11 (= 1.15-1+deb9u1) mais il n'est pas installable
libcairo-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libdevmapper1.02.1 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libglib-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libgtk2-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libhtml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libjson-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
liblocale-gettext-perl : Pré-Dépend: perlapi-5.14.2 mais il n'est pas installable
liblvm2app2.2 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libnet-cups-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-dbus-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libnet-ssleay-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libp11-kit0 : Dépend: libc6 (< 2.14) mais 2.24-11+deb9u3 est installé
libpango-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libperl5.14 : Dépend: perl-base (= 5.14.2-21+deb7u6) mais 5.24.1-3+deb9u4 est installé
libpurple0 : Dépend: perlapi-5.14.2 mais il n'est pas installable
Recommande: libpurple-bin mais il n'est pas installé
libtext-charwidth-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libtext-iconv-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libuuid-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
libxml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
locales : Dépend: libc-bin (> 2.24) mais 2.13-38+deb7u12 est installé
Dépend: libc-l10n (> 2.24) mais il n'est pas installable
nfs-common : Dépend: init-system-helpers (>= 1.18~) mais il n'est pas installé
Dépend: keyutils mais il n'est pas installé
perlmagick : Dépend: perlapi-5.14.2 mais il n'est pas installable
texinfo : Dépend: libtext-unidecode-perl mais il n'est pas installé
Dépend: libxml-libxml-perl mais il n'est pas installé
Dépend: tex-common (>= 6) mais il n'est pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances

Et même punition. Et même question : Comment se fait-il qu'il y ait tant de paquets (les mêmes) "non installables" ?
A+
Heureux qui comme Unique
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

01 nov. 2018, 19:48

Salut,
jlD a écrit :
01 nov. 2018, 16:11
Et même question : Comment se fait-il qu'il y ait tant de paquets (les mêmes) "non installables" ?

La belle mécanique est cassée (et tes sources.list ne laissent pas beaucoup de marge à apt).
Reste une solution:
Mettre les trois branches dans ton sources.list:

cat /etc/apt/sources.list

Code : Tout sélectionner

deb http://ftp.fr.debian.org/debian/ stretch main
deb http://security.debian.org/ stretch/updates main
deb http://ftp.fr.debian.org/debian/ jessie main
deb http://ftp.fr.debian.org/debian/ wheezy main


On pourra alors tenter un upgrade "progressif".
Tu fais un apt-get update (donne nous le retour de la commande) puis un apt upgrade -s (-s = simulation. donne nous aussi le retour).
SI la commande fonctionne donne aussi le retour de apt list --upgradable
On tentera alors, de faire la mise à niveau progressivement en fonction du résultat.
Ça va être un peu coton...
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
Avatar du membre
Junichirô
Membre actif
Membre actif
Messages : 828
Enregistré le : 26 avr. 2016, 01:10
Localisation : Baillif (Guadeloupe)
Contact :
Status : Hors ligne

01 nov. 2018, 22:36

A ce point là, on espère que tu as un /home séparé et que tu vas te lancer dans une belle installation toute neuve. ça ira plus vite.
“Lorsque vous avez éliminé l’impossible, ce qui reste, si improbable soit-il, est nécessairement la vérité.”
Avatar du membre
lol
Membre hyper actif
Membre hyper actif
Messages : 2952
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

02 nov. 2018, 06:27

Salut,
Junichirô a écrit :
01 nov. 2018, 22:36
A ce point là, on espère que tu as un /home séparé et que tu vas te lancer dans une belle installation toute neuve. ça ira plus vite.

Rien ne dis que c'est une machine qui fait office de desktop (/home séparé).
Oui, ça ira plus vite mais il n'aura rien appris...
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Générateur de sources.list!
PascalHambourg
Contributeur
Contributeur
Messages : 356
Enregistré le : 05 août 2016, 20:25
Status : Hors ligne

02 nov. 2018, 10:59

Il a déjà appris (à la dure) le plus important : on ne fait pas de mise à niveau en sautant une version.
Avatar du membre
jlD
Membre
Membre
Messages : 11
Enregistré le : 28 oct. 2018, 14:44
Status : Hors ligne

02 nov. 2018, 15:06

Salut
Hmmm ! Déjà la commande gedit commence à me signaler quelques pbs :
dessort@DESSORT:~$ sudo gedit /etc/apt/sources.list
[sudo] password for dessort:
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values in <test> isn't supported and may not work as expected

(gedit:29374): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: La création du fichier « /root/.local/share/recently-used.xbel.NN9GRZ » a échoué : No such file or directory

(gedit:29374): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(gedit:29374): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: La création du fichier « /root/.local/share/recently-used.xbel.Y8SSRZ » a échoué : No such file or directory

(gedit:29374): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(gedit:29374): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: La création du fichier « /root/.local/share/recently-used.xbel.ITHYRZ » a échoué : No such file or directory

(gedit:29374): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

Il manque un fichier sous root, chose que le système ne me signalait pas auparavant.
Faut-il y remédier ?
Heureux qui comme Unique
Avatar du membre
jlD
Membre
Membre
Messages : 11
Enregistré le : 28 oct. 2018, 14:44
Status : Hors ligne

02 nov. 2018, 16:18

Voici le retour pour la commande :
dessort@DESSORT:~$ sudo apt-get update
Atteint http://ftp.fr.debian.org stretch Release.gpg
Atteint http://security.debian.org stretch/updates Release.gpg
Atteint http://ftp.fr.debian.org jessie Release.gpg
Atteint http://security.debian.org stretch/updates Release
Atteint http://ftp.fr.debian.org wheezy Release.gpg
Atteint http://ftp.fr.debian.org stretch Release
Atteint http://security.debian.org stretch/updates/main i386 Packages
Atteint http://ftp.fr.debian.org jessie Release
Atteint http://security.debian.org stretch/updates/main Translation-en
Atteint http://ftp.fr.debian.org wheezy Release
Atteint http://ftp.fr.debian.org stretch/main i386 Packages
Atteint http://ftp.fr.debian.org stretch/main Translation-fr
Atteint http://ftp.fr.debian.org stretch/main Translation-en
Atteint http://ftp.fr.debian.org jessie/main i386 Packages
Atteint http://ftp.fr.debian.org jessie/main Translation-fr
Atteint http://ftp.fr.debian.org jessie/main Translation-en
Atteint http://ftp.fr.debian.org wheezy/main i386 Packages
Atteint http://ftp.fr.debian.org wheezy/main Translation-fr
Atteint http://ftp.fr.debian.org wheezy/main Translation-en
Lecture des listes de paquets... Fait
W: Ignoring Provides line with DepCompareOp for package libapt-inst
W: Ignoring Provides line with DepCompareOp for package libapt-pkg
W: Ignoring Provides line with DepCompareOp for package libespeak-dev
W: Ignoring Provides line with DepCompareOp for package libespeak1
W: Ignoring Provides line with DepCompareOp for package libgpgme11-dev
W: Ignoring Provides line with DepCompareOp for package kodi-api-guilib
W: Ignoring Provides line with DepCompareOp for package kodi-api-pvr
W: Ignoring Provides line with DepCompareOp for package libparse-cpan-meta-perl
W: Ignoring Provides line with DepCompareOp for package libjpeg62
W: Ignoring Provides line with DepCompareOp for package lsb
W: Ignoring Provides line with DepCompareOp for package lsb-core
W: Ignoring Provides line with DepCompareOp for package php-psr-log-implementation
W: Ignoring Provides line with DepCompareOp for package php-seclib
W: Ignoring Provides line with DepCompareOp for package php-sabre-http
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pkg-config
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package sagenb-export
W: Ignoring Provides line with DepCompareOp for package sagenb-export
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
Heureux qui comme Unique
Avatar du membre
jlD
Membre
Membre
Messages : 11
Enregistré le : 28 oct. 2018, 14:44
Status : Hors ligne

02 nov. 2018, 16:22

Et voici le retour de la commande :
dessort@DESSORT:~$ sudo apt-get upgrade -s
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
comerr-dev : Dépend: libcomerr2 (= 1.43.4-2) mais 1.42.5-1.1+deb7u1 est installé
krb5-multidev : Dépend: libgssrpc4 (= 1.15-1+deb9u1) mais 1.10.1+dfsg-5+deb7u9 est installé
Dépend: libkadm5srv-mit11 (= 1.15-1+deb9u1) mais il n'est pas installé
Dépend: libkadm5clnt-mit11 (= 1.15-1+deb9u1) mais il n'est pas installé
libcairo-perl : Dépend: perlapi-5.14.2
libdevmapper1.02.1 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libglib-perl : Dépend: perlapi-5.14.2
libgtk2-perl : Dépend: perlapi-5.14.2
libhtml-parser-perl : Dépend: perlapi-5.14.2
libjson-xs-perl : Dépend: perlapi-5.14.2
liblocale-gettext-perl : Pré-Dépend: perlapi-5.14.2
liblvm2app2.2 : Dépend: libudev1 (>= 183) mais il n'est pas installé
libnet-cups-perl : Dépend: perlapi-5.14.2
libnet-dbus-perl : Dépend: perlapi-5.14.2
libnet-ssleay-perl : Dépend: perlapi-5.14.2
libp11-kit0 : Dépend: libc6 (< 2.14) mais 2.24-11+deb9u3 est installé
libpango-perl : Dépend: perlapi-5.14.2
libperl5.14 : Dépend: perl-base (= 5.14.2-21+deb7u6) mais 5.24.1-3+deb9u4 est installé
libpurple0 : Dépend: perlapi-5.14.2
Recommande: libpurple-bin mais il n'est pas installé
libtext-charwidth-perl : Dépend: perlapi-5.14.2
libtext-iconv-perl : Dépend: perlapi-5.14.2
libuuid-perl : Dépend: perlapi-5.14.2
libxml-parser-perl : Dépend: perlapi-5.14.2
locales : Dépend: libc-bin (> 2.24) mais 2.13-38+deb7u12 est installé
Dépend: libc-l10n (> 2.24) mais il n'est pas installé
nfs-common : Dépend: init-system-helpers (>= 1.18~) mais il n'est pas installé
Dépend: keyutils mais il n'est pas installé
perlmagick : Dépend: perlapi-5.14.2
texinfo : Dépend: libtext-unidecode-perl mais il n'est pas installé
Dépend: libxml-libxml-perl mais il n'est pas installé
Dépend: tex-common (>= 6) mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

A+
Heureux qui comme Unique
Répondre