Mapper un lecteur réseaux à l'aide de la commande MOUNT Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Avatar du membre
fabdunet13
Messages : 4
Enregistré le : 24 juil. 2018, 12:00
Status : Hors ligne

24 juil. 2018, 12:06

Bonjour tout le monde,

Comment allez vous ?, Pouvez vous m’aider SVP ?

Je vous explique : Sous Windows 10 j’ai des partages réseaux et j’aimerais arriver à les consulter depuis mon linux Debian (installé sans interface graphique).
Avant quand mes postes été sous Windows 7 sa fonctionné et depuis que je suis passé sous Windows 8 et Windows 10 mes ligne de commande ne fonctionne plus.

Code : Tout sélectionner

mount -t cifs -o username=administrateur,password=OK //192.168.0.10/Data /media/Windows/Data
mount -t smbfs //192.168.0.10/Data /media/Windows/Data -o username=administrateur -o passwd=OK
Mon objectif est de connecter mes quatres ordinateurs de la maison sur ce serveur Linux et faire des sauvegarde sans programmé les quatres postes. (C’est un anciel de chez vous qui me l’avez conseillé Mr LOL:-) )

Pouvez vous m’aider s’il vous plait a monter mes lecteurs réseaux ?
Linux debian01 4.9.0-7-amd64 #1 SMP Debian 4.9.110-1 (2018-07-05) x86_64 GNU/Linux
Avatar du membre
fabdunet13
Messages : 4
Enregistré le : 24 juil. 2018, 12:00
Status : Hors ligne

24 juil. 2018, 12:12

J'ai oublier le plus important, je vous donne le message d’erreur

root@debian01:/media# mount -t smbfs //192.168.0.3/c$ /media/c -o username=administrateur -o passwd=OK
mount: type de système de fichiers « smbfs » inconnu
root@debian01:/media#
Linux debian01 4.9.0-7-amd64 #1 SMP Debian 4.9.110-1 (2018-07-05) x86_64 GNU/Linux
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2882
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

24 juil. 2018, 19:58

Pourquoi as tu 2 lignes pour la même chose ?
La ligne doit étre du type:

Code : Tout sélectionner

    mount -t cifs  //192.168.0.10/Data  /media/Windows/Data
ce qui signifie que tu monte le répertoire distant de type fichier windows sur le point de montage /media/Windows/Data
ensuite au bout tu rajoutes -o suivi des options (username et password)
Les types reconnus sont:
adfs, affs, autofs, cifs, coda, coherent, cramfs, debugfs, devpts, efs, ext, ext2, ext3, ext4, hfs, hfsplus, hpfs, iso9660, jfs, minix, msdos, ncpfs, nfs, nfs4, ntfs, proc, qnx4, ramfs, reiserfs, romfs, squashfs, smbfs, sysv, tmpfs, ubifs, udf, ufs, umsdos, usbfs, vfat, xenix, xfs, xiafs
si cifs ou smbfs ne fonctionnent pas, essais auto
Assures toi aussi que coté windows le partage est autorisé
et vérifie coté linux que cifs-utils est bien installé
Avatar du membre
fabdunet13
Messages : 4
Enregistré le : 24 juil. 2018, 12:00
Status : Hors ligne

25 juil. 2018, 00:31

Merci :-)
ça marche
Linux debian01 4.9.0-7-amd64 #1 SMP Debian 4.9.110-1 (2018-07-05) x86_64 GNU/Linux
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2882
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

25 juil. 2018, 12:08

c'était quoi le problème ?
Avatar du membre
fabdunet13
Messages : 4
Enregistré le : 24 juil. 2018, 12:00
Status : Hors ligne

14 nov. 2018, 13:53

piratebab a écrit :
25 juil. 2018, 12:08
c'était quoi le problème ?
Tout simplement la ligne de commande fonctionne sur des partage depuis le HDD local sous windows (SATA) et non en USB. Sa parais bizarre mais pour tant vrais .
Merci de votre aide et désolé de la réponse en retard
[Le problème provenais de windows et non de nos ligne de commande Linux]
Linux debian01 4.9.0-7-amd64 #1 SMP Debian 4.9.110-1 (2018-07-05) x86_64 GNU/Linux
Répondre