Clamav et openssl... wtf ??? Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
Andromède
Messages : 4
Enregistré le : 29 mai 2018, 00:00
Status : Hors ligne

29 mai 2018, 00:18

Bonjour,

Je suis sous debian stretch.
Lorsque je passe par les dépôts pour installer clamav, ça marche mais lorsque je fais un freshclam ça me dit que la version est obsolète.
Soit.
Je vais sur le site clamav.net sur lequel je télécharge la version recommandée lors de mon freshclam.
Je télécharge et j'installe toute les dépendances requises, puis je lance un ./configure

Et là... WTF ??? ça me marque un :

Code : Tout sélectionner

checking for OpenSSL installation... /usr
configure: error: Your OpenSSL installation is misconfigured or missing
alors j'opte pour la première proposition vu qu'openssl est installé.
Le soucis c'est que le bug est présent sur beaucoup de pages web, mais je n'ai pas trouvé la solution.

Quelqu'un pourrait me guider s'il vous plaît ?

D'avance merci.
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2714
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

29 mai 2018, 08:20

Bonjour,
vérifie dans quel chemin il cherche le fichier, et dans quel chemin il se trouve réellement. Suivant les distributions, il peut y avoir des différences.
Mais de façon générale, évite ce type d'installation et privilégie les paquets debian. Soit via les backports, soit via un fichier preference pour avoir des versions plus récentes que celles de la stable.
Andromède
Messages : 4
Enregistré le : 29 mai 2018, 00:00
Status : Hors ligne

29 mai 2018, 17:40

Merci Piratebab pour ton intervention.

Oui je privilégie habituellement les dépôt et j'essaye toujours de chopper un .deb dans le cas où rien ne soit présent dans les backports.
Là justement, je suis dans le cas où j'ai pas envie de voir le message de version obsolète.
En tout cas je crois que le bug vient du code dans configure en lui même.

le ssl.h se trouve dans le /usr/include/openssl/

Il le trouve d'ailleurs quand on voit la ligne au dessus lorsqu'il affiche /usr

Après dans le fichier configure, je publie un fragment de code, celui que je pense être responsable de l'arrêt de configure, Je ne suis malheureusement pas assez calé en code pour savoir ce qui cloche. A noter que je suis loin d'être le seul à avoir ce bug.

Voici donc les tests effectués par configure à partir du moment où il a affiché /usr

Code : Tout sélectionner

17546 save_LDFLAGS="$LDFLAGS"
17547 save_CFLAGS="$CFLAGS"
17548 save_LIBS="$LIBS"
17549 
17550 SSL_LIBS="$LIBS -lssl -lcrypto -lz"
17551 LIBS="$LIBS $SSL_LIBS"
17552 
17553 if test "$LIBSSL_HOME" != "/usr"; then
17554     SSL_LDFLAGS="-L$LIBSSL_HOME/lib"
17555     SSL_CPPFLAGS="-I$LIBSSL_HOME/include"
17556     LDFLAGS="-L$LIBSSL_HOME/lib"
17557     CFLAGS="$SSL_CPPFLAGS"
17558 else
17559     SSL_LDFLAGS=""
17560     SSL_CPPFLAGS=""
17561 fi
17562 
17563 have_ssl="no"
17564 have_crypto="no"
17565 
17566 cat confdefs.h - <<_ACEOF >conftest.$ac_ext
17567 /* end confdefs.h.  */
17568 #include <openssl/ssl.h>
17569 int
17570 main ()
17571 {
17572 SSL_library_init();
17573   ;
17574   return 0;
17575 }
17576 _ACEOF
17577 if ac_fn_c_try_link "$LINENO"; then :
17578   have_ssl="yes";
17579 else
17580   as_fn_error $? "Your OpenSSL installation is misconfigured or missing" "$LINENO" 5
17581 fi
Merci
Andromède
Messages : 4
Enregistré le : 29 mai 2018, 00:00
Status : Hors ligne

30 mai 2018, 20:34

Trouvé !

Après quelques recherches je me suis aperçu qu'il me manquait les dépendance -dev de zlib et libssl + je n'avais pas téléchharger le fichier .sig et mis dans le dossier d'install. Pour les dépendances -dev, c'est spécifié dans le PDF d'install de clamav si besoin.

Une fois tout ce ptit monde ajouté, plus de problème avec configure. :icon_e_biggrin:

Cela pourra peut-être servir de retour à des gens qui sont dans le même cas que moi

A++
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2714
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

31 mai 2018, 08:17

C'est à dire qui n'ont pas lu le pdf d'install ? :)
Andromède
Messages : 4
Enregistré le : 29 mai 2018, 00:00
Status : Hors ligne

31 mai 2018, 23:47

Lol, bin en même temps, sur le site est publiée la liste des dépendances mais elle est incomplète.

Au début, je n'avais pas vu que le pdf d'install se trouvait dans le package :P
Enfin bon, le tout est de s'en apercevoir hahaha
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2714
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : En ligne

01 juin 2018, 09:47

C'est généralement le cas. Lorsque tu ne passe pas par les packets, tu as dans l'archive que tu as téléchargé un fichier texte INSTALL qu'il est important de lire. Parfois il n'apporte rien, parfois il est trés utile.
Tu as même parfois un fichier debian-install.
C'est une bonne habitude de les lire!
Répondre