Montage NFS au boot Le sujet est résolu

Demande d'aide : c'est ici.
Message
Auteur
Avatar de l’utilisateur
Arnaud
Membre
Membre
Messages : 149
Inscription : 23 avr. 2016, 14:31
Localisation : Allemagne
Status : Hors-ligne

Montage NFS au boot

#1 Messagepar Arnaud » 16 févr. 2018, 11:47

Bonjour,

Depuis quelques semaines, mes partages NFS ne sont plus montés au démarrage de l'ordinateur. Ce n'est ni un problème urgent, ni réellement gênant, mais j'aimerais tout de même en comprendre l'origine pour le réparer.

L'erreur au boot :

Code : Tout sélectionner

# journalctl -b -p err
-- Logs begin at Fri 2018-02-16 09:09:12 CET, end at Fri 2018-02-16 11:42:29 CET. --
févr. 16 09:09:12 ordi blkmapd[357]: open pipe file /run/rpc_pipefs/nfs/blocklayout failed: No such file or directory
févr. 16 09:09:15 ordi systemd[1]: Failed to mount /media/PartageNFS.


J'ai trouvé quelques reports de bugs à l'encontre de blkmapd, mais il est partout spécifié que le problème est résolu "dans la nouvelle version", en sachant que les reports de bugs datent de début 2017.

Contenu du Fstab :

Code : Tout sélectionner

192.168.42.42:/media/PartageNFS  	/media/PartageNFS    	nfs     x-systemd.automount,users,rsize=32768,wsize=32768,nolock,_netdev       0        0

Une idée ?

Avatar de l’utilisateur
piratebab
Modérateur
Modérateur
Messages : 2277
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Re: Montage NFS au boot

#2 Messagepar piratebab » 16 févr. 2018, 15:42

une option de montage que tu as utilisé et qui serait "dépréciée" ?

Avatar de l’utilisateur
Arnaud
Membre
Membre
Messages : 149
Inscription : 23 avr. 2016, 14:31
Localisation : Allemagne
Status : Hors-ligne

Re: Montage NFS au boot

#3 Messagepar Arnaud » 03 mars 2018, 17:28

J'ai tenté de désactiver la plupart des options, je pense que le problème ne vient pas de fstab, mais bien du démon blkmapd.

Il y a bien un bug report ici : https://bugs.debian.org/cgi-bin/bugrepo ... bug=850464

Dans le fichier de configuration systemd de nfs-blkmap, j'ai le bon chemin : /run ... à la place de /var/run ... donc l'origine doit être différente.

Avatar de l’utilisateur
Arnaud
Membre
Membre
Messages : 149
Inscription : 23 avr. 2016, 14:31
Localisation : Allemagne
Status : Hors-ligne

Re: Montage NFS au boot  Le sujet est résolu

#4 Messagepar Arnaud » 01 mai 2018, 16:06

Résolu lors de la dernière mise à jour.


Revenir à « Support Debian »

Qui est en ligne ?

Utilisateurs parcourant ce forum : R2D21 et 4 invités