freecad et debian

Demande d'aide : c'est ici.
Répondre
Avatar du membre
debianjam
Membre
Membre
Messages : 162
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

18 sept. 2017, 16:33

Messieurs je voudrais lancer une série de sujets d'aide pour l'installation de logiciels qui à priori ne semblent pas trop faciles
comment installer freecad dans debian 9 ?
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2907
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

19 sept. 2017, 09:05

Avec aptitude ?
La difficulté n'est pas l'installation, mais l'utilisation. C'est un logiciel qui traite d'un domaine complexe, la conception méca 3D.
Avatar du membre
dezix
Membre
Membre
Messages : 437
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

19 sept. 2017, 11:46

@debianjam

Salut,

Te réfères-tu à une version plus récente que celle de stable ?

Car il y a de cela quelques temps... je voulais apprendre à me servir de FreeCAD.
À cette époque, la communauté recommandait l'installation de la dernière version pour se focaliser sur cette dernière.

Personnellement n'ayant pas d'expérience dans la compilation de paquets maison,
j'ai abandonné après quelques bonnes prises de tête.

Mais il semble que la version actuelle soit 0.16.6712 => c'est celle proposée par testing et la stable propose aussi une version 0.16

Donc apparemment plus besoin de bidouiller son paquet soi-même ;-)
Debian testing/stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 162
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

24 sept. 2017, 20:06

Bonjour, je viens de procéder à l'installation de freecad avec synaptic et bravo c'est extrêmement simple et ça semble tout à fait fonctionnel.
Mea coulpa je n'avais jamais employé synaptic qui me semblait compliqué et trop difficile à comprendre, c'est en fait simple et efficace dans debian 9.
Par contre j'avais beaucoup de mal avec les indications que l'on trouve chez freecad.
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2907
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

24 sept. 2017, 20:29

si tu as un fichier preferences et un sources.list multi versions de debian, synaptic te permet de façon simple d'aller pioché dans d'autres versions de debian.
a tes risques et périls bien évidement ..
Avatar du membre
debianjam
Membre
Membre
Messages : 162
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

17 juil. 2018, 13:38

0.17 est sortie avril 2018 et est à installer de cette façon pour GNU/Linux users
début de citation
"FreeCAD can be installed from most Linux distributions official repositories, but the version they provide might be quite dated and be missing many features. Instead you can download the linked AppImage above, mark it as executable and launch it without installation. Please see the Install on Unix page for more installation options, including how to get up-to-date packages for Ubuntu and derivatives ." selon https://www.freecadweb.org/wiki/Download
fin de citation
effectivement freecad 0.17 se retrouve à côté de 0.16 dans le menu d'applications
intéressant étant donnée la liste importante d'améliorations comparé à 0.16
Avatar du membre
debianjam
Membre
Membre
Messages : 162
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

27 juil. 2018, 20:34

bonjour, croyez vous qu'on arriverait à installer 0.18 qui est la version daily ?
https://www.freecadweb.org/wiki/Install ... th_console
https://launchpad.net/~freecad-maintain ... ecad-daily
j'ai installé calculix-ccx avec synaptic
puis voici ce qui se passe dans le terminal

Code : Tout sélectionner

utilisateur1@debian:~$ su
Mot de passe : 
root@debian:/home/utilisateur1# add-apt-repository ppa:freecad-maintainers/freecad-daily
 Ubuntu daily builds of FreeCAD. These packages are generated by Launchpad's automatic system, and are untested.

Note: the ccx package brings CalculiX support to the FEM workbench, and needs to be installed separately.
 More info: https://launchpad.net/~freecad-maintainers/+archive/ubuntu/freecad-daily
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmpsgxpygiy/pubring.gpg' created
gpg: failed to start the dirmngr '/usr/bin/dirmngr': Aucun fichier ou dossier de ce type
gpg: connecting dirmngr at '/tmp/tmpsgxpygiy/S.dirmngr' failed: Aucun fichier ou dossier de ce type
gpg: keyserver receive failed: Pas de dirmngr
root@debian:/home/utilisateur1# apt-get update
Ign:1 http://deb.debian.org/debian stretch InRelease
Réception de:2 http://security.debian.org stretch/updates InRelease [94,3 kB]
Réception de:3 http://deb.debian.org/debian stretch-updates InRelease [91,0 kB]                        
Réception de:4 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu cosmic InRelease [15,4 kB]
Atteint:5 http://deb.debian.org/debian stretch Release                                                  
Ign:4 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu cosmic InRelease
Réception de:6 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu cosmic/main i386 Packages [1 120 B]
Réception de:7 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu cosmic/main amd64 Packages [1 120 B]
Réception de:9 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu cosmic/main Translation-en [820 B]
204 ko réceptionnés en 0s (272 ko/s)   
Lecture des listes de paquets... Fait
W: Erreur de GPG : http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu cosmic InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 005EAE8119BB5BCA
W: The repository 'http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu cosmic InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@debian:/home/utilisateur1# ^C
root@debian:/home/utilisateur1# 
Avatar du membre
dezix
Membre
Membre
Messages : 437
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

28 juil. 2018, 00:21

Salut,

Je ne veux pas t'alarmer inutilement mais ajouter des sources de paquets venant d'Ubuntu (ou d'ailleurs que des dépôts Debian) me parait risqué pour ton système,
à moins que tu saches exactement ce que tu fais ... bien évidemment ;-)

Je ne suis personnellement pas assez qualifié pour te conseiller dans cette voie :((
mais je crois que tu devrais (si c'est pas déjà le cas) tester sur une VM VirtualBox ou autre système "jetable" plutôt que sur ton système principal.

Une Question : j'ai freecad 0.16.6712+dfsg1-3 amd64 (testing)

et je n'ai pas l'interface web interne pour accéder à la doc en ligne.
La console python affiche : No module webgui

Est-ce que toi aussi tu as ce problème ?

Merci pour ton retour.

@+
Debian testing/stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 162
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

28 juil. 2018, 11:51

bonjour +dezix c'est exact il s'agit bien de paquets ubuntu on le voit dans les adresses des packages et seulement là
une discussion extérieure m'a fait savoir si j'ai bien compris que les paquets allaient être mis au point pour debian cet été https://plus.google.com/u/0/+jacquesmor ... aVeLYbnRyo
je ne comprends pas les réponses du terminal lors de la tentative d'installation mais on dirait que le système se protège tout seul

votre question : je crois que mon interface web est complètement fonctionnelle voici ce qui s'affiche https://photos.app.goo.gl/2NmEFDM14GJCzrPE9
pourquoi ne pas passer à 0.17 il y a plus deux ans d'écart entre les deux versions et quand on voit dans certaines vidéo ce qu'apporte la version 0.18 on a aussi très envie de l'utiliser https://youtu.be/oX2XoszM6sY
Avatar du membre
dezix
Membre
Membre
Messages : 437
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

28 juil. 2018, 13:12

Merci,
tu as bien l'interface web.

Effectivement, je pourrais ... je vais tester AppImage de la version 0.17

Sur https://github.com/FreeCAD/FreeCAD/releases l'AppImage de 0.18 est disponible

C'est ce que tu devrais essayer plutôt de faire des mixes Ubuntu/Debian qui risquent de finir en casse-tête pour restaurer les dépendances correctes
de toutes façons, il me semble que apt ne gère pas (au moins par défaut les ppa d'ubuntu)

Au mieux/pire je téléchargerai manuellement le .deb et je tenterai son installation via Gdebi qui demandera de satisfaire les dépendances avant d'accepter ton paquet.

là encore ça peut tourner au casse-tête avec des des dépendances en cascades et finalement l'impossibilité d'installer certains paquets en conflit avec ce qui est déjà sur ton système.

Fais une sauvegarde de ton système avant de tenter ça => je te recommande fsarchiver pour la sauvegarde ; il est inclus dans SystemRescueCD

@+
Debian testing/stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 162
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

30 juil. 2018, 18:14

+dezix
je vais essayer de ne pas prendre trop de risques donc je ne vais pas insister
d'ailleurs au début si j'avais mieux compris que c'était pour ubuntu je n'aurais pas tenté autant
cette méthode Applmage parait intéressante mais on est un peu perdu devant tant de fichiers je me demande comment on s'y prend pour utiliser ça
Avatar du membre
dezix
Membre
Membre
Messages : 437
Enregistré le : 04 juin 2016, 14:50
Diaspora* : dezix@framasphere.org
Status : Hors ligne

05 août 2018, 11:42

Je n'ai pas eu le temps de tester (en plus je suis en panne sur mon poste de travail fixe)

mais pour ce qui m'a semblé, AppImge est un fichier qui permet de faire tourner l'application sans installation,
donc sans risque
et c'est certainement pas trop compliqué (il y a surement un README explicatif)

J'esserai de tester quand j'aurai réparé et un peu de temps

@+
Debian testing/stable - XFCE
Avatar du membre
debianjam
Membre
Membre
Messages : 162
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

02 juil. 2019, 13:58

Bonjour, un applmge de freecad 018 est disponible sur le site freecad, une fois téléchargé et le fichier rendue exécutable dans le menu propriétés on accède à 018 avec un double clic sur le fichier
Avatar du membre
debianjam
Membre
Membre
Messages : 162
Enregistré le : 27 août 2017, 14:18
Status : Hors ligne

26 août 2019, 09:35

bonjour,
je n'arrive pas à importer un modèle collada avec mon freecad 0.18
cette importation nécessite un module python pycollada que je vois installé avec le gestionnaire de paquet synaptic
or lorsque j'importe un fichier DAE donc un fichier collada, freecad 0.18 répond :
"pycollada introuvable, le support de collada est désactivé"
je ne trouve pas de réglage dans les préférences pour améliorer le problème
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 2907
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

26 août 2019, 09:45

essaie de lancer ton freecad depuis un terminal, tu auras peut étre plus d'infos sur l'erreur.
Par exemple, est ce que c'est un problème de version ou de chemin.
Répondre