Paquets défectueux Le sujet est résolu

Demande d'aide : c'est ici.
Message
Auteur
sylvain-deb
Membre
Membre
Messages : 12
Inscription : 15 mai 2018, 17:13
Status : Hors-ligne

Paquets défectueux

#1 Messagepar sylvain-deb » 15 mai 2018, 17:24

Bonjour à tous.
Debian est réputé pour sa stabilité et c'est vrai. Pourtant je rencontre un problème et je ne vois nul par sur le net une solution. Pour essayé de faire cours j'ai voulu installé un logiciel que je n'ai trouvé qu'en rajoutant a ma source.list le dépot sid. Après installation du dit logiciel j'ai supprimé la ligne de sid et fait un update et upgrade. Depuis j'ai rencontré des problèmes, notemment sur brasero que j'ai résolu en passant par une installation via synaptic.
J'ai voulu ensuite pour vérifier mon système installer debsums et la problème. Je vous met les différents retour que j'ai eu pour l'installation :

Code : Tout sélectionner

root@sylvaindeb:/home/sylvain# apt install debsums
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 debsums : Dépend: libfile-fnmatch-perl mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@sylvaindeb:/home/sylvain# 

root@sylvaindeb:/home/sylvain# apt install libfile-fnmatch-perl
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libfile-fnmatch-perl : Dépend: perlapi-5.24.1
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@sylvaindeb:/home/sylvain# 

root@sylvaindeb:/home/sylvain# apt install perlapi-5.24.1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet perlapi-5.24.1 est un paquet virtuel fourni par :
  perl-base 5.24.1-3+deb9u3 [Pas de version candidate]
  perl-base 5.24.1-3+deb9u2 [Pas de version candidate] 

Ma version de debian :

Code : Tout sélectionner

Linux sylvaindeb 4.15.0-2-amd64 #1 SMP Debian 4.15.11-1 (2018-03-20) x86_64 GNU/Linux
buster/sid
Debian GNU/Linux buster/sid \n \l
Un grand merci si quelqu'un peut m'aider!!!!

marcastro
Membre actif
Membre actif
Messages : 638
Âge : 66
Inscription : 22 avr. 2016, 12:05
Localisation : 83560 Saint Julien
Status : Hors-ligne

Re: Paquets défectueux

#2 Messagepar marcastro » 15 mai 2018, 18:09

Après installation du dit logiciel j'ai supprimé la ligne de sid et fait un update et upgrade.

si tu veux installer un logiciel depuis sid il faut absolument faire un fichier preferences pour ce logiciel et ne pas supprimer l'entrée sid dans ton sources.list.
sur le forum depuis 2007.
testing 4.16-amd64#1 sid 4.16-amd64 stretch4.16- bpo nvidia-driver

Avatar de l’utilisateur
piratebab
Site Admin
Site Admin
Messages : 2618
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Re: Paquets défectueux

#3 Messagepar piratebab » 15 mai 2018, 19:50

Pour y voir plus clair, poste le sources.list tel qu'il est aujourdhui, et explique précisément les lignes que tu as enlevé/ajouter lors de tes différentes manips.

sylvain-deb
Membre
Membre
Messages : 12
Inscription : 15 mai 2018, 17:13
Status : Hors-ligne

Re: Paquets défectueux

#4 Messagepar sylvain-deb » 17 mai 2018, 14:01

Code : Tout sélectionner

deb http://ftp.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ stretch-updates main contrib non-free

deb http://security.debian.org/debian-security stretch/updates main 


Ensuite donc j'avais ajouter cette ligne mais sans mettre quoi que se soit dans le fichier preference :

Code : Tout sélectionner

deb http://ftp.debian.org/debian/ sid main

Et donc forcément tout c'est mis a jour en version sid puis effacement de cette ligne et rebasculement en stable. Debian n'a pas trop aimé. J'ai eu un autre problème avec brasero qui se plantait mais en passant par synaptic j'ai pu régler le problème. Ca n'a pas marché avec debsums.

Avatar de l’utilisateur
piratebab
Site Admin
Site Admin
Messages : 2618
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Re: Paquets défectueux

#5 Messagepar piratebab » 17 mai 2018, 15:06

rien d'anormal dans ton sources.list. A part les deb-src qui sont rarement utiles.

Essaie avec aptitude au lieu de apt-get, il est plus adapté pour résoudre les problèmes. Il propose parfois des solutions intéressantes.

marcastro
Membre actif
Membre actif
Messages : 638
Âge : 66
Inscription : 22 avr. 2016, 12:05
Localisation : 83560 Saint Julien
Status : Hors-ligne

Re: Paquets défectueux

#6 Messagepar marcastro » 17 mai 2018, 17:45

quel est le nom du logiciel sid que tu voulais installer? ce logiciel existe il dans les backports?
sur le forum depuis 2007.
testing 4.16-amd64#1 sid 4.16-amd64 stretch4.16- bpo nvidia-driver

sylvain-deb
Membre
Membre
Messages : 12
Inscription : 15 mai 2018, 17:13
Status : Hors-ligne

Re: Paquets défectueux

#7 Messagepar sylvain-deb » 18 mai 2018, 15:14

le logiciel que je voulais installer est keePassXC
sinon pour aptitude encore une surprise, il n'est pas installé sur ma debian. J'ai voulu l'installer et voila le message recu :

Code : Tout sélectionner

apt install aptitude
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 aptitude : Dépend: aptitude-common (= 0.8.7-1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
A savoir que :

Code : Tout sélectionner

apt install aptitude-common
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
aptitude-common est déjà la version la plus récente (0.8.10-6).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

sylvain-deb
Membre
Membre
Messages : 12
Inscription : 15 mai 2018, 17:13
Status : Hors-ligne

Re: Paquets défectueux

#8 Messagepar sylvain-deb » 18 mai 2018, 15:21

Finalement j'ai réussi avec synaptic a "enlever" aptitude-common 0.8.10-6 mais voila le dernier message auquel j'ai répondu non évidemment :

Code : Tout sélectionner

apt install aptitude
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  analog debian-policy developers-reference-fr doc-debian-fr doc-linux-fr-text
  firefox-esr-l10n-fr gir1.2-vte-2.91 hp-ppd libcairo-perl libept1.5.0
  libglib-perl libgtk2-perl libpango-perl librarian0 maint-guide-fr
  manpages-fr manpages-fr-extra python-debian python-debianbts python-httplib2
  python-pycurl python-pysimplesoap python3-debconf python3-debian
  python3-debianbts python3-httplib2 python3-pycurl python3-pysimplesoap
  rarian-compat synaptic x11-apps x11-session-utils xinit xorg
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  libcwidget3v5
Paquets suggérés :
  aptitude-doc-en | aptitude-doc apt-xapian-index debtags tasksel
  libcwidget-dev
Les paquets suivants seront ENLEVÉS :
  apt apt-listchanges apt-utils python-reportbug python3-reportbug reportbug
  task-desktop task-french task-french-desktop task-print-server
  task-ssh-server task-web-server tasksel tasksel-data
Les NOUVEAUX paquets suivants seront installés :
  aptitude libcwidget3v5
ATTENTION : Les paquets essentiels suivants vont être enlevés.
Vous NE devez PAS faire ceci, à moins de savoir exactement ce
que vous êtes en train de faire.
  apt
0 mis à jour, 2 nouvellement installés, 14 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 1 790 ko dans les archives.
Après cette opération, 1 208 ko d'espace disque seront libérés.
Vous êtes sur le point de faire quelque chose de potentiellement dangereux
Pour continuer, tapez la phrase « Oui, faites ce que je vous dis ! »
 ?]

Avatar de l’utilisateur
piratebab
Site Admin
Site Admin
Messages : 2618
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Re: Paquets défectueux

#9 Messagepar piratebab » 18 mai 2018, 15:50

aptitude-common est déjà la version la plus récente (0.8.10-6)
0.8.10 est une version qu'on ne trouve qu'a partir de la testing, pas en stable. Je n sais pas ce que tu as fait, mais il semblerai que toi non plus, tu es avec des paquets plus récents que la stable. Impossible de revenir simplement en stable.
Fai toi un sources.list complet , et un fichier preferences pour une stable. Au moins, ça te permettra de piocher dans la bonne version et d'installer tes paquets. Ce ne seront peut étre pas ceux de la stable, mais au moins tu ne seras pas bloqué.

sylvain-deb
Membre
Membre
Messages : 12
Inscription : 15 mai 2018, 17:13
Status : Hors-ligne

Re: Paquets défectueux

#10 Messagepar sylvain-deb » 18 mai 2018, 18:38

Fai toi un sources.list complet , et un fichier preferences pour une stable. Au moins, ça te permettra de piocher dans la bonne version et d'installer tes paquets. Ce ne seront peut étre pas ceux de la stable, mais au moins tu ne seras pas bloqué.
La j'avoue ca dépasse un peu mes compétences sous debian de faire un fichier preferences pour une stable!!!

marcastro
Membre actif
Membre actif
Messages : 638
Âge : 66
Inscription : 22 avr. 2016, 12:05
Localisation : 83560 Saint Julien
Status : Hors-ligne

Re: Paquets défectueux

#11 Messagepar marcastro » 18 mai 2018, 21:01

avant toute chose sauvegarder l'existant parce la suite risque d'être rock'n'roll . Je verrais deux possibilités pour arriver à remettre de l'ordre:
la première possibilité serait de supprimer ton paquet keepassxc et de rétrograder toutes ses dépendances en installant ces mêmes dépendances avec leurs paquets .deb issus de stable, un peu long mais faisable. Il est prudent de ne pas supprimer ces dépendances parce qu'elles peuvent servir à d'autres paquets installés.
Une fois que c'est fait alors réinstaller keepassxc pris dans sid; MAIS créer un fichier preferences avant installation.
Le fichier preferences est fait ainsi:

Package: *
Pin: release n=sid
Pin-priority:100

Package: keepassxc
Pin: release n=sid
Pin-Priority: 900

des explications et des exemples pour le pinnig: https://debian-facile.org/doc:systeme:a ... references

https://wiki.debian-fr.xyz/L%27etiqueta ... references

La deuxième possibilité c'est créer le fichier preferences tout de suite et de continuer à utiliser le système tel quel mais je pense que c'est moins propre. Moi je commencerais par la première possibilité mais ce n'est que mon point de vue.

NB: ne pas oublier de rajouter la ligne sid dans le sources.list.
sur le forum depuis 2007.
testing 4.16-amd64#1 sid 4.16-amd64 stretch4.16- bpo nvidia-driver

Avatar de l’utilisateur
piratebab
Site Admin
Site Admin
Messages : 2618
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Re: Paquets défectueux

#12 Messagepar piratebab » 19 mai 2018, 07:45

marcastro, il semblerait qu'il n'y ai pas que keepassx qui soit passé en SID.
syvain-db, c'est avec ce genre d'expérience qu'on progresse dans la connaissance de son systeme. debian est une distribution très adaptable, tu peux la tordre dans tout les sens, et toujours la faire fonctionner!

marcastro
Membre actif
Membre actif
Messages : 638
Âge : 66
Inscription : 22 avr. 2016, 12:05
Localisation : 83560 Saint Julien
Status : Hors-ligne

Re: Paquets défectueux

#13 Messagepar marcastro » 19 mai 2018, 08:44

eh oui! peut être que le mieux pour sylvain-db serait de basculer complètement sur une sid en modifiant son sources list et en installant le paquet apt-listbugs. Mais je n'ai jamais fais basculer une stable en sid directement sans passer par testing avant, là je ne sais pas si c'est possible ou recommandé.
sur le forum depuis 2007.
testing 4.16-amd64#1 sid 4.16-amd64 stretch4.16- bpo nvidia-driver

sylvain-deb
Membre
Membre
Messages : 12
Inscription : 15 mai 2018, 17:13
Status : Hors-ligne

Re: Paquets défectueux

#14 Messagepar sylvain-deb » 19 mai 2018, 15:59

Et une réinstallation en sauvant mon home pourrait-il solutionner le problème???
Ou en sauvegardant mon home je sauvegarderai des paquets issus de sid???

marcastro
Membre actif
Membre actif
Messages : 638
Âge : 66
Inscription : 22 avr. 2016, 12:05
Localisation : 83560 Saint Julien
Status : Hors-ligne

Re: Paquets défectueux

#15 Messagepar marcastro » 19 mai 2018, 16:38

c'est pas ton home le problème mais les libs de ton système qui sont passées en sid; pour retrouver un système sain non bancal il faudrait soit réinstaller une stable soit basculer tout ton système sur sid . La bascule sur sid est la solution la plus rapide; si tu choisis cette voie tu peux lire cette page qui donne des bons conseils:

https://wiki.debian.org/fr/DebianUnstable

L'avantage de sid c'est que tu as les paquets les plus récents; souvent avant qu'ils ne descendent dans la version stable; exemple avec keepassxc.

et un petit topo sur dpkg qui est utile quand on bricole en sid(ou en testing aussi):

https://wiki.debian-fr.xyz/DPKG
sur le forum depuis 2007.
testing 4.16-amd64#1 sid 4.16-amd64 stretch4.16- bpo nvidia-driver

Avatar de l’utilisateur
piratebab
Site Admin
Site Admin
Messages : 2618
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Re: Paquets défectueux

#16 Messagepar piratebab » 20 mai 2018, 07:21

Sans aller jusqu'a tout passer en SID, je propose de rester en stable, ou en testing, en allant piocher dans SID au besoin pour débloque une situation. Petit à petit, la situation va se stabiliser sur une hybride stable/SID.
Pour un débutant, c'est à mon avis moins risquer.
La gestion d'une SID requiert un peu d'expérience, ça reste "en développement"!

sylvain-deb
Membre
Membre
Messages : 12
Inscription : 15 mai 2018, 17:13
Status : Hors-ligne

Re: Paquets défectueux

#17 Messagepar sylvain-deb » 22 mai 2018, 12:30

Code : Tout sélectionner

Package: *
Pin: release o=Debian,a⁼stable
Pin-Priority: 500

Package: keepassxc
Pin: release n=sid
Pin-Priority: 490

Package: aptitude
Pin: release n=sid
Pin-Priority: 490


J'ai essayé de créer ce fichier preferences mais dès que je fais un apt update et après j'ai fait un apt --upgradable pour voir et Debian veut mettre a jour plus de 700 paquets en sid. Si quelqu'un peut me dire comment éviter qu'il me mette tout le système en version sid. J'ai regardé les différents liens pour paramétrer le fichier preferences et je pensais que ce que j'avais fait était bon mais apparemment pas!!

marcastro
Membre actif
Membre actif
Messages : 638
Âge : 66
Inscription : 22 avr. 2016, 12:05
Localisation : 83560 Saint Julien
Status : Hors-ligne

Re: Paquets défectueux

#18 Messagepar marcastro » 22 mai 2018, 13:43

plus haut je t'ai indiqué un fichier preferences pour keepassxc sans faire basculer tout ton système en sid.
sur le forum depuis 2007.
testing 4.16-amd64#1 sid 4.16-amd64 stretch4.16- bpo nvidia-driver

Avatar de l’utilisateur
piratebab
Site Admin
Site Admin
Messages : 2618
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Re: Paquets défectueux

#19 Messagepar piratebab » 23 mai 2018, 10:04

Comme je l'ai expliqué, essayer de bloquer un seul paquet est acrobatique et requiers de l'expérience.
Alors qu'avoir un fichier sources.list complet + un fichier préférences pour tout bloquer par défaut en stable, puis gérer ensuite au cas par cas me semble plus simple et moins risquer.
Je n'ai pas de fichier sources.list et préférences à te conseiller, il y en a peut étre sur notre wiki. Sinon tu en trouveras sur le net, c'est du classique debian.

sylvain-deb
Membre
Membre
Messages : 12
Inscription : 15 mai 2018, 17:13
Status : Hors-ligne

Re: Paquets défectueux  Le sujet est résolu

#20 Messagepar sylvain-deb » 24 mai 2018, 14:01

Alors pour donner une suite a ce post j'ai finalement décider de réinstaller debian stable et repartir sur une meilleur base. Jonglé avec 2 versions de debian c'est pas vraiment une chose facile a faire (enfin pour moi!! lol) !!
Je retenterai l'expérience d'installer une version d'un logiciel mais avec un peu plus de recul et de précaution. Ca m'a quand même appris qu'on pouvait jongler avec différentes versions de debian pour avoir un logiciel plus récent par exemple.
Merci à tous ceux qui ont pris le temps de m'aider!!!


Revenir à « Support Debian »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités