probleme ispconfig et double version PHP

Demande d'aide : c'est ici.
Message
Auteur
keryado
Messages : 6
Inscription : 28 janv. 2018, 19:16
Status : Hors-ligne

probleme ispconfig et double version PHP

#1 Messagepar keryado » 28 janv. 2018, 20:09

Bonjour,
Je suis Didier, je remet les mains dans le cambouis après avoir délaissé mes serveurs qui tournent sans problème depuis des années.

Je viens de refaire mon serveur avec debian 9. J'ai installé ensuite ISPConfig 3 et j'ai choisi de mettre les deux versions de php 5.6 et 7 vu que j'ai besoin pour un site de php 5.6.
Le problème, c'est que j'ai eu un message pendant l'installation.

Attention You had installed php7 and php 5.6 to make php 5.6 you had to configure the following in ispconfig
Path for PHP FastCGI binary : /usr/bin/php-cgi5.6
Path for php.ini directory : /etc/php/5.6/cgi
Path for PHP-FPM init script : /etc/init.d/php5.6-fpm
Path for php.ini directory : /etc/php/5.6/fpm
Path for PHP-FPM pool directory : /etc/php/5.6/fpm/pool.d

je n'arrive donc pas à mettre sur mon site php5.6 le 7 est par default. J'ai bien compris dans l'info ci-dessous qu'il fallait modifier un fichier de config, mais après plusieurs heures de recherche je cale ! voilà mon problème. Sinon le serveur tourne sans problème, il a juste le problème php7. Reste un soucis du même style avec Roundcube, un problème aussi de chemin, mais je n'ai pas eu le temps de copier le message, je verrais plus tard quitte à refaire une installation.

merci d'avance aux membres de ce forum pour l'aide .

Bonne soirée

Didier

keryado
Messages : 6
Inscription : 28 janv. 2018, 19:16
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#2 Messagepar keryado » 28 janv. 2018, 21:27

RE
En fait je viens de trouver la solution. Il faut aller dans ISpconfig, système,additional php versions, cliquez sur le nom du serveur et ensuite rentrer les infos pour FASTCGI Settings et PHP-FPM.
Bref à force de chercher....

Bonne soirée

Didier

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2762
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#3 Messagepar lol » 29 janv. 2018, 06:24

Salut et bienvenu!
Dnoc si j'ai bien compris tu as installé les deux versions de php pendant l'installation de ispconfig (tu n'as pas compilé php5 à partir des sources à posteriori) ?
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

keryado
Messages : 6
Inscription : 28 janv. 2018, 19:16
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#4 Messagepar keryado » 12 févr. 2018, 17:52

bonjour,

Oui j'ai installé les deux versions en automatique, j'ai juste changé les chemins pour FASTCGI etc....
Sauf que maintenant j'ai un site en php7 qui fonctionne et un autre en php 5 .6 qui génère une erreur 500 ! SI je le met en php7 ca fonctionne.
j'ai été voir dans var/log/apache2/error.log, je ne vois rien pour m'éclairer. J'ai pensé à une erreur de chemin, mais j'ai vérifié et je ne trouve pas de problème. Je viens de découvrir ce problème. J'ai regardé mes dernières bidouilles, j'ai juste rajouté un rewrite dans etc/phpmymadin pour forcer le https pour phpmyadmin, je ne pense pas que cela puisse jouer dans l'affaire.

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteCond %{REQUEST_URI} ^/monmail
RewriteRule ^/?(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Merci

Didier

keryado
Messages : 6
Inscription : 28 janv. 2018, 19:16
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#5 Messagepar keryado » 12 févr. 2018, 18:27

Salut

Du nouveau, j'ai vérifié les chemins de php5.6 /user/bin/php-cgi5.6 il n'y a pas de fichier avec ce nom dans le répertoire, idem pour etc/php/ /etc/php/5.6/cgi pourtant, pendant l'installation, j'ai eu un message en rouge me demandant de rajouter les chemins. Bref panade..

Bonne soirée

Didier

keryado
Messages : 6
Inscription : 28 janv. 2018, 19:16
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#6 Messagepar keryado » 12 févr. 2018, 18:50

En fait j'ai compris, j'ai fait deux fois l'installation du serveur, et la deuxième fois, il ne m'a pas demandé de rajouter les chemins. Donc je pense que l'installation n'a pas rajouté php5.6. Maintenant soit je fais une réinstallation. Soit je tente ce tuto https://www.howtoforge.com/tutorial/how ... 9-stretch/
Je ne sais pas si c'est jouable de rajouter manuellement maintenant ?

Didier

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2762
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#7 Messagepar lol » 13 févr. 2018, 06:49

Salut,
Le tuto est ok, je l'ai souvent suivi pour compiler plusieurs versions de PHP sur mes installations IpsConfig - sur un serveur j'ai 5 versions de php...
Donc normalement pas de problème.
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

keryado
Messages : 6
Inscription : 28 janv. 2018, 19:16
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#8 Messagepar keryado » 13 févr. 2018, 13:02

Salut

En fait j'ai tenté l'installation 5.6 mais j'ai été bloqué à ce niveau nano /opt/php-5.6/etc/php-fpm.conf, il ne trouvait pas le fichier. Vu le temps que j'ai passé, j'ai préféré recommencer toute l'installation de A à Z du serveur , ce qui m'a permis de profiter pour faire un tuto pour la prochaine fois. Maintenant tout est ok, plus de problèmes.

Merci
Didier

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2762
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#9 Messagepar lol » 13 févr. 2018, 16:32

Ben de rien!
Tu as du rater un "cp" avant
Un truc du genre:

Code : Tout sélectionner

cp /opt/php-5.6/etc/php-fpm.conf.default /opt/php-5.6/etc/php-fpm.conf

Content que tu y soit parvenu en tout cas (même si c'est dommage de réinstaller :icon_wink: )
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

boubou81
Messages : 3
Inscription : 11 oct. 2018, 13:03
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#10 Messagepar boubou81 » 11 oct. 2018, 13:06

keryado a écrit :
13 févr. 2018, 13:02
Salut

En fait j'ai tenté l'installation 5.6 mais j'ai été bloqué à ce niveau nano /opt/php-5.6/etc/php-fpm.conf, il ne trouvait pas le fichier. Vu le temps que j'ai passé, j'ai préféré recommencer toute l'installation de A à Z du serveur , ce qui m'a permis de profiter pour faire un tuto pour la prochaine fois. Maintenant tout est ok, plus de problèmes.

Merci
Didier
Bonjour,
Si j'ai bien compris, tu as reussi une installation sans compilation des autres versions de PHP. Dans ce cas, je veux bien un accès à ton tuto. Merci d'avance.
Boubou81

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2762
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#11 Messagepar lol » 11 oct. 2018, 20:22

Salut,
Sur les nouvelles installations de ispconfig (debian 9) on te propose d'installer PHP 5.6 en plus de PHP 7.
Je ne sais pas si c'est compilé ou pas (C'est en arrière plan pendant l'installation).
Je vérifie et je te dis ça (j'ai fait une installation aujourd'hui)...
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2762
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#12 Messagepar lol » 15 oct. 2018, 17:49

Hello,
J'ai vérifié, les deux versions sont installées via apt.

Code : Tout sélectionner

~# apt-cache policy php5.6
php5.6:
  Installé : 5.6.38-1+0~20181001133120.5+stretch~1.gbpcf4838
  Candidat : 5.6.38-1+0~20181001133120.5+stretch~1.gbpcf4838
 Table de version :
 *** 5.6.38-1+0~20181001133120.5+stretch~1.gbpcf4838 100
        100 https://packages.sury.org/php stretch/main amd64 Packages
        100 /var/lib/dpkg/status

Code : Tout sélectionner

~# apt-cache policy php7.0
php7.0:
  Installé : 7.0.30-0+deb9u1
  Candidat : 7.0.30-0+deb9u1
 Table de version :
     7.0.32-1+0~20181001133631.6+stretch~1.gbpcd8588 100
        100 https://packages.sury.org/php stretch/main amd64 Packages
 *** 7.0.30-0+deb9u1 500
        500 https://deb.debian.org/debian stretch/main amd64 Packages
        500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
        100 /var/lib/dpkg/status
L'installation se fait via ce dépôt:

Code : Tout sélectionner

~# cat /etc/apt/sources.list.d/deb.sury.org.list
deb https://packages.sury.org/php/ stretch main
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

boubou81
Messages : 3
Inscription : 11 oct. 2018, 13:03
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#13 Messagepar boubou81 » 16 oct. 2018, 11:25

Bonjour,

Merci pour ces infos.

A partir de quelle version ISPConfig propose t'il d'installer plusieurs versions de PHP ? Je ne l'ai jamais constaté et j'ai pourtant fait une installation il y a seulement quelques semaines.
Faut-t'il choisir un mode d'installation particulier ?
Pour ma part j'avais continué à chercher pendant le week-end et j'étais tombé sur le dépôt de Sury, que j'ai configuré et j'ai installé les paquets PHP CGI et FPM 5.6, 7.1 et 7.2. Mais comme c'est tout manuel, je n'ai peut être pas fait ce que ferait l'installeur, et je me pose la question suivante:
Comment rendre le dépôt Sury moins prioritaire que le dépôt officiel Debian, de sorte que PHP 7.0 reste le paquet officiel Debian et non celui de Sury, car il a été mis à jour automatiquement ?

Merci d'avance....
Boubou81

Avatar de l’utilisateur
piratebab
Modérateur
Modérateur
Messages : 2546
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#14 Messagepar piratebab » 16 oct. 2018, 12:10

en faisant du pining sur les dépots.

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2762
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#15 Messagepar lol » 16 oct. 2018, 15:02

A partir de la dernière...
https://www.ispconfig.org/ispconfig/download/

Mais je viens de me rendre compte que ce n'est pas IspConfig qui installe php7 et php5... Mes confuses... désolé!
C'est le script d’installation automatique qui prépare l'installation...
https://www.howtoforge.com/tutorial/isp ... ll-script/

Code : Tout sélectionner

apt-get update && apt-get -y upgrade
apt-get install -y unzip
cd /tmp
wget --no-check-certificate -O installer.tgz "https://github.com/servisys/ispconfig_setup/tarball/master"
tar zxvf installer.tgz
cd *ispconfig*
bash install.sh

Et là, dans le processus, il te propose php5.6 en plus de php7...
Capture d’écran_2018-10-16_16-00-54.png
Vous ne pouvez pas consulter les pièces jointes insérées à ce message.
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

boubou81
Messages : 3
Inscription : 11 oct. 2018, 13:03
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#16 Messagepar boubou81 » 16 oct. 2018, 16:45

@lol
C'est le script d’installation automatique qui prépare l'installation...
Ah, je comprends mieux :icon_wink:

@piratebab:
en faisant du pining sur les dépots.
Merci, mais sans autre forme d'information c'est pas évident !
Comme je suis pas du genre à tout demander, j'ai commencé par chercher ce que voulait dire "pining", j'ai vite trouvé beaucoup d'informations liées à la gestion des dépôts sous Debian, mais après 3 heures de lecture, je sèche. Domaine fort complexe et pas toujours très détaillé sur la toile...

Mes dépôts sont ainsi configurés:

Code : Tout sélectionner

root:~# cat /etc/apt/sources.list
deb http://debian.mirrors.ovh.net/debian/ stretch main contrib non-free
deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb http://debian.mirrors.ovh.net/debian/ stretch-updates main contrib non-free

Code : Tout sélectionner

root:~# cat /etc/apt/sources.list.d/php.list 
deb https://packages.sury.org/php/ stretch main
Et je veux que tous les paquets viennent de la distribution officielle sur les miroirs OVH, sauf ceux qui n'y existent pas et qui sont disponibles dans le dépôt de SURY, c'est justement le cas de PHP 5.6, 7.1 et 7.2.
Si j'ai bien tout compris, les deux dépôts pointant vers la même distribution Stretch, il faut que je fasse la différence sur l'origine, mais là je ne m'en sorts pas.
Je dois écrire une règle dans /etc/apt/preferences.d/preferences/xxx pour prioriser un dépôt par rapport à l'autre avec une instruction du type

Code : Tout sélectionner

Pin: release o=Origin
, mais que mettre dans Origin ?

Encore merci pour votre aide préciseuse...

Avatar de l’utilisateur
piratebab
Modérateur
Modérateur
Messages : 2546
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Re: probleme ispconfig et double version PHP

#17 Messagepar piratebab » 17 oct. 2018, 12:06

Le pining consiste à donner des priorités sur les dépots via un fichier preferences. regarde dans notre wiki, on essaie d'avoir des infos à jour et synthétique sur ce type de sujet.


Revenir à « Support Debian »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 6 invités