apt update = libproxy1v5 : Est en conflit avec: libproxy1 Le sujet est résolu

Demande d'aide : c'est ici.
Message
Auteur
Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2441
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

apt update = libproxy1v5 : Est en conflit avec: libproxy1

#1 Messagepar lol » 06 déc. 2017, 07:20

Salut,
J'ai un problème avec apt-get update qui traîne sur une de mes machines (Unstable) depuis un moment et que je n'arrive pas à régler:

Code : Tout sélectionner

# apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libproxy1v5 : Est en conflit avec: libproxy1 mais 0.4.11-4+b2 devra être installé
E: Paquets défectueux

Code : Tout sélectionner

# apt-cache policy libproxy1v5
libproxy1v5:
  Installé : 0.4.14-3
  Candidat : 0.4.14-3
 Table de version :
 *** 0.4.14-3 500
        500 http://deb.debian.org/debian testing/main amd64 Packages
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     0.4.14-2 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages

Code : Tout sélectionner

# apt-cache policy libproxy1
libproxy1:
  Installé : (aucun)
  Candidat : 0.4.11-4+b2
 Table de version :
     0.4.11-4+b2 500
        500 http://deb.debian.org/debian jessie/main amd64 Packages
        100 /var/lib/dpkg/status

J'ai cherché les dépendances inverses de libproxy1 et libproxy1v5 et essayé de les supprimer mais en vain, ça casse tout...

Code : Tout sélectionner

# apt-cache showpkg libproxy1v5 |  sed -n '/Reverse Depends/,/Dependencies/p' |  sed '1d;$d' | cut -d, -f1 | sort -u |  xargs -n 50 dpkg --get-selections 2> /dev/null | grep '[[:space:]]install'
glib-networking:amd64				install
glib-networking-services			install
libqt5network5:amd64				install
libquvi-0.9-0.9.3:amd64				install

Code : Tout sélectionner

# apt-cache showpkg libproxy1 |  sed -n '/Reverse Depends/,/Dependencies/p' |  sed '1d;$d' | cut -d, -f1 | sort -u |  xargs -n 50 dpkg --get-selections 2> /dev/null | grep '[[:space:]]install'
glib-networking:amd64				install
glib-networking-services			install
libproxy1v5:amd64				install

Si j'ai bien compris libproxy1v5 remplace libproxy1, mais je ne comprend pas pourquoi il veut à tout prix installer libproxy1...

A part ces quelques paquets mon système est à jour:

Code : Tout sélectionner

# apt list --upgradable
En train de lister... Fait
gimp-gutenprint/testing,unstable 5.2.13-1 amd64 [upgradable from: 5.2.11-1+b2]
libgutenprint2/testing,unstable 5.2.13-1 amd64 [upgradable from: 5.2.11-1+b2]
libgutenprintui2-1/testing,unstable 5.2.13-1 amd64 [upgradable from: 5.2.11-1+b2]
libowncloudsync0/unknown 2.3.4-8626 amd64 [upgradable from: 2.3.3+dfsg-2]
printer-driver-cups-pdf/testing,unstable 3.0.1-4 amd64 [upgradable from: 2.6.1-22]
printer-driver-gutenprint/testing,unstable 5.2.13-1 amd64 [upgradable from: 5.2.11-1+b2]

Et aptitude ne moufte pas:

Code : Tout sélectionner

# aptitude upgrade
Résolution des dépendances…                             
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 7 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.

Des idées pour me sortir de ce cul de sac ?


Edit: Les paquets épinglés:

Code : Tout sélectionner

# apt-cache policy | sed -n -e '/Paquets\ épinglés/,$p'
Paquets épinglés :
     akonadi-server -> 4:17.08.0-1+b1 with priority -30000
     akonadi-server -> 4:16.04.3-6+b1 with priority -30000
     akonadi-server -> 4:16.04.3-4 with priority -30000
     akonadi-server -> 1.13.0-2+deb8u2 with priority -30000
     mdadm -> 4.0-2 with priority -30000
     mdadm -> 3.4-4+b1 with priority -30000
     mdadm -> 3.3.2-5+deb8u2 with priority -30000
     conky-all -> 1.9.0-6 with priority 1001
     conky -> 1.9.0-6 with priority 1001
     libmyodbc -> 5.1.10-3 with priority -30000
     tex-gyre -> 20160520-1 with priority -30000
     tex-gyre -> 20140520-1 with priority -30000
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

Avatar de l’utilisateur
wetaskiwin
Membre actif
Membre actif
Messages : 863
Inscription : 23 avr. 2016, 19:06
Localisation : Île de France
Status : Hors-ligne

Re: apt update = libproxy1v5 : Est en conflit avec: libproxy1

#2 Messagepar wetaskiwin » 06 déc. 2017, 08:21

lol a écrit :
06 déc. 2017, 07:20
Salut,

Et aptitude ne moufte pas:

Code : Tout sélectionner

# aptitude upgrade
Résolution des dépendances…                             
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 7 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.

Des idées pour me sortir de ce cul de sac ?

Salut,

Une première (idée), à part la patience d'attendre encore et encore : as-tu essayé aptitude -s full-upgrade ?

Et puis libproxy est aux abonnés absents :

Code : Tout sélectionner

$ apt-cache policy libproxy1
libproxy1:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :

Code : Tout sélectionner

$ apt-cache policy libproxy1v5
libproxy1v5:
  Installé : 0.4.14-3
  Candidat : 0.4.14-3
 Table de version :
 *** 0.4.14-3 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        500 http://ftp.fr.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
     0.4.14-2 500
        500 http://ftp.fr.debian.org/debian stable/main amd64 Packages
On cède d’abord sur les mots et puis, peu à peu, aussi sur les choses (Sigmund Freud - Psychologie des foules et analyse du moi)

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2441
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: apt update = libproxy1v5 : Est en conflit avec: libproxy1

#3 Messagepar lol » 06 déc. 2017, 11:18

Salut,
Merci pour la piste, mais ça ne règle rien, aptitude est aussi ballot qu'apt sur ce coup.

Code : Tout sélectionner

# aptitude -s full-upgrade
Les NOUVEAUX paquets suivants vont être installés :     
  libproxy1{a} ocqt562-libqt5concurrent5{a} ocqt562-libqt5core5a{a} ocqt562-libqt5dbus5{a} ocqt562-libqt5gui5{a} 
  ocqt562-libqt5keychain1{a} ocqt562-libqt5network5{a} ocqt562-libqt5widgets5{a} 
Les paquets suivants seront mis à jour : 
  gimp-gutenprint guile-2.0-libs libgutenprint2 libgutenprintui2-1 libowncloudsync0 printer-driver-cups-pdf 
  printer-driver-gutenprint 
7 paquets mis à jour, 8 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de télécharger 9 877 ko/12,1 Mo d'archives. Après dépaquetage, 26,0 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 cups-pdf : Dépend: printer-driver-cups-pdf (= 2.6.1-22) but 3.0.1-4 is to be installed
 libproxy1v5 : Est en conflit avec: libproxy1 but 0.4.11-4+b2 is to be installed
 ijsgutenprint : Dépend: libgutenprint2 (= 5.2.11-1+b2) but 5.2.13-1 is to be installed
Les actions suivantes permettront de résoudre ces dépendances :

      Conserver les paquets suivants dans leur version actuelle :
1)      gimp-gutenprint [5.2.11-1+b2 (<NULL>, now)]              
2)      libgutenprint2 [5.2.11-1+b2 (<NULL>, now)]               
3)      libgutenprintui2-1 [5.2.11-1+b2 (<NULL>, now)]           
4)      libowncloudsync0 [2.3.3+dfsg-2 (now, testing, unstable)] 
5)      libproxy1 [Non installé]                                 
6)      ocqt562-libqt5gui5 [Non installé]                        
7)      ocqt562-libqt5network5 [Non installé]                    
8)      ocqt562-libqt5widgets5 [Non installé]                    
9)      printer-driver-cups-pdf [2.6.1-22 (<NULL>, now)]         
10)     printer-driver-gutenprint [5.2.11-1+b2 (<NULL>, now)]    



Accepter cette solution ? [Y/n/q/?] 

Choisir "n" 10 fois ne change rien, je me retrouve avec ce genre de truc, en boucle:

Code : Tout sélectionner

      Conserver les paquets suivants dans leur version actuelle :
4)      libgutenprint2 [5.2.11-1+b2 (<NULL>, now)]               
5)      libproxy1 [Non installé]                                 
6)      ocqt562-libqt5gui5 [Non installé]                        
7)      ocqt562-libqt5network5 [Non installé]                    
8)      ocqt562-libqt5widgets5 [Non installé]                    
9)      printer-driver-cups-pdf [2.6.1-22 (<NULL>, now)]         
10)     printer-driver-gutenprint [5.2.11-1+b2 (<NULL>, now)]

Code : Tout sélectionner

      Leave the following dependencies unresolved:               
11)     printer-driver-all recommande printer-driver-gutenprint  
12)     cups recommande printer-driver-gutenprint

Et le --full-resolver n'est pas plus malin...

Code : Tout sélectionner

# aptitude -s full-upgrade --full-resolver
Les NOUVEAUX paquets suivants vont être installés :     
  libproxy1{a} ocqt562-libqt5concurrent5{a} ocqt562-libqt5core5a{a} ocqt562-libqt5dbus5{a} ocqt562-libqt5gui5{a} 
  ocqt562-libqt5keychain1{a} ocqt562-libqt5network5{a} ocqt562-libqt5widgets5{a} 
Les paquets suivants seront mis à jour : 
  gimp-gutenprint guile-2.0-libs libgutenprint2 libgutenprintui2-1 libowncloudsync0 printer-driver-cups-pdf 
  printer-driver-gutenprint 
7 paquets mis à jour, 8 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de télécharger 9 877 ko/12,1 Mo d'archives. Après dépaquetage, 26,0 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 cups-pdf : Dépend: printer-driver-cups-pdf (= 2.6.1-22) but 3.0.1-4 is to be installed
 libproxy1v5 : Est en conflit avec: libproxy1 but 0.4.11-4+b2 is to be installed
 ijsgutenprint : Dépend: libgutenprint2 (= 5.2.11-1+b2) but 5.2.13-1 is to be installed
Les actions suivantes permettront de résoudre ces dépendances :

      Conserver les paquets suivants dans leur version actuelle :
1)      gimp-gutenprint [5.2.11-1+b2 (<NULL>, now)]              
2)      libgutenprint2 [5.2.11-1+b2 (<NULL>, now)]               
3)      libgutenprintui2-1 [5.2.11-1+b2 (<NULL>, now)]           
4)      libowncloudsync0 [2.3.3+dfsg-2 (now, testing, unstable)] 
5)      libproxy1 [Non installé]                                 
6)      ocqt562-libqt5gui5 [Non installé]                        
7)      ocqt562-libqt5network5 [Non installé]                    
8)      ocqt562-libqt5widgets5 [Non installé]                    
9)      printer-driver-cups-pdf [2.6.1-22 (<NULL>, now)]         
10)     printer-driver-gutenprint [5.2.11-1+b2 (<NULL>, now)]

:003:


Je crois que je vais commencer pas faire le grand ménage dans les cups/gutemprint et autres printer-driver, j'y verrais plus clair après je suppose.
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

Avatar de l’utilisateur
wetaskiwin
Membre actif
Membre actif
Messages : 863
Inscription : 23 avr. 2016, 19:06
Localisation : Île de France
Status : Hors-ligne

Re: apt update = libproxy1v5 : Est en conflit avec: libproxy1

#4 Messagepar wetaskiwin » 06 déc. 2017, 12:25

Pour le seul problème de libproxy1, est-ce qu'il ne faudrait pas bloquer son installation ? Ce paquet n'a plus de version au delà de Jessie (dépôts absents de mon sources-list) et la version sid n'est que pour l'architecture arm64 :
https://packages.debian.org/search?keywords=libproxy1
On cède d’abord sur les mots et puis, peu à peu, aussi sur les choses (Sigmund Freud - Psychologie des foules et analyse du moi)

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2441
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: apt update = libproxy1v5 : Est en conflit avec: libproxy1  Le sujet est résolu

#5 Messagepar lol » 06 déc. 2017, 15:37

Hello,

J'ai fait un peu de ménage et surtout supprimé jessie dans mon sources.list, et... plus d'erreur.
Je n'ai pas trop compris la source du problème, mais j'ai une machine sur laquelle j'avais pas mal bidouillé, en supprimant 2/3 sources.list inutiles et Jessie, tout va bien...

Moralité, toujours avoir un fichier sources.list propre!

Merci d'avoir regardé mon soucis.
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

Avatar de l’utilisateur
wetaskiwin
Membre actif
Membre actif
Messages : 863
Inscription : 23 avr. 2016, 19:06
Localisation : Île de France
Status : Hors-ligne

Re: apt update = libproxy1v5 : Est en conflit avec: libproxy1

#6 Messagepar wetaskiwin » 06 déc. 2017, 18:19

Dans mon sources-list, j'ai préféré indiquer stable et testing, au lieu du p'tit nom de chaque branche. Pour gérer une sid, ce n'est sans doute pas essentiel mais ça m'évite d'oublier de le modifier à la sortie d'une nouvelle stable.

Et puis j'suis contente d'avoir apporté un p'tit caillou moins musical que d'habitude. :icon_biggrin:
On cède d’abord sur les mots et puis, peu à peu, aussi sur les choses (Sigmund Freud - Psychologie des foules et analyse du moi)

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2441
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: apt update = libproxy1v5 : Est en conflit avec: libproxy1

#7 Messagepar lol » 07 déc. 2017, 05:48

Hello,
Y'a pas de petit ou gros caillou, juste des caillous... :icon_wink:
Je me suis fait prendre avec un sources.list bancale (comme un débutant...), sans toi je cherchais encore!
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

Avatar de l’utilisateur
wetaskiwin
Membre actif
Membre actif
Messages : 863
Inscription : 23 avr. 2016, 19:06
Localisation : Île de France
Status : Hors-ligne

Re: apt update = libproxy1v5 : Est en conflit avec: libproxy1

#8 Messagepar wetaskiwin » 07 déc. 2017, 10:31

Salut,

An non ! Le gros caillou, je le garde pour le jeter sur mon ordinateur, les jours où il me fait une blague. :icon_biggrin: :066: :icon_biggrin:
On cède d’abord sur les mots et puis, peu à peu, aussi sur les choses (Sigmund Freud - Psychologie des foules et analyse du moi)


Revenir à « Support Debian »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité