Erreur "AH01797"

Demande d'aide : c'est ici.
Message
Auteur
yonamoke
Messages : 9
Inscription : 05 août 2017, 21:56
Status : Hors-ligne

Erreur "AH01797"

#1 Messagepar yonamoke » 05 août 2017, 22:05

Bonjour,

Je viens d'installer debian8. J'ai gardé la même config, avec Fail2Ban notamment. C'est un site DRUPAL 8.

Mais depuis, je n'arrête pas d'avoir ces messages en nombre important; par exemple :

- apache-multiport: banned 82.124.133.14 from [Mon serveur]
The IP 82.124.133.14 has just been banned by Fail2Ban after 8 attempts against apache-multiport.
Lines containing IP:82.124.133.14 in /var/log/apache*/*error.log

[Sat Aug 05 20:16:25.072914 2017] [access_compat:error] [pid 31505] [client 82.124.133.14:49417] AH01797: client denied by server configuration: /var/www/apple-touch-icon-precomposed.png
[Sat Aug 05 20:16:25.217709 2017] [access_compat:error] [pid 31505] [client 82.124.133.14:49417] AH01797: client denied by server configuration: /var/www/apple-touch-icon.png
[Sat Aug 05 20:16:25.365550 2017] [access_compat:error] [pid 31505] [client 82.124.133.14:49417] AH01797: client denied by server configuration: /var/www/system
[Sat Aug 05 20:16:25.510550 2017] [access_compat:error] [pid 31505] [client 82.124.133.14:49417] AH01797: client denied by server configuration: /var/www/favicon.ico
[Sat Aug 05 20:16:25.657943 2017] [access_compat:error] [pid 31505] [client 82.124.133.14:49417] AH01797: client denied by server configuration: /var/www/apple-touch-icon-precomposed.png
[Sat Aug 05 20:16:25.806388 2017] [access_compat:error] [pid 31505] [client 82.124.133.14:49417] AH01797: client denied by server configuration: /var/www/apple-touch-icon.png
[Sat Aug 05 20:16:25.949427 2017] [access_compat:error] [pid 31505] [client 82.124.133.14:49417] AH01797: client denied by server configuration: /var/www/system
[Sat Aug 05 20:16:26.098396 2017] [access_compat:error] [pid 31505] [client 82.124.133.14:49417] AH01797: client denied by server configuration: /var/www/favicon.ico

Dans mon .htaccess, j'ai :
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !=/favicon.ico
RewriteRule ^ index.php [L]

et dans mon apache j'ai bien autorisé l'accès à mon répertoire :

<Directory /var/www/>
Options -Indexes -FollowSymLinks -MultiViews -Includes -ExecCGI +IncludesNOEXEC
AllowOverride All
Require all granted
</Directory>

> J'ai mis dans www le favicon.ico au cas où mais rien ne change.
AVEZ VOUS UNE IDEE de ce qu'il faut faire ?

Cordialement
yonamoke

Avatar de l’utilisateur
Grhim
Membre actif
Membre actif
Messages : 602
Inscription : 30 mai 2016, 01:00
Localisation : Terra
Status : Hors-ligne

Re: Erreur "AH01797"

#2 Messagepar Grhim » 06 août 2017, 12:37

exemple :

Code : Tout sélectionner

<Directory /var/www/>
        Options Indexes FollowSymLinks Multiviews
        AllowOverride All
        <RequireAll>
        Require all granted
        Require not ip 188.40 46.4 176.9 46.166 46.21 78.46 91.207.7.21 0.0.0.0 91.207.7.182
        </RequireAll>
</Directory> 
https://www.apachelounge.com/viewtopic.php?p=28631
-- D3b1@n S1d -.- E17/KDE5 -- -- https://wiki.debian-fr.xyz/ -

yonamoke
Messages : 9
Inscription : 05 août 2017, 21:56
Status : Hors-ligne

Re: Erreur "AH01797"

#3 Messagepar yonamoke » 06 août 2017, 13:07

Bonjour,

merci mais il me semble que ma déclaration soit dans les règles :
Je n'ai pas envie néanmoins de l'index, du suivi de lien et multiviews d'ou ma déclaration
<Directory /var/www/>
Options -Indexes -FollowSymLinks -MultiViews -Includes -ExecCGI +IncludesNOEXEC
AllowOverride All
Require all granted
</Directory>

qu'est ce qui ne va pas ?
merci

Avatar de l’utilisateur
Grhim
Membre actif
Membre actif
Messages : 602
Inscription : 30 mai 2016, 01:00
Localisation : Terra
Status : Hors-ligne

Re: Erreur "AH01797"

#4 Messagepar Grhim » 06 août 2017, 13:17

-- D3b1@n S1d -.- E17/KDE5 -- -- https://wiki.debian-fr.xyz/ -

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 1918
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: Erreur "AH01797"

#5 Messagepar lol » 06 août 2017, 16:20

Salut,
yonamoke a écrit :
05 août 2017, 22:05
Je viens d'installer debian8. J'ai gardé la même config, avec Fail2Ban notamment. C'est un site DRUPAL 8.

Pourquoi old stable alors que Debian9 est dans les racks depuis des semaines ?
Tu parles de quelle config exactement ??? Des configs de Jessie, Wheezy ? Apache, Fail2ban ?
Quelles sont les version de Apache2 (Je suppose qu'on parle d'apache), Fail2ban ?
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).

yonamoke
Messages : 9
Inscription : 05 août 2017, 21:56
Status : Hors-ligne

Re: Erreur "AH01797"

#6 Messagepar yonamoke » 06 août 2017, 20:03

Pour moi ca a l'air ok ce que j'ai fait par rapport à cette doc que j'avais déjà bien parcourue.
Des idées ?
yonamoke

yonamoke
Messages : 9
Inscription : 05 août 2017, 21:56
Status : Hors-ligne

Re: Erreur "AH01797"

#7 Messagepar yonamoke » 06 août 2017, 20:05

lol, j'ai bien précisé en entête debian8, drupal 7 (faute j'avais mis drupal8), et bien fail2ban.
Pour apache, c'est bien 2.4.

le pourquoi ?
Simple, le contexte. Site drupal 7 existant, à refaire en 8 très prochainement.
Lui le futur sera développé en debian 9, et drupal 8.
L'existant sur drupal 7, c'est une obligation pour la maintenance.

yonamoke

Avatar de l’utilisateur
Grhim
Membre actif
Membre actif
Messages : 602
Inscription : 30 mai 2016, 01:00
Localisation : Terra
Status : Hors-ligne

Re: Erreur "AH01797"

#8 Messagepar Grhim » 07 août 2017, 17:02

possible d'avoir toute ta configuration d'Apache ? car l'erreur n'est pas dans les fichiers que tu nous a donné
-- D3b1@n S1d -.- E17/KDE5 -- -- https://wiki.debian-fr.xyz/ -

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 1918
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: Erreur "AH01797"

#9 Messagepar lol » 09 août 2017, 19:48

Hello,

A moins que la conf d'apache vienne d'un Apache 2.2 ???
Il y a eu des changements entre 2.2 et 2.4.
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).

yonamoke
Messages : 9
Inscription : 05 août 2017, 21:56
Status : Hors-ligne

Re: Erreur "AH01797"

#10 Messagepar yonamoke » 10 août 2017, 12:08

hello,

désolé de ma réponse tardive, mais j'ai été en déplacement.
Voici la config :
(j'ai remplacé mon site par xxx.fr et my_ip par mon IP)

<VirtualHost *:443>
DocumentRoot /var/www
ServerAdmin xxx@gmail.com
ServerName www.xxx.fr
ServerAlias xxx.fr

<Directory />
Options None
AllowOverride None
Require all denied
Allow from my_ip
</Directory>

<Directory /var/www/>
Options -Indexes -FollowSymLinks -Multiviews
AllowOverride All
<RequireAll>
Require all granted
</RequireAll>
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Require all granted
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel error
ServerSignature Off
CustomLog ${APACHE_LOG_DIR}/ssl_access.log combined

# SSL Engine Switch:
# Enable/Disable SSL for this virtual host.
SSLEngine on
[... My config ssl qui marche avec debian7]

</VirtualHost>

voilà.
yonnel

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 1918
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: Erreur "AH01797"

#11 Messagepar lol » 12 août 2017, 12:06

Salut,
Commence par virer ou commenter tous les Require all denied

Il y a une incohérence entre:

DocumentRoot /var/www

<Directory />
Require all denied


et

<Directory /var/www/>
<RequireAll>
Require all granted
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).

yonamoke
Messages : 9
Inscription : 05 août 2017, 21:56
Status : Hors-ligne

Re: Erreur "AH01797"

#12 Messagepar yonamoke » 12 août 2017, 23:12

Hello,

Je ne comprend pas pourquoi ?

1/ <directory /> vise à protéger mon serveur, hors mon site web (sauf moi)
==> denied
2/ <Directory /var/www/> vise à autoriser tout le monde l'aller su rmon serveur Web
==> DocumentRoot /var/www
==>all granted

pourquoi incohérence ?

merci
yo

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 1918
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: Erreur "AH01797"

#13 Messagepar lol » 13 août 2017, 15:33

Salut
yonamoke a écrit :
12 août 2017, 23:12
pourquoi incohérence ?

merci
yo

A partir du moment ou tu déclare /var/www comme document root, quand tu fais référence à "/" c'est équivalent à /var/www (le document root du vhost).
Ce n'est pas possible de remonter plus haut que le document root.
A quel dossier penses tu quand tu mets "/" ? /var ? /var/www ? / ?
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).

yonamoke
Messages : 9
Inscription : 05 août 2017, 21:56
Status : Hors-ligne

Re: Erreur "AH01797"

#14 Messagepar yonamoke » 13 août 2017, 15:57

bonjour lol,

quand je fais "/", je pense à mon répertoire principal du serveur : "/".
je pensais que je protégeais de tout accès ce qui est en dessous de /var/www !

Si je fais "<Directory /var/www/>", je met accès à mon web.
Et le reste, en dessous, de "/" et de "/var", dois-je le protéger ? Et comment ?

quand tu m'as interpellé dessus, je me suis rendu compte que je faisais sans doute une bêtise et ce que tu dis est évident.
Mais dans la protection d'un serveur VDS, dans ma déclaration "<VirtualHost ...", excepté la déclaration
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Require all granted
</Directory>

je dois faire autre chose que ma "<Directory /var/www/>" ?

merci pour ton aide
yo

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 1918
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: Erreur "AH01797"

#15 Messagepar lol » 13 août 2017, 16:16

Hello,

ça s'imbrique en cascade (Du plus près de la racine au plus loin)

Code : Tout sélectionner

<Directory /var/www/>
Tes consignes (Allow ou pas, etc)
</Directory>

  <VirtualHost IP:80>
  DocumentRoot /var/www/monsite

    <Directory /var/www/monsite>
    Tes consignes (Allow ou pas, etc)
    </Directory>

    Ici tes consignes cgi-bin ou fast-cgi

  </VirtualHost>
Regarde le fichiers default.conf d'apache:

Code : Tout sélectionner

<VirtualHost *:80>
...
DocumentRoot /var/www/html
...
</VirtualHost>
Le fait de fixer le DocumentRoot suffit: Impossible de remonter au dessus de /html
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).

yonamoke
Messages : 9
Inscription : 05 août 2017, 21:56
Status : Hors-ligne

Re: Erreur "AH01797"

#16 Messagepar yonamoke » 13 août 2017, 16:37

ok, je n'avais pas compris cela.
Quand tu dis "Le fait de fixer le DocumentRoot suffit: Impossible de remonter au dessus de /html", tu veux dire en dessous je pense ?

yo

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 1918
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: Erreur "AH01797"

#17 Messagepar lol » 13 août 2017, 16:38

Oui, pardon. En dessous... ;-)
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).

yonamoke
Messages : 9
Inscription : 05 août 2017, 21:56
Status : Hors-ligne

Re: Erreur "AH01797"

#18 Messagepar yonamoke » 13 août 2017, 16:44

merci pour ton aide.
a bientôt

yo


Revenir vers « Support Debian »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités