LibreOffice la dernière version

Partagez ici vos Trucs et vos Astuces.
Répondre
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

:006: :rolleyes: Si nous voulons la dernière version de Libre Office :
1. Télécharger depuis le site Web du fabricant (package principal + packages linguistiques) https://fr.libreoffice.org/download/tel ... breoffice/ :wacko:
paquets nommés : LibreOffice_7.2.2_Linux_x86-64_deb.tar.gz
et le package de langue LibreOffice_7.2.2_Linux_x86-64_deb_langpack_fr.tar.gz

2. Nous déballons les colis
3. Supprimez (désinstallez) l'ancienne version avec les commandes suivantes :

Code : Tout sélectionner

sudo apt-get remove --purge libreoffice*
sudo apt-get purge libreoffice-core
sudo apt autoclean
sudo apt autoremove
Remarque : la désinstallation via Symantic laisse beaucoup de déchets. La note dans la commande "--purge" ne doit pas être utilisée pour tout, car avec "--purge", j'ai désinstallé le bloc-notes Plum et il a planté autre chose jusqu'à ce que je doive réparer MATE
4. Via MC avec les privilèges root nous sommes dans le répertoire avec le package décompressé et nommé DEBS
... et la commande collée (en bas du MC se trouve la ligne de commande)

Code : Tout sélectionner

sudo dpkg -i *.deb
... nous faisons de même avec les packs de langues.
Des instructions d'installation et de désinstallation détaillées sont très utiles pour les utilisateurs novices, j'essaie donc toujours d'expliquer "pas à pas". " Réparez-le pour que tout fonctionne.
Des instructions inexactes posent de nombreux problèmes.
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

UFF !!! :wacko: :blush: assez pour aujourd'hui. Désolé, des excuses très fortes pour d'éventuelles erreurs, mais ce n'est pas moi .... c'est le traducteur google ??? !!
:drinks: :pleasantry: les commandes sont OK - identiques dans toutes les langues.
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
C2G9
Membre
Membre
Messages : 12
Enregistré le : 23 févr. 2020, 14:45
Status : Hors ligne

Salut
Tu peux avoir aussi la dernière version en activant les dépôts backports

Code : Tout sélectionner

$ apt list -a libreoffice
En train de lister... Fait
libreoffice/bullseye-backports,now 1:7.2.2-1~bpo11+1 amd64  [installé]
libreoffice/stable-security 1:7.0.4-4+deb11u1 amd64
libreoffice/stable 1:7.0.4-4 amd64
Et comme ça peut re mis mis à jour avec apt.
Debian Bullseyes XFCE4
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1493
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

C2G9 a écrit : 19 nov. 2021, 22:07 Tu peux avoir aussi la dernière version en activant les dépôts backports

:good:

C'est (je pense) une approche nettement plus académique.

L'installation hors Dépôts Debian ne devrait être envisagée qu'en dernier ressort.

Sinon ça sert à quoi que APT se décarcasse ? :033:
Debian stable - XFCE
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

:good: D'accord qu'il vaut mieux utiliser "apt" - mais je ne le savais pas, et merci beaucoup pour l'info. Question pour 10 points ??? Et avant d'ajouter des référentiels, désinstaller ce que j'ai installé avec ma méthode ? :wacko:
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

:006: Avec Google traducteur - ce n'est pas tout à fait vrai, mais dans un sens, car pour être "raisonnablement correct" du polonais vers le français - il faut connaître un peu la spécificité des langues et insérer le texte approprié. Je mets devant les verbes polonais (qui n'existe pas en polonais) MOI, VOUS, LUI, NOUS, VOUS (bien sûr il y a des mots, mais ils ne se mettent pas comme en français "je fais" - il n'y a pas de "je" et c'est aussi utile d'utiliser le programme VERBISTE :wacko: :shok:
verbiste
verbiste-gtk
au Synaptic, ou https://leconjugueur.lefigaro.fr/conjug ... uerir.html en réseau depuis le net ou sur Android :dirol:
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
C2G9
Membre
Membre
Messages : 12
Enregistré le : 23 févr. 2020, 14:45
Status : Hors ligne

lcoyote a écrit : 20 nov. 2021, 14:07 :good: D'accord qu'il vaut mieux utiliser "apt" - mais je ne le savais pas, et merci beaucoup pour l'info. Question pour 10 points ??? Et avant d'ajouter des référentiels, désinstaller ce que j'ai installé avec ma méthode ? :wacko:
Sans être catégorique à 100%, je pense qu'il est préférable de tout désinstaller afin de repartir avec une base "propre". Je crois me souvenir d'avoir essayer ta méthode et après celle des backports sans rien désinstaller et c'était pas terrible. Mais ma tête me fait défaut et je ne pourrais dire pourquoi ?
Debian Bullseyes XFCE4
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

Je vais laisser ce que j'avais pour l'instant, et ajouter un référentiel - car je veux vérifier l'orthographe de la franco-polonaise
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1493
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

lcoyote a écrit : 20 nov. 2021, 14:07 Et avant d'ajouter des référentiels, désinstaller ce que j'ai installé avec ma méthode ?

Une première précaution, qui devrait être une routine bien rodée

=> Si tu n'es pas sûr (je le suis rarement) :
  1. Fais une sauvegarde de ton système avant de le modifier.
  2. Si tu n'es vraiment pas sûr > Teste d'abord sur une machine virtuelle (VM) p.ex avec VirtualBox (version récente disponible en sid, j'ai expliqué récemment Comment installer "proprement" )
Normalement, pour les logiciels installés par simple décompression/copie des fichiers dans /opt ou dans /home/user/... la simple suppression des fichiers devrait suffire.

Les logiciels installés depuis un paquet avec : dpkg --install <paquet>.deb
devraient pouvoir être désinstallés avec : dpkg --remove <paquet>.deb

Là où ça peut être plus compliqué (je ne sais pas à quel point car je ne fais jamais cela)
  • logiciel installé par un script genre appli-installer.sh ne sachant pas ce que fait le script ????
  • logiciels installés depuis les sources avec les commandes make et install là encore pas facile de savoir ce qu'on fait ces commandes


Voilà je ne peux pas t'aider au-delà de cela.
Debian stable - XFCE
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1493
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

lcoyote a écrit : 20 nov. 2021, 14:26 Avec Google traducteur - ce n'est pas tout à fait vrai, .......

As-tu testé : https://www.deepl.com
Nie jestem w stanie sprawdzić, czy polska wersja tłumacza https://www.deepl.com jest sprawna i czy respektuje znaczenia zgodne z kontekstem.
Ale dla angielskiego i hiszpańskiego ten tłumacz działa całkiem dobrze, niektórzy mówią, że lepiej niż Google (przynajmniej dla angielskiego/francuskiego)


Traduction de :
Je ne peux pas tester si la version polonaise du traducteur https://www.deepl.com est efficace et si elle respecte bien les sens en fonction du contexte.
Mais pour l'anglais et l'espagnol ce traducteur fonctionne assez bien, certain disent qu'il fonctionne mieux que celui de Google (au moins pour l'anglais / français)
Debian stable - XFCE
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

Merci d'avoir fourni le lien. Une autre occasion de s'éloigner de l'oncle Google. Déjà dans Android 10 j'en ai tellement marre parce que le téléphone fait ce qu'il veut tout seul que j'ai dû changer la carte SIM pour un téléphone senior acheté spécialement. De tels cirques. Merci encore. :blush: :give_rose:
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

:006: Il existe de nombreux programmes 100% meilleurs que le korpo américain. Abby Fine Reader fabriqué à Saint-Pétersbourg, en Russie, pour reconnaître les textes scannés. La version 9.0 que je peux donner gratuitement (probablement plusieurs langues au choix) et qui n'est pas encore :yahoo: :rolleyes: enregistrée.
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

dezix a écrit : 20 nov. 2021, 16:03 Voilà je ne peux pas t'aider au-delà de cela.
:blush: Parfois, j'utilise l'option "téléphoner à un ami", un frère en Pologne, spécialiste en informatique industrielle. Tant qu'il a "de la gentillesse pour les animaux" et qu'il est prêt à répondre. Mais j'essaie généralement de chercher des informations sur Internet. Et je vérifie sur un tissu vivant (ordinateur portable), si tout échoue exceptionnellement - alors sous Windows 8.1 sur le même disque je formate Linux et à partir de l'USB (j'ai toujours deux Linux en réserve) - réinstallation. J'archive des documents tous les jours - pour ne rien perdre. :yahoo: :spiteful: :crazy:
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
frank
Membre
Membre
Messages : 22
Enregistré le : 28 févr. 2021, 21:56
Status : Hors ligne

s.v.p corrige ceci

1. pas des paquets rpm mais deb.
paquets nommés : LibreOffice_7.2.2_Linux_x86-64_rpm.tar.gz
et le package de langue LibreOffice_7.2.2_Linux_x86-64_rpm_langpack_fr.tar.gz

mais comme ceci;
paquets nommés : LibreOffice_7.2.2_Linux_x86-64_deb.tar.gz
et le package de langue LibreOffice_7.2.2_Linux_x86-64_deb_langpack_fr.tar.gz

3. cet commande suffit amplement.

Code : Tout sélectionner

# apt remove --purge libreoffice* lodevbasis*
dans remarque corrige -> Symantic pour synaptic

4.en console administrateur dans le répertoire de Téléchargements

Code : Tout sélectionner

# apt update
# cd /home/~/Téléchargements/LibreOffice_7.2.2.1_Linux_x86-64_deb/DEBS
# dpkg -i *.deb
# cd /home/~/Téléchargements/LibreOffice_7.2.2.1_Linux_x86-64_deb_langpack_fr/DEBS
# dpkg -i *.deb
ou comme cet vidéo https://www.youtube.com/watch?v=KN1W9DxJxlQ
debian oldstabe/stable/testing/unstable avec gnome
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

:006: Merci, corrigé (paquets DEB bien sûr) Je n'avais pas entendu parler de cette commande plus longue. Merci aussi. Je vais vérifier, car je suis curieux de tout ce qui concerne la console et les commandes. Les commandes de la console peuvent faire plus que SYMANTIC Mais c'est plus sûr grâce à Symantic. :good:
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
frank
Membre
Membre
Messages : 22
Enregistré le : 28 févr. 2021, 21:56
Status : Hors ligne

c'est quoi symantic ?
debian oldstabe/stable/testing/unstable avec gnome
Avatar du membre
lcoyote
Membre
Membre
Messages : 59
Enregistré le : 15 nov. 2021, 15:09
Localisation : Auvergne-Rhône-Alpes
Status : Hors ligne

Erreur d'orthographe (mal orthographié) - devrait être Synaptic Package Manager :wacko:
---------
Vérifiez vos yeux, activez votre réflexion jusqu'à ce qu'il soit trop tard et que ce soit toujours légal !
Debian 11 MATE
Répondre