[Aptitude] Savoir pourquoi un paquet peut ou ne peut pas etre installer

Partagez ici vos Trucs et vos Astuces.
Répondre
Avatar du membre
Grhim
Membre très actif
Membre très actif
Messages : 1075
Enregistré le : 30 mai 2016, 01:00
Localisation : Zurich
Status : Hors ligne

28 juil. 2017, 19:59

la commande cherche les paquets qui dépendent ou qui sont en conflit avec ce paquet

Code : Tout sélectionner

~$ aptitude why nautilus
i   kdm                     Recommande kde-workspace | x-session-manager | x-window-manager
p   gnome-session-flashback Fournit    x-session-manager                                   
p   gnome-session-flashback Dépend     nautilus (>= 3.8)   

il existe aussi aptitude why-not why-not cherche la chaîne de dépendances qui conduit au conflit avec le paquet ciblé
Debian Testing-Sid / Debian Stable / Kali Linux / LXDE sur Gnome3 - KissOs - Raspberry 3b+ -
Répondre