Qutebrowser un navigateur minimaliste !

Partagez ici vos Trucs et vos Astuces.
Message
Auteur
--gilles--
Membre
Membre
Messages : 229
Inscription : 24 août 2016, 19:35
Status : Hors-ligne

Qutebrowser un navigateur minimaliste !

#1 Messagepar --gilles-- » 02 oct. 2017, 15:30

Qutebrowser version 0.11.0-1 un navigateur minimaliste !
D'après une idée de Grhim
Source originale des informations :
https://www.qutebrowser.org/INSTALL.htm ... ian_ubuntu

Testé avec les bibliothèques sous-jacentes :
Backend: QtWebEngine (Chromium 49.0.2623.111)
CPython: 3.5.3
Qt: 5.7.1
PyQt: 5.7

sip: 4.18.1
colorama: no
pypeg2: 2.15
jinja2: 2.8
pygments: 2.2.0
yaml: 3.12
cssutils: no
typing: yes
OpenGL: 3.1.0
PyQt5.QtWebEngineWidgets: yes
PyQt5.QtWebKitWidgets: yes
pdf.js: 1.5.188 (/usr/share/javascript/pdf/build/pdf.js)
SSL: OpenSSL 1.0.2l 25 May 2017

Style: QFusionStyle
Platform: Linux-4.9.0-3-amd64-x86_64-with-debian-9.1, 64bit
Linux distribution: Debian GNU/Linux 9 (stretch) (debian)

Vous avez vécu des aventures passionnantes avec le Terminal, vous en voulez encore ? Vous allez pouvoir dépoussiérer votre Terminal avec Qutebrowser. Qutebrowser à partir d'un programmation en python réutilise beaucoup de code sous-jacent : Qt, QtWebengine PythonQt … Il est donc minimaliste, il utilise le minimum de code en propre pour arriver à son résultat. Il est aussi minimaliste dans l'approche interface homme-machine, ceux qui cherchent les personnalisations, les thèmes, les plugins et les extensions n'y trouveront pas leur compte. Par contre ceux qui aiment le droit au but aimeront tester ce nouveau navigateur.

Ouvrez votre Terminal, c'est parti !

1] L'installation
Au départ, installation des dépendances indispensables :
# apt-get install python3-lxml python-tox python3-pyqt5 python3-pyqt5.qtwebkit python3-pyqt5.qtquick python3-sip python3-jinja2 python3-pygments python3-yaml python3-pyqt5.qtsql libqt5sql5-sqlite python3-pyqt5.qtwebengine python3-pyqt5.qtopengl

Ensuite, les dépendances recommandés : # aptitude install python-jinja2-doc subversion python3-pytest ttf-bitstream-vera python3-opengl

Pour l'installation de qutebrowser_0.11.0-1_all.deb :

Code : Tout sélectionner

# wget https://github.com/qutebrowser/qutebrowser/releases/download/v0.11.0/qutebrowser_0.11.0-1_all.deb


Pour l'installation de python3-pypeg2_2.15.2-1:

Code : Tout sélectionner

# wget https://qutebrowser.org/python3-pypeg2_2.15.2-1_all.deb
Nous mettons les droits root à ces .deb :
# chgrp -LR root qutebrowser_0.11.0-1_all.deb
# chown -LR root qutebrowser_0.11.0-1_all.deb

# chgrp -LR root python3-pypeg2_2.15.2-1_all.deb
# chown -LR root python3-pypeg2_2.15.2-1_all.deb

Nous installons ces .deb :
# dpkg -i python3-pypeg2_*_all.deb
# dpkg -i qutebrowser_*_all.deb

C'est bon, vous pouvez déjà lancer Qutebrowser en ligne de commande avec l'option --backend webengine :
$ qutebrowser --backend webengine

Nous pouvons peaufiner avec les paquets suggérés :
# aptitude install libjs-pdf python3-colorlog







2] Le lanceur
Vous dites :« Non, mais là, Qutebrowser c'est bien, mais ils sont feignants ou extrêmes ces développeurs, ils n'ont pas mis de lanceur ! Je veux un lanceur pour mon projet ! »

« OK, OK, monsieur le responsable marketing, on reste cool ! »

L'icône de Qutebrowser :
Image

Vous la télécharger à partir d'ici : https://upload.wikimedia.org/wikipedia/ ... er.svg.png

Genre ~/Images $ wget https://upload.wikimedia.org/wikipedia/ ... er.svg.png

Le lanceur à mettre dans son ~/.local/share/applications : le fichier : qutebrowser.desktop

********** est à remplacer par votre nom d'utilisateur
[Desktop Entry]
Version=0.11.0-1
Encoding=UTF-8
Name=Navigateur Qutebrowser
GenericName=Navigateur Qutebrowser
Name[fr]=Navigateur Qutebrowser
GenericName[fr]=Navigateur Qutebrowser
Comment[fr]=Navigateur Qutebrowser
Exec=/usr/bin/qutebrowser --backend webengine
Icon=/home/**********/Images/Qutebrowser.svg.png
Terminal=false
Type=Application
Categories=Application;Network;WebBrowser;
Keywords=WebBrowser;Network;
Name[fr_FR.UTF-8]=Navigateur Qutebrowser



3] Les raccourcis clavier
Ils sont ici : http://qutebrowser.org/img/cheatsheet-big.png

Image

Réjouissez-vous ! :icon_biggrin:
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2441
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#2 Messagepar lol » 02 oct. 2017, 17:59

Super, merci!
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

Avatar de l’utilisateur
Grhim
Membre actif
Membre actif
Messages : 838
Inscription : 30 mai 2016, 01:00
Localisation : Terra
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#3 Messagepar Grhim » 02 oct. 2017, 19:52

super tuto !! rapide , très bien expliquer :023:
-- D3b1@n Testing-Unstable -.- Enlightenment / KDE5 - Librazik- Kali - kissballad.arpinux.org
gibt es den Chat-Raum für Hilfe.

--gilles--
Membre
Membre
Messages : 229
Inscription : 24 août 2016, 19:35
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#4 Messagepar --gilles-- » 04 oct. 2017, 18:57

La documentation en local de qutebrowser :

/usr/lib/python3/dist-packages/qutebrowser/html/doc/index.html ( mais certains liens ne fonctionnent pas )

Les exécutables : $ dpkg --search qutebrowser


Le principal développeur : https://github.com/The-Compiler
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell

--gilles--
Membre
Membre
Messages : 229
Inscription : 24 août 2016, 19:35
Status : Hors-ligne

Qutebrowser 0.11.0-1 un navigateur minimaliste !

#5 Messagepar --gilles-- » 07 oct. 2017, 12:49

Bon, les logiciels de cryptographie pour les certificats des sites https ont évolués après la sortie de Qt5.7.1 qui vient avec Debian 9, ce qui fait que ma version de qutebrowser 0.11.0-1-Qt5.7.1 n'est pas à jour. Au passage si vous voulez connaître les bibliothèques installées utilisées par Qutebrowser :
Faîtes comme si vous rapportiez un bug donc :report et ensuite vous ouvrez Show Log et les bibliothèques utilisées sont sous ==== Version info ==== et ensuite bien sûr : Don't report

À la lecture des bibliothèques installées et pas installées cela fait 2 bibliothèques à suggérer à rajouter : python3-colorama et python3-cssutils

# aptitude install python3-colorama python3-cssutils
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell

--gilles--
Membre
Membre
Messages : 229
Inscription : 24 août 2016, 19:35
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#6 Messagepar --gilles-- » 07 oct. 2017, 18:00

Vu que la version de Qt est importante pour différencier le comportement de Qutebrowser0.11.0-1, en effet Qutebrowser0.11.0-1 est à jour avec certaines versions de Qt, mais obsolète avec d'autres comme par exemple Qt5.7.1, je change le lanceur qutebrowser.desktop dans ~/.local/share/applications . J'atends d'ailleurs que Grhim nous confirme sa version de Qt avec laquelle Qutebrowser0.11.0-1 est à jour. Pour l'image de l'icône, voir le message qui traite déjà du lanceur plus haut.

[Desktop Entry]
Version=0.11.0-1
Encoding=UTF-8
Name=Navigateur Qutebrowser 0.11.0-1 bibliothèque Qt5.7.1
GenericName=Navigateur Qutebrowser 0.11.0-1 bibliothèque Qt5.7.1
Name[fr]=Navigateur Qutebrowser 0.11.0-1 bibliothèque Qt5.7.1
GenericName[fr]=Navigateur Qutebrowser 0.11.0-1 bibliothèque Qt5.7.1
Comment[fr]=Navigateur Qutebrowser 0.11.0-1 bibliothèque Qt5.7.1
Exec=/usr/bin/qutebrowser --backend webengine
Icon=/home/intervenant100/Images/Qutebrowser.svg.png
Terminal=false
Type=Application
Categories=Application;Network;WebBrowser;
Keywords=WebBrowser;Network;
Name[fr_FR.UTF-8]=Navigateur Qutebrowser 0.11.0-1 bibliothèque Qt5.7.1
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell

--gilles--
Membre
Membre
Messages : 229
Inscription : 24 août 2016, 19:35
Status : Hors-ligne

Nette amélioration de la stabilité de qutebrowser0.11.0-1 Qt5.7.1

#7 Messagepar --gilles-- » 09 oct. 2017, 09:54

Nette amélioration de la stabilité de qutebrowser0.11.0-1 Qt5.7.1 par la mise à jour Linux-4.9.0-3-amd64-x86_64-debian-9.1 vers Linux-4.9.0-4-amd64-x86_64-9.2 effectuée hier. Fin de l'avertissement Google : « Votre navigateur n'est pas à jour » ! À tester plus à fond avec youtube qui posait problème avec qutebrowser0.11.0-1 Qt5.7.1 Voir aussi l'influence de la changement de version de la libc.
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell

Avatar de l’utilisateur
Grhim
Membre actif
Membre actif
Messages : 838
Inscription : 30 mai 2016, 01:00
Localisation : Terra
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#8 Messagepar Grhim » 09 oct. 2017, 19:53

voila ce que j'ai en qutebrowser0.11.1-1 :
je fais la grosse mise a jour système demain , on verra ensuite

Code : Tout sélectionner

Error while initializing: QtWebEngine is not supported with Nouveau graphics (unless QT_XCB_FORCE_SOFTWARE_OPENGL is set as environment variable).
d'ailleurs , l'erreur adblock es la :icon_e_biggrin:
-- D3b1@n Testing-Unstable -.- Enlightenment / KDE5 - Librazik- Kali - kissballad.arpinux.org
gibt es den Chat-Raum für Hilfe.

Avatar de l’utilisateur
Grhim
Membre actif
Membre actif
Messages : 838
Inscription : 30 mai 2016, 01:00
Localisation : Terra
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#9 Messagepar Grhim » 09 oct. 2017, 20:08

bon etrange bizarrerrie ... si j'appelle qute via Konsole (kde5) j'ai droit a l'erreur , et si j'appelle qute par la barre de lancement plasma , il s'ouvre sans erreur ... :017: Image
-- D3b1@n Testing-Unstable -.- Enlightenment / KDE5 - Librazik- Kali - kissballad.arpinux.org
gibt es den Chat-Raum für Hilfe.

Avatar de l’utilisateur
Grhim
Membre actif
Membre actif
Messages : 838
Inscription : 30 mai 2016, 01:00
Localisation : Terra
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#10 Messagepar Grhim » 09 oct. 2017, 20:13

--gilles-- a écrit :
07 oct. 2017, 18:00
...que Grhim nous confirme sa version de Qt avec laquelle Qutebrowser0.11.0-1 est à jour.
je suis en 0-11-1 ..

Code : Tout sélectionner

Widg==== Timestamps ====
Launch: Mon Oct  9 20:02:26 2017
Crash: Mon Oct  9 20:09:53 2017

==== Version info ====
qutebrowser v0.11.1
Git commit: 
Backend: legacy QtWebKit (WebKit 538.1)

CPython: 3.5.4
Qt: 5.9.1
PyQt: 5.9

sip: 4.19.3
colorama: 0.3.7
pypeg2: 2.15
jinja2: 2.9.6
pygments: 2.2.0
yaml: 3.12
cssutils: 1.0.2 $Id$
typing: yes
PyQt5.QtWebEngineWidgets: yes
PyQt5.QtWebKitWidgets: yes
pdf.js: 1.5.188 (/usr/share/javascript/pdf/build/pdf.js)
SSL: OpenSSL 1.0.2l  25 May 2017

Style: Breeze::Style
Platform: Linux-4.12.0-1-amd64-x86_64-with-debian-jessie-sid, 64bit
Linux distribution: Debian 
Frozen: False
Imported from /usr/lib/python3/dist-packages/qutebrowser
Qt library executable path: /usr/lib/x86_64-linux-gnu/qt5/libexec, data path: /usr/share/qt5
-- D3b1@n Testing-Unstable -.- Enlightenment / KDE5 - Librazik- Kali - kissballad.arpinux.org
gibt es den Chat-Raum für Hilfe.

--gilles--
Membre
Membre
Messages : 229
Inscription : 24 août 2016, 19:35
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#11 Messagepar --gilles-- » 09 oct. 2017, 20:44

On verra cela demain après ta mise à jour.
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell

Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 2441
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#12 Messagepar lol » 10 oct. 2017, 08:32

Hello,
Ce n'est pas une émoticône agréée ça!
Grhim a écrit :
09 oct. 2017, 20:08
Image
:003: :icon_biggrin:
Debian SID. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Pas de support par message privé... Merci!

--gilles--
Membre
Membre
Messages : 229
Inscription : 24 août 2016, 19:35
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#13 Messagepar --gilles-- » 10 oct. 2017, 09:25

Grhim a écrit :
09 oct. 2017, 20:08
bon etrange bizarrerrie ... si j'appelle qute via Konsole (kde5) j'ai droit a l'erreur , et si j'appelle qute par la barre de lancement plasma , il s'ouvre sans erreur ... :017: Image
Il n'y a rien de bizarre si on creuse un peu plus, qutebrowser0.11.0-1 peut utiliser 2 bibliothèques de moteur de rendu :
  • QtWebKit
  • QtWebEngine

Source de l'information : Fin de la réponse à la troisième question de la FAQ de qutebrowser : https://qutebrowser.org/FAQ.html

Par défaut qutebrowser0.11.0-1 utilise QtWebKit, donc si tu lances $ qutebrowser tu utiliseras QtWebKit, ce que nous pouvons voir dans ton message ( #10) concernant les biblio installées, par contre dans les modèles de lanceur que tu as sans doute repris, il y a cette ligne : Exec=/usr/bin/qutebrowser --backend webengine, donc dans ce cas-ci tu utiliseras QtWebEngine !

QtWebKit est plus simpliste que QtWebEngine et Chromium, Google Chrome, QupZilla l'ont abandonné pour passer à QtWebEngine. qutebrowser pense aussi fortement l'abandonner, d'ailleurs si tu lis les docs, elles préconisent d'utiliser $ qutebrowser --backend webengine


  • Conclusion :
Que ce soit à partir indirectement d'un lanceur ou bien directement en console toujours qutebrowser --backend webengine

Je pense d'ailleurs qu'il faudra mettre ces infos explicatives dans le wiki dès que nous aurons le temps, regarde le dernier plan que j'ai écrit en bas de la discussion associée à la page du wiki concernant qutebrowser0.11.0-1 et les remarques de lol. :icon_e_biggrin:
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell

Avatar de l’utilisateur
Grhim
Membre actif
Membre actif
Messages : 838
Inscription : 30 mai 2016, 01:00
Localisation : Terra
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#14 Messagepar Grhim » 10 oct. 2017, 16:47

lol a écrit :
10 oct. 2017, 08:32
Hello,
Ce n'est pas une émoticône agréée ça!
Grhim a écrit :
09 oct. 2017, 20:08
Image
:003: :icon_biggrin:
mais tres sympa :icon_e_biggrin:
-- D3b1@n Testing-Unstable -.- Enlightenment / KDE5 - Librazik- Kali - kissballad.arpinux.org
gibt es den Chat-Raum für Hilfe.

Avatar de l’utilisateur
Grhim
Membre actif
Membre actif
Messages : 838
Inscription : 30 mai 2016, 01:00
Localisation : Terra
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#15 Messagepar Grhim » 11 oct. 2017, 00:07

--gilles-- a écrit :
10 oct. 2017, 09:25

Il n'y a rien de bizarre si on creuse un peu plus, qutebrowser0.11.0-1 peut utiliser 2 bibliothèques de moteur de rendu :
  • QtWebKit
  • QtWebEngine

c'est vrais , c'est vrais, arf , !! j'ai rien dit :icon_mrgreen:
-- D3b1@n Testing-Unstable -.- Enlightenment / KDE5 - Librazik- Kali - kissballad.arpinux.org
gibt es den Chat-Raum für Hilfe.

--gilles--
Membre
Membre
Messages : 229
Inscription : 24 août 2016, 19:35
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#16 Messagepar --gilles-- » 17 oct. 2017, 17:05

La fenêtre de démarrage de qutebrowser0.11.0-1:


Image
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell

Avatar de l’utilisateur
Grhim
Membre actif
Membre actif
Messages : 838
Inscription : 30 mai 2016, 01:00
Localisation : Terra
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#17 Messagepar Grhim » 06 déc. 2017, 20:32

je viens de découvrir que c'etait officielle dans les depots debian .....

Code : Tout sélectionner

~$ acp qutebrowser
qutebrowser:
  Installed: 1.0.4-2
  Candidate: 1.0.4-2
  Version table:
 *** 1.0.4-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.4-1 500
        500 http://httpredir.debian.org/debian testing/main amd64 Packages

~$ aptitude search qutebrowser
i   qutebrowser                                                                                                                                           - Keyboard-driven, vim-like browser based on PyQt5                 
-- D3b1@n Testing-Unstable -.- Enlightenment / KDE5 - Librazik- Kali - kissballad.arpinux.org
gibt es den Chat-Raum für Hilfe.

--gilles--
Membre
Membre
Messages : 229
Inscription : 24 août 2016, 19:35
Status : Hors-ligne

Qutebrowser dans les dépôts !

#18 Messagepar --gilles-- » 07 déc. 2017, 08:56

Oui Grhim, mais seulement à partir de buster et au delà voir : https://packages.debian.org/search?suit ... utebrowser

$ apt-cache policy qutebrowser
qutebrowser:
Installé : 1.0.4-1
Candidat : 1.0.4-1
Table de version :
*** 1.0.4-1 500
500 http://ftp.fr.debian.org/debian buster/main amd64 Packages
100 /var/lib/dpkg/status


De toute façon avec Deb9, qutebrowser n'était pas à 100 % stable avec certains sites, alors qu'il l'est si on utilise buster future Deb10.
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell

network-king
Membre
Membre
Messages : 158
Inscription : 09 nov. 2017, 11:23
Status : Hors-ligne

Re: Qutebrowser un navigateur minimaliste !

#19 Messagepar network-king » 07 déc. 2017, 16:13

Merci pour ce tuto.

Par contre je voudrais quelques stats comme par exemple la charge sur la ram,le temps de lancement avant que je l'installe car j'utilise, outre FF, Midori.

Merci encore

--gilles--
Membre
Membre
Messages : 229
Inscription : 24 août 2016, 19:35
Status : Hors-ligne

Qutebrowser

#20 Messagepar --gilles-- » 07 déc. 2017, 20:50

network-king a écrit :
07 déc. 2017, 16:13
Merci pour ce tuto.

Par contre je voudrais quelques stats comme par exemple la charge sur la ram,le temps de lancement avant que je l'installe car j'utilise, outre FF, Midori.

Merci encore
Comme les données que tu demandes dépendent des machines de chacun et des sites que chacun est susceptible de visiter et qu'en plus nous ignorons ta version de Debian, il serait plus judicieux que tu installes pour tester. Mais comme tu déclares utiliser encore midori :
https://packages.debian.org/search?keyw ... lla-search

donc si je tiens compte de ta déclaration et si tu n'es pas un pro de la compilation, tu ne peux utiliser que soit wheezy ou jessie-backports ou stretch. Dans ton cas, seul stretch permet d'utiliser qutebrowser.

https://www.qutebrowser.org/doc/install ... mint_lt_18



Ton cas mis à part, ce que je peux dire, après deux tests rapides et peut-être non-significatifs, c'est que Qutebrowser consomme généralement plus de CPU que Firefox et moins de RAM que Firefox à sites visités identiques. Mais cela demanderait à être confirmé.
Parler de liberté n'a de sens qu'à condition que ce soit la liberté de dire aux gens ce qu'ils n'ont pas envie d'entendre. Eric Blair, George Orwell


Revenir à « Trucs et astuces »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité