[RELEASE] DEBIAN 11 — BULLSEYE est la nouvelle version stable

On y discute de tout, ou presque...
Répondre
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1491
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

Bonjour, :006:

Depuis hier (2021-08-14) Debian a changé de version stable.

Debian — Informations sur la version « Bullseye » de Debian

Nos camarades de debian-fr.org ont déjà bien commencé à partager leurs retours.


Pour ma part, je ne suis pas vraiment concerné vu que je tourne principalement en testing,
et je n'ai qu'un avertissement pour les utilisateurs de XFCE
il va y avoir un changement de version pour la 4.16
(Je ne suis pas certain si Buster était resté à 4.14)
Buster est resté à 4.12

Voilà, restez prudents et faites vos sauvegardes avant .... :059:


@+ :banana_parachute:
Debian stable - XFCE
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1491
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

Pour rappel, j'avais déjà mis dans les Trucs et Astuces: XFCE 4.16 : Continuer à utiliser le calendrier ORAGE
Debian stable - XFCE
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1491
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

Au niveau du sources.list,
il y a normalement un peu de changement :

les mises à jour de sécurité doivent maintenant correspondre à une ligne
comme indiqué dans : Changement de l’organisation de l’archive security


Votre nouveau /etc/apt/sources.list pourrait ressembler à :

Code : Tout sélectionner

deb [arch=amd64] https://deb.debian.org/debian/ bullseye main non-free contrib

deb [arch=amd64] https://deb.debian.org/debian-security bullseye-security main contrib non-free

deb [arch=amd64] https://deb.debian.org/debian/ bullseye-updates main contrib non-free

deb [arch=amd64] https://deb.debian.org/debian/ bullseye-backports main contrib non-free 

et ça fonctionne, la preuve :

Code : Tout sélectionner

# apt update
Atteint :1 https://deb.debian.org/debian bullseye InRelease
Réception de :2 https://deb.debian.org/debian-security bullseye-security InRelease [44,1 kB]
Atteint :3 https://deb.debian.org/debian bullseye-updates InRelease
Atteint :4 https://deb.debian.org/debian bullseye-backports InRelease
Atteint :5 https://deb.debian.org/debian sid InRelease
44,1 ko réceptionnés en 2s (19,9 ko/s)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Tous les paquets sont à jour.

Note : en "5" j'ai une ligne pour sid car j'ai aussi un fichier /etc/apt/sources.list.d/sid.list pour ce qui manque dans bullseye => virtualbox

Le dépôt est visible là : https://deb.debian.org/


J'espère que cela vous aidera, ce n'est bien sûre qu'un exemple
Debian stable - XFCE
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1491
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

LXQt

Avertissement à prendre avec circonspection car provient d'une VM Viirtualbox

J'avais une VM avec une installation minimum depuis Netinstal avec en tasksel :
  • Bureau Debian
  • LXQt
  • Outils Systèmes
Je l'ai mise à jour sous Buster avec un # apt dist-upgrade
puis,
modification du sources.list comme indiqué plus haut
suivi par :
# apt update
# apt dist-upgrade
# reboot


[ÉDITÉ]

Je ne suis pas 100% certain, mais je préfère avoir redémarré avec succès avant :
# apt autoremove
# apt autoclean

[\ÉDITÉ]


À partir de là, le Bureau n'a plus de fond, ni d'icons,
toute la section Préférences du Menu principal ne fonctionne plus donc plus d'accès graphique aux réglages,
ni à l'écran de déconnexion/arrêt.

Les autres applications du menu fonctionnent mais sans cadres de fenêtres.

Je n'ai pas le temps de rechercher d'où cela peut provenir,
le coupable devrait être Qt
ou Virtualbox (additions) au quel cas ce serait une fausse alerte de ma part.

Vous êtes avertis.
Debian stable - XFCE
Avatar du membre
Junichirô
Membre actif
Membre actif
Messages : 872
Enregistré le : 26 avr. 2016, 01:10
Localisation : Baillif (Guadeloupe)
Contact :
Status : Hors ligne

Mise à niveau sans problème comme d'habitude. Et on retrouve synaptic sous gnome.
“Lorsque vous avez éliminé l’impossible, ce qui reste, si improbable soit-il, est nécessairement la vérité.”
Avatar du membre
piratebab
Site Admin
Site Admin
Messages : 3756
Enregistré le : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors ligne

Sur mon install, testing les mise à jour auto ne se faisait plus , c'est à dire que la mise à jour des dépots ne fonctionnait plus en arrière plan.
Un petit apt update en console, répondre oui aux questions proposant les mises à jour du sources.list, et c'est reparti.
Avatar du membre
genpashiro
Membre
Membre
Messages : 143
Enregistré le : 25 sept. 2018, 15:07
Localisation : Douai, Nord
Status : Hors ligne

@dezix du coup, si on ne met pas de dépôt sid, on ne peut pas installer VirtualBox ?

je suis pour l'instant resté sur la 10.10
Avatar du membre
dezix
Modérateur
Modérateur
Messages : 1491
Enregistré le : 04 juin 2016, 14:50
Status : Hors ligne

Pour ce que j'en sais,

Debian -- Résultats de la recherche de paquets -- virtualbox
affiche :
Paquet virtualbox

stretch-backports (misc): x86 virtualization solution - base binaries [contrib]
5.2.24-dfsg-4~bpo9+1: amd64 i386

sid (unstable) (misc): x86 virtualization solution - base binaries [contrib]
6.1.26-dfsg-3: amd64

Sinon, il doit y avoir un dépôt tiers sur le site de l'éditeur à rajouter aux sources.

Perso, j'évite ce genre de solution, mais c'est une de mes maniaqueries. :003:
Debian stable - XFCE
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3474
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

Junichirô a écrit : 19 août 2021, 01:45 Mise à niveau sans problème comme d'habitude. Et on retrouve synaptic sous gnome.

Oui l'upgrade est très fluide.
C'est la première fois que je migre plusieurs serveurs sans aucune intervention particulière post upgrade!
Depuis Sarge...

J'en ai même profité pour passer à nftables, enfin... :blush:
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Avatar du membre
genpashiro
Membre
Membre
Messages : 143
Enregistré le : 25 sept. 2018, 15:07
Localisation : Douai, Nord
Status : Hors ligne

Moi, ça m'a flingué le driver du dongle realtek wifi sur mon portable lenovo, il a fallu recompiler à partir d'une source trouvé sur un github, c'était pas insurmontable 😚

nftables, un rapport avec iptables ?
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3474
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

Salut,
genpashiro a écrit : 05 sept. 2021, 11:59 Moi, ça m'a flingué le driver du dongle realtek wifi sur mon portable lenovo, il a fallu recompiler à partir d'une source trouvé sur un github, c'était pas insurmontable 😚
Shit happens...
Bien joué d'avoir réussis à contourner, ce n’est pas toujours évident avec les dongle wifi un peu exotiques.

nftables, un rapport avec iptables ?
Oui,
nftables est à terme le remplaçant d'iptables.
nftables is the default and recommended firewalling framework in Debian, and it replaces the old iptables (and related) tools.
C'est une question de temps.
nftables est plus simple à utiliser et plus puissant qu'iptables.

Mais je ne vais pas m'étendre, je sais que @pascalhambourg est dans les parages, il sera plus précis s'il il a envie d'intervenir.

J'ai fait le pas nftables + firewalld et franchement je ne regrette pas, c'est presque enfantin.
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Répondre