Smartmontools : recevoir email de notification Le sujet est résolu

Ubuntu ; MX Linux ; Linux Mint ; etc.
Répondre
Kaphey
Membre
Membre
Messages : 19
Enregistré le : 26 janv. 2020, 10:55
Status : Hors ligne

26 janv. 2020, 11:28

Bonjour et merci de m'accueillir sur ce forum :smile:

Depuis plusieurs jours je fais des tests avec Smartmontools après avoir suivi cet article du wiki : https://wiki.debian-fr.xyz/Smartmontools

J'ai effectué le test suivant et je reçois bien un mail.
Par défaut, vous ne serez alerté que des erreurs, mais vous avez peut-être envie de tester la fonction...

Remplacez "-M exec /usr/share/smartmontools/smartd-runner" par “-M test” à la fin de vos lignes de configuration

Redémarrez smartd
Je ne comprends pas si on reçoit un mail lorsque le disque présente des problèmes ou si de nouveaux problèmes sont détectés ?

J'aimerais bien reçevoir un mail même s'il n'y a pas de nouvelles erreurs car mes disques durs sont en mauvais état.

Code : Tout sélectionner

sda :
SMART overall-health self-assessment test result: PASSED
 5 Reallocated_Sector_Ct   0x0033   100   100   010    Pre-fail  Always       -       16
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       0
187 Reported_Uncorrect      0x0032   050   050   000    Old_age   Always       -       50

sdb :
SMART overall-health self-assessment test result: PASSED
 5 Reallocated_Sector_Ct   0x0033   100   100   010    Pre-fail  Always       -       56
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       0
187 Reported_Uncorrect      0x0032   001   001   000    Old_age   Always       -       104
Et si possible que ce mail arrive dans ma propre boite mail plutôt que celle du système.

Pouvez-vous m'aider pour les commandes qui vont bien svp ?
Mon OS est Linux Mint Cinnamon 19.2 installé sur sda, les sauvegardes sont sur sdb.

Merci beaucoup
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

26 janv. 2020, 14:56

Salut et bienvenue! :006:

Je te suggère d'utiliser msmtp (Si le paquet est disponible dans ta Cinnamon 19.2):

Code : Tout sélectionner

apt install msmtp msmtp-mta

Code : Tout sélectionner

# nano ~/.msmtprc
Avec ceci (à adapter naturellement):

Code : Tout sélectionner

defaults
port 587
tls on
tls_trust_file /etc/ssl/certs/ca-certificates.crt

account DEFAUT
host mail.domaine.tld
from tech@domaine.tld
auth on
user tech@domaine.tld
password xxxxxxxxxxxxxxxxxxxxxx

account default : DEFAUT

On teste ainsi:

Code : Tout sélectionner

# msmtp toi@tondomaine.com
Hello,
C'est un test.
Et on envoie le mail avec un CTRL + D


Je l'utilise ainsi dans mes scripts (ça ne devrait pas être compliqué d'adapter pour smartmontools):

Code : Tout sélectionner

msmtp toi@tondomaine.com  < /tmp/resultats.txt
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Kaphey
Membre
Membre
Messages : 19
Enregistré le : 26 janv. 2020, 10:55
Status : Hors ligne

26 janv. 2020, 17:34

Merci pour ton accueil et ta réponse :)

Je viens de vérifier, le paquet est disponible dans les dépôts, je vais essayer :smile:

J'aurais bien aimé aussi recevoir un mail après chaque test, même s'il n'y a pas de nouvelles erreurs sur les disques.

Tu aurais une idée de comment adapter la commande

Code : Tout sélectionner

/dev/sda -a -d sat -o on -S on -s (S/../.././01|L/../../1/03) -m root -M exec /usr/share/smartmontools/smartd-runner
afin de recevoir un mail à chaque test ?

Comme je ne reçois rien sauf si je fais ça :
Remplacez "-M exec /usr/share/smartmontools/smartd-runner" par “-M test” à la fin de vos lignes de configuration

je suppose qu'un mail n'est envoyé qu'en cas de nouvelles erreurs, mais comme mes disques sont mal en point, je voudrais être certaine que le test est bien effectué, tandis que là je ne sais pas trop ce qu'il en est.

Encore merci
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

27 janv. 2020, 07:31

Salut,

SI tu reçois un mail de test tout est bien configuré.
Il faut lancer un test manuel et vérifier le résultat dans la console si tu souhaites être certain de la santé de tes disques.

Tu as modifié le fichier /etc/smartmontools/run.d/10mail pour passer par msmtp ?
Ça m'intéresserait de voir la modification...
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Kaphey
Membre
Membre
Messages : 19
Enregistré le : 26 janv. 2020, 10:55
Status : Hors ligne

27 janv. 2020, 17:03

Bonjour,
lol a écrit :
27 janv. 2020, 07:31
Tu as modifié le fichier /etc/smartmontools/run.d/10mail pour passer par msmtp ?
Je viens d'installer le logiciel et suis partie à la recherche du numéro de port à renseigner.
Pour Gmail, le port SMTP est le 465

Mais je ne suis pas sûre de ce qu'il faut adapter, si tu pouvais me donner un petit coup de main, ça serait sympa :023: :

Code : Tout sélectionner

defaults
port 465
tls on
tls_trust_file /etc/ssl/certs/ca-certificates.crt

account DEFAUT
host mail.domaine.tld (là je ne sais pas quoi mettre)
from moi@gmail.com
auth on
user moi@gmail.com
password monMotDePasse

account default : DEFAUT
Comme je suis plutôt débutante, tu as bien fait de préciser qu'il faudra ensuite modifier le fichier /etc/smartmontools/run.d/10mail pour passer par msmtp :icon_e_wink:
Tu vas être déçu par ma façon de faire la modification, car je n'en ai aucune idée :003:

Voilà ce qu'il contient :

Code : Tout sélectionner

#!/bin/bash -e

# Send mail if /usr/bin/mail exists
if ! [ -x /usr/bin/mail ]; then
	echo "Your system does not have /usr/bin/mail.  Install the mailx or mailutils package" 
	exit 1
fi

input=$1


shift

/usr/bin/mail "$@" < $input
J'avais installé mailutils pour les mails en interne, je n'aurai donc pas le message "Your system does not have /usr/bin/mail. Install the mailx or mailutils package"

Que faut-il modifier ? :blush:

Merci pour ton aide :)
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

28 janv. 2020, 07:36

Salut,
Si tu utilise gmail comme smtp tu risque de galérer un peu, mais bon...

1) Il faut désactiver l'utilisation des applications "moins sécurisées" dans google...
https://myaccount.google.com/lesssecureapps
Capture_2020-01-28_09-25-33.png

2) Le fichier ~/.msmtprc doit contenir ceci

Code : Tout sélectionner

defaults
port 587
tls on
tls_trust_file /etc/ssl/certs/ca-certificates.crt
tls_starttls on
tls_certcheck on
logfile ~/.msmtp.log

account gmail
host smtp.gmail.com
from toi@ton_domaine.tld (Tu peux mettre n'importe quoi comme email)
auth on
user lol@gmail.com
password Ton_mot_de_pass_en_clair

# Set a default account
account default : gmail
Le coup du mot de passe en clai n'est pas très cool.
Au minimum il faut mettre un chmod 600 sur le fichier:

Code : Tout sélectionner

# chmod 600 ~/.msmtprc
Mieux, il faut utiliser gpg: https://wiki.debian.org/msmtp


3) Tu teste comme je te l'ai expliqué:
Tu entre msmtp lol@gmail.com
Tu tape Hello, + ENTER
Tu tape Ceci est un mail de test! + ENTER
Tu tape CTRL + D pour faire partir le mail de test.

Code : Tout sélectionner

# msmtp lol@gmail.com
Hello,
Ceci est un mail de test!
Quand tu tape CTRL + D cela envoie le mail.
Tu dois avoir confirmation dans les logs:

Code : Tout sélectionner

# cat ~/.msmtp.log 
janv. 28 09:23:17 host=smtp.gmail.com tls=on auth=on user=lol@gmail.com from=toi@ton_domaine.tld recipients=lol@gmail.com mailsize=93 smtpstatus=250 smtpmsg='250 2.0.0 OK  1580192596 64sm18104950pfd.48 - gsmtp' exitcode=EX_OK
msmtp étant configuré tu peux passer à smartmontools.
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

28 janv. 2020, 07:53

Et voici donc la suite pour smartmontools...

Il suffit de modifier /etc/smartmontools/run.d/10mail ainsi:

Code : Tout sélectionner

#!/bin/bash -e

input=$1
shift

/usr/bin/msmtp lol@gmail.com  < $input
Fais un backup avant:

Code : Tout sélectionner

cp /etc/smartmontools/run.d/10mail /etc/smartmontools/10mail.bak
Ensuite modifie ton fichier /etc/smartd.conf ainsi: (Remplace -M exec /usr/share/smartmontools/smartd-runner par -M test)

Code : Tout sélectionner

/dev/sda -a -o on -S on -s (S/../.././01|L/../../1/20) -m lol@gmail.com -M test

Redémarre smartmontools (/etc/init.d/smartmontools restart ou service smartmontools restart ou systemctl restart smartmontools) et vérifie ta boite mail.
Ça devrait fonctionner.
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Kaphey
Membre
Membre
Messages : 19
Enregistré le : 26 janv. 2020, 10:55
Status : Hors ligne

28 janv. 2020, 19:37

Bonsoir et merci beaucoup de m'avoir mâché le travail, je n'y serais pas arrivée.

Pas très rassurée pour la sécurité de mon compte Gmail si j'active cette option, j'ai choisi une adresse gmx à la place, le port SMTP est 587.

Code : Tout sélectionner

defaults
port 587 
tls on
tls_trust_file /etc/ssl/certs/ca-certificates.crt

tls_starttls on
tls_certcheck on
logfile ~/.msmtp.log  

account gmx   
host smtp.gmx.com
from mia@pc5.com     
auth on
user moi@gmx.fr   
password xxxxxxxxxxx
J'ai mis le chmod 600 sur le fichier, pour l'instant, je verrai plus tard pour le lien :icon_e_wink:

Code : Tout sélectionner

mia@mia-PC5:~$ sudo msmtp moi@gmx.fr
Hello,
Ceci est le mail de test vers gmxmsmtp: account default not found in /home/mia/.msmtprc
mia@mia-PC5:~$ 
Il y a un petit problème, mais j'y suis presque, j'ai du cafouiller entre le .com et le .fr
Je n'ai plus le temps aujourd'hui, je vérifierai tout demain.

Je n'avais pas vu la suite pour smartmontools, ça sera pour demain aussi.

Encore merci pour la peine que tu te donnes à m'expliquer comment faire :smile:
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

29 janv. 2020, 09:23

Ok @Kaphey, tiens nous au jus! :006:
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Kaphey
Membre
Membre
Messages : 19
Enregistré le : 26 janv. 2020, 10:55
Status : Hors ligne

29 janv. 2020, 15:41

Bonjour,

Ça avance, mais vraiment tout doucement, désolée :banana_stoner:

Mon adresse gmx fini bien en .fr, je me suis envoyée un mail en .com, il n'arrive pas.

Il semble maintenant y avoir un problème de sécurité

Code : Tout sélectionner

mia@mia-PC5:~$ sudo msmtp moi@gmx.fr 
[sudo] Mot de passe de mia :             
essai8
msmtp: TLS certificate verification failed: the certificate owner does not match hostname smtp.gmx.com
msmtp: could not send mail (account default from /home/mia/.msmtprc)
J'ai aussi tenté ma chance en remplaçant smtp.gmx.com par mail.gmx.com car j'avais un doute en regardant les paramètres de gmx
Image

Code : Tout sélectionner

defaults
port 587
tls on
tls_trust_file /etc/ssl/certs/ca-certificates.crt

tls_starttls on
tls_certcheck on
logfile ~/.msmtp.log

account gmx
host mail.gmx.com
from mia@pc5.com  
auth on
user moi@gmx.fr 
password xxxxxxxxxx

# Set a default account
account default : gmx
Cette fois, c'est peut-être l'adresse de l'expéditeur qui ne convient pas au serveur de gmx :

Code : Tout sélectionner

mia@mia-PC5:~$ sudo msmtp moi@gmx.fr 
essai9
msmtp: envelope from address mia@pc5.com not accepted by the server
msmtp: server message: 550-Requested action not taken: mailbox unavailable
msmtp: server message: 550 Sender address is not allowed.
msmtp: could not send mail (account default from /home/mia/.msmtprc)
mia@mia-PC5:~$ 
:006:
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

29 janv. 2020, 17:12

Salut,

Code : Tout sélectionner

msmtp: envelope from address mia@pc5.com not accepted by the server
msmtp: server message: 550-Requested action not taken: mailbox unavailable
msmtp: server message: 550 Sender address is not allowed.
msmtp: could not send mail (account default from /home/mia/.msmtprc)
Le serveur n'accepte pas l'adresse de l'expéditeur: mia@pc5.com

Essaye de remplacer mia@pc5.com par moi@gmx.fr dans /home/mia/.msmtprc

Par contre en production il faudra utiliser /root/.msmtprc
Samrtmontools n'ira pas chercher la conf dans ton /home.
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Kaphey
Membre
Membre
Messages : 19
Enregistré le : 26 janv. 2020, 10:55
Status : Hors ligne

30 janv. 2020, 09:40

Bonjour,

Toujours pas :unknw:

Code : Tout sélectionner

mia@mia-PC5:~$ sudo msmtp mamath@gmx.fr 
[sudo] Mot de passe de mia :             
testJeudi1
msmtp: envelope from address moi@gmx.fr not accepted by the server
msmtp: server message: 550-Requested action not taken: mailbox unavailable
msmtp: server message: 550 Sender address is not allowed.
msmtp: could not send mail (account default from /home/mia/.msmtprc)
mia@mia-PC5:~$ 
Tu mets une adresse qui n'existe pas et ça passe pour toi ?
Je vais essayer avec une adresse valide dans from des fois que...
lol a écrit :
29 janv. 2020, 17:12
Par contre en production il faudra utiliser /root/.msmtprc
Ok merci pour l'info, dès que je reçois quelque chose, je change :icon_e_wink:
Kaphey
Membre
Membre
Messages : 19
Enregistré le : 26 janv. 2020, 10:55
Status : Hors ligne

30 janv. 2020, 09:49

J'ai mis la même adresse gmx dans from et dans user, j'ai enfin reçu un mail ! :yahoo:
Mais vide de contenu (et de sujet mais ça c'est normal je pense)
On avance :dirol:

Edit : avec mon adresse gmail dans from, je reçois à nouveau le messasge d'erreur

Code : Tout sélectionner

mia@mia-PC5:~$ sudo msmtp moi@gmx.fr 
essai avec boite gmail
msmtp: envelope from address moi@gmail.com not accepted by the server
msmtp: server message: 550-Requested action not taken: mailbox unavailable
msmtp: server message: 550 Sender address is not allowed.
msmtp: could not send mail (account default from /home/mia/.msmtprc)
mia@mia-PC5:~$ 
avec une adresse free, même message

edit 2 :
Je viens de remarquer une chose :
je peux mettre n'importe laquelle de mes adresses dans la commande sudo msmtp
ça arrive bien à l'adresse gmx
donc from et user doivent être identiques

Pour le corps de texte vide, c'est curieux, j'ai une redirection de cette adresse vers mon adresse gmail, je reçois donc une copie du mail gmx dans gmail, et là le corps de texte y est bien ! :icon_twisted:
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

30 janv. 2020, 13:30

Hello,

Content que tu ai enfin un résultat!

Je ne sais pas trop pourquoi le corps du mail est vide... GMX ne gère que les mails en html ? :icon_confused:
Le sujet c'est normal, mais tu devrais avoir au moins

Code : Tout sélectionner

Hello,
Ceci est un mail de test!
Tu devrais peut-être passer à la conf de smartmontools maintenant.
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Kaphey
Membre
Membre
Messages : 19
Enregistré le : 26 janv. 2020, 10:55
Status : Hors ligne

30 janv. 2020, 14:57

Re,

Je viens de faire une découverte qui me laisse perplexe :crazy:

Je peux envoyer un mail à toutes mes adresses, free, gmail, etc... !!!

Il suffit de lancer la commande avec l'adresse adéquate :

Code : Tout sélectionner

sudo msmtp L_ADRESSE_A_LAQUELLE_ENVOYER_LE_MESSAGE 
et ça fonctionne, même avec gmail sans que j'ai eu besoin de désactiver l'utilisation des applications "moins sécurisées" dans google.

Il semblerait l'adresse gmx serve d'expéditeur et non de destinataire. :icon_idea:

Pour mémoire, voici le fichier tel qu'il doit être paramétré pour que ça fonctionne :

Code : Tout sélectionner

mia@mia-PC5:~$ sudo cat .msmtprc
[sudo] Mot de passe de mia :             
defaults
port 587
tls on
tls_trust_file /etc/ssl/certs/ca-certificates.crt

tls_starttls on
tls_certcheck on
logfile ~/.msmtp.log

account gmx
host mail.gmx.com
from moi@gmx.fr
auth on
user moi@gmx.fr
password xxxxxxxxxx

# Set a default account
account default : gmx

mia@mia-PC5:~$ 
Le contenu du mail reçu est un peu spécial, j'espère que ça se passera bien pour la surveillance des disques.
Je le mets entre balises code pour que ça prenne moins de place, mais c'est bien le contenu du message.

Code : Tout sélectionner

essai vers mia2free
Message-ID: <1MFKKX-1imSPQ19PF-00Fmto@mail.gmx.com>
X-Provags-ID: V03:K1:0BtMlItWkkTB8+13tuIaFHC9E4WIxaxBte6diypAFjxJQGwZKfe
 +fruMLHneEcjtWnvrSYEf1shMEUieGgzh0FLkUOp5qkiVWTVrpofJJjEXCT4Q7fLamrDmGO
 LLHUHgiMvNZrYI6Bf7QyEV67AJ4Xb/y3oTLDbPC07vzKvZgocFeRAbUbK2wcvC0U2N1RRaw
 d4x5a4d0saXhbMCctgKZw==
X-Spam-Flag: NO
X-UI-Out-Filterresults: notjunk:1;V03:K0:ruyWbMo5FuI=:LcCictHgMULDZujFm2Vji1
 lFiTu8/R2ivTXFkCCFkRqAb6bOGXumJG/UxCOOxzrDjsNnp1BQzecSfLrHkBavKlFVcMqGn0o
 cQHi/B63LCKs6aP1yL83parxuOAG7NaPsQwRuZoJjaONlBzFk5Q4HW1luj6Zc6++MHSjyVoz8
 g8N3OxBpnUZJjPfGgOQDIkA0cLhuQZDhNTvWV19TzcuY1SLBCFKQbs0WIh6iU5twm6qheC+uu
 +9Udwx/Dpoi7PcOEGeMgV+F8N6PJUM4W2dHrFkJ13ndEvqGISEG7oEDj8FCq/ZWXIwI98QI8c
 oAxAI5ou5aw4hMSPN07ZLKKAEMR5q5TdyvVAMIaVuQmLBgXbybMI+juUXqhqg331KFWypeWeI
 DRR0gZw8XiRpHmeqVcw91/0E17Ryl3eMGZDjB6qiX+w0rzC0rBHc+UccAaVM3Iav9lD4KxK+x
 gdnYsW/Y0px24A4n555k7zHZFTIX0CaWPr2W0fXlkFTfYQUBmPZhQyqFHecb+y1bo1H7uYP4d
 gYkcBgijoszZL2Z+jqWF6pD8S3/KnWRWRWdcEv3ew/ivwg82tmO9Z51ITkvelym/yn8AoDofK
 OgD9wVIR422/yhCv2sCJm0XEeL9r7hqabk9upfG0T+gANBEU4YJXGkJf41ULsxXccghi+7muI
 J3i4ovc992kQv9JgLWVy9eHCBaTCeLhpktSlOvVkm28SffbAKyWeyiW5cKZbtEU7q3Qa+i0iK
 jMI/cYKWQjUoAdKTGUSWsKPOmxUVb873kaG8HIJ+ZRBOw2ie1z9HTiKage3o2/mQDNSZnm8WC
 wfXxyzqZN6xZJdpSk99LlcYWQ7hOG6910beYnfAIiAxA5s8nDIDKzUL7BWDKo1g275STZQdXA
 SPccOOjcGrxQdwGK0/f1vx5Xx2CF2ey8omVpTR3bw8zUV8s2yI/gpklU5YcSf36G/G7wWs7RE
 k1mw2ZtSuuwtswV/2s28cLbR4MkXCHj3kk1GtqqyhPfVKXLpD3WmELLFA1HrRDglfQjsGtKnT
 iXrVP/thIpXy5/g4rPB3S4UaHBLLwkrsdHtgwwiDetQ7obvAo31hC74rdSCVkzUZfb2x9FyFy
 sBpgcXKwwOA/pDiE9kV333aMi8YxvzGAgYaCNzP5PUck7IKUlU5IR1E01SJRwpBOjEZivqfJ0
 pwiDrvqd+exNc1k9Q1yB6J7I0EGtnn6sEiC/iA/XX//Zp2Mc7dKGEEMV95MhsKeYxqqoxf26P
 y5z3nbACTlPZzIvp2
J'ai ensuite copié le fichier msmtprc de mon home vers celui de root.
Remis le chmod 600, je ne sais pas si c'était nécessaire dans root qui doit avoir un accès très protégé.

Je passe à la configuration de smartmontools demain, faut que j'aille bosser :wink:

Merci pour ton suivi :smile:
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

30 janv. 2020, 15:21

Kaphey a écrit :
30 janv. 2020, 14:57
Il suffit de lancer la commande avec l'adresse adéquate :
...
Il semblerait l'adresse gmx serve d'expéditeur et non de destinataire. :icon_idea:
Je suis nul et archi-nul de ne pas avoir vu la confusion, désolé. :blush:
Oui, tu dois configurer l'accès au SMTP (Donc les identifiants de l'expéditeur. Hôte smtp, adresse mail et mot de passe).
Si le SMTP accepte de te parler (D'envoyer tes emails) tu peux envoyer à qui tu le souhaites... Même à gmail bien sur. :wink:

Kaphey a écrit :Le contenu du mail reçu est un peu spécial, j'espère que ça se passera bien pour la surveillance des disques.
C'est le code source que tu nous montres.
Comment as tu ouvert le mail ?

Kaphey a écrit :J'ai ensuite copié le fichier msmtprc de mon home vers celui de root.
Remis le chmod 600, je ne sais pas si c'était nécessaire dans root qui doit avoir un accès très protégé.
Non, très bon reflexe. :good:

Kaphey a écrit :Je passe à la configuration de smartmontools demain, faut que j'aille bosser :wink:
Merci pour ton suivi :smile:
:drinks:
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Kaphey
Membre
Membre
Messages : 19
Enregistré le : 26 janv. 2020, 10:55
Status : Hors ligne

31 janv. 2020, 12:24

Bonjour :icon_biggrin:

Tu n'as surtout pas à être désolé, je suis vraiment contente de trouver de l'aide, depuis le temps que je galérais avec ça :good:

Pour le code source qui apparaît dans les mails :

Depuis le webmail de gmx, le corps de texte est vide,
Mais quand je clique sur le i d'information, plein de renseignements apparaissent, dont le corps du message que j'ai écris, et le code source.

Depuis gmail et free, c'est différent, le corps du message et le code sources apparaissent sans que je n'ai rien à faire.

Pour le fichier 10mail :

J'ai une ligne en plus

Code : Tout sélectionner

# Send mail if /usr/bin/mail exists
if ! [ -x /usr/bin/mail ]; then
        echo "Your system does not have /usr/bin/mail.  Install the mailx or m$
        exit 1
fi
Je ne savais pas s'il fallait la supprimer, comme /usr/bin/mail existe, j'ai laissé.

Pour la ligne

Code : Tout sélectionner

/usr/bin/msmtp lol@gmail.com  < $input
Quand j'ouvre ce fichier, par défaut c'est

Code : Tout sélectionner

/usr/bin/mail ...
J'ai donc modifié pour mettre msmtp.

Je fais ces remarques pour avoir des pistes en cas où ça ne fonctionnerait pas :icon_e_wink:

Pour le fichier smartmontools :

Je ne sais pas ce qu'il se passe, lorsque je veux l'éditer, nano me dit qu'il est déjà ouvert par root.
Je pensais qu'en redémarrant ça rentrerait dans l'ordre, mais non.

Image

Je ne vois pas ce PID en faisant un top.
J'ai édité ce fichier de nombreuses fois auparavant sans avoir ce message :unknw:
J'ai donc fini par dire Oui

#DEVICESCAN -d removable -n standby -m root -M exec /usr/share/smartmontools/smartd-runner
/dev/sda -a -d sat -o on -S on -s (S/../.././13) -m moi@gmx.fr -M test
/dev/sdb -a -d sat -o on -S on -s (S/../../6/12) -m mia -M exec /usr/share/smartmontools/smartd-runner

J'ai redémarré le service, plus qu'à attendre 13h pour voir si ça fonctionne pour sda :wink:
Quoique, quand je cherchais comment mettre des minutes, j'ai cru comprendre que 13 ne veut pas dire 13 heures, mais entre 13 et 14 h
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

31 janv. 2020, 13:13

Salut,

Le fichier /etc/smartmontools/run.d/10mail doit absolument au moins contenir ceci:

Code : Tout sélectionner

#!/bin/bash -e
input=$1
shift
/usr/bin/msmtp TOI@GMAIL.COM  < $input
Kaphey a écrit :Je ne savais pas s'il fallait la supprimer, comme /usr/bin/mail existe, j'ai laissé.
Ce test ne sert plus à rien, tu peux tout virer... ou remplacer mail par msmtp... :wink:

Code : Tout sélectionner

# Send mail if /usr/bin/msmtp exists
if ! [ -x /usr/bin/msmtp ]; then
        echo "Your system does not have /usr/bin/msmtp.  Install the msmtp package" 
        exit 1
fi
Kaphey a écrit :J'ai donc fini par dire Oui
Comme tu es la seule à travailler sur cette machine ça n'a pas d'importance.

Kaphey a écrit :J'ai redémarré le service, plus qu'à attendre 13h pour voir si ça fonctionne pour sda
Non, normalement le mail de test part immédiatement après le redémarrage du service.
Si ce n'est pas le cas c'est qu'il y a un schmilblick quelque part...

Kaphey a écrit :
31 janv. 2020, 12:24
j'ai cru comprendre que 13 ne veut pas dire 13 heures, mais entre 13 et 14 h
A partir de 13h surtout.
En fonction du test choisit ça peut prendre du temps. Et le rapport arrive en fin de scan!
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Kaphey
Membre
Membre
Messages : 19
Enregistré le : 26 janv. 2020, 10:55
Status : Hors ligne

31 janv. 2020, 13:47

Bon, il a eu largement le temps de faire le test et je n'ai rien reçu :unknw:

Le fichier /etc/smartmontools/run.d/10mail contient bien ce que tu mentionnes .
Voilà son contenu (je n'avais pas l'info pour remplacer mail par msmtp dans la partie inutile) :

Code : Tout sélectionner

mia@mia-PC5:~$ cat /etc/smartmontools/run.d/10mail
#!/bin/bash -e

# Send mail if /usr/bin/mail exists
if ! [ -x /usr/bin/mail ]; then
	echo "Your system does not have /usr/bin/mail.  Install the mailx or mailutils package" 
	exit 1
fi

input=$1
shift

/usr/bin/msmtp moi@gmx.fr < $input

mia@mia-PC5:~$ 
Les espaces entre les lignes sont autorisés je crois.

Le mail arrivait pourtant bien dans la boite mail du système quand j'avais remplacé "-M exec /usr/share/smartmontools/smartd-runner" par “-M test” :icon_confused:
Avatar du membre
lol
Site Admin
Site Admin
Messages : 3302
Enregistré le : 04 avr. 2016, 12:11
Localisation : Madagascar
Contact :
Status : Hors ligne

31 janv. 2020, 14:59

Kaphey a écrit :
31 janv. 2020, 13:47
Le mail arrivait pourtant bien dans la boite mail du système quand j'avais remplacé "-M exec /usr/share/smartmontools/smartd-runner" par “-M test” :icon_confused:

Mais... :good: :yahoo: :good: C'est bon alors. Smartmontools n'envoie un rapport que si il detecte un problème!


Pour être certaine fait un test manuel et regarde le résultat

Code : Tout sélectionner

# smartctl -t short /dev/sda
Puis regarde le résultat quelques minutes plus tard:

Code : Tout sélectionner

# smartctl -a /dev/sda

Les points suivants sont à regarder de près:

Code : Tout sélectionner

1 Raw_Read_Error_Rate
13 Read_Soft_Error_Rate
187 Reported_Uncorrect
195 Hardware_ECC_Recovered
197 Current_Pending_Sector
199 UDMA_CRC_Error_Count
Si les RAW value de ces tests sont à 0 il n'y a pas à s'inquieter plus que ça.
De toute façon SI smartd a envoyé le mail de test, soit CERTAINE qu'il enverra un mail en cas de "failure"
Debian stable. XFCE.
C'est curieux chez les marins ce besoin de faire des phrases (Les tontons flingueurs).
Répondre